Welcome
Send Feedback

VoIP Video SIP SDK

Crystal clear and crisp video collaboration at the glance

The Conaito VoIP Video SIP SDK provides a powerful and highly versatile solution to add quickly SIP (Session Initiation Protocol) based dial and receive video phone calls features in your software applications. It accelerates the development of SIP/RTP compliant soft phone with a fully-customizable user interface and brand name.

It contains a high performance voip video conferencing client capable of delivering crystal clear sound and crisp video even for both low and high-bandwidth users and SIP compatible devices (hardware and software). It enables a worldwide communication over the internet or intern networks either and delivers superior voice and video quality by integrating digital voice processing features including auto gain controller (AGC), acoustic echo suppression (AES) and noise suppression. It supports multiple lines, multi-party voice conference, call hold, call forwarding and transfer, DTMF, Packet Loss Concealment (PLC), adaptive jitter buffer, record and playing WAV or MP3 and much more!

VoIP Video SIP SDK has all the same functionality as Standard VoIP SIP Client SDK and additionally provides video stream support on the basis of H.263, H.263+, H.261, H.264, VP8 WebM and Theora codecs. It is possible to control and disable video when you do not need it.

The VoIP Video SIP SDK is based on IETF standards (SIP, RTP, STUN, TURN, ICE etc.), so it should be compatible with other standard based products such as: SER, Sip EXpress, OpenSER and Asterisk.

New features of the version 1.3:

  • Recording voice conversation into mp3 (.mp3) file (without or ID3v2.1 tag supported)
  • Playing mp3 (.mp3) files to the remote end (without or ID3v2.1 tag supported)
  • VP8 WebM video codec support
  • Codec selection and sorting
  • Change User Agent (UA) with Identity property
  • Webdemo sample with video support
  • Video start/stop function including AutoStartSendingVideo
  • Fixed VB6 example bug
  • Fixed STUN event bug
  • Fixed no Webcam bug
  • Fixed Outbound Proxy bug
  • Additional minor improvements as well file size optimization and performance of the SDK

New features of the version 1.1/1.2:

  • Supported selectable CIF (Common Intermediate Format)
  • Multiple sip accounts registration support (unlimited)
  • H264 video codec support
  • Improved video conference
  • Improved NAT Traversal for video conferences
  • Max Bitrate for video stream (VideoMaxBitrate) - free configurable
  • Many minor improvements

Key features of the VoIP Video SIP SDK:

  • Easily make and receive SIP (Session Initiation Protocol) based video phone calls through any SIP gateway or SIP compliant IP-Telephony service provider
  • VoIP video conferencing with crystal clear sound and crisp video even for both low and high-bandwidth users
  • Supported audio codec?s: G729, G723, G711 A-Law, G711 U-Law, Speex, Speex-wb, GSM6.10 and iLBC
  • Supported video codec?s: H263, H263+, H261, H264, VP8 WebM and Theora codec
  • Open standards-based and interoperable with all of the major equipment vendors
  • UDP and TCP support
  • Multi-party voice conference support (Conference split and join, locally mixed conferences)
  • Multi-line support (multiple simultaneous calls)
  • Multiple sip accounts registration support (unlimited)
  • SIP Instant/Chat Messaging with send/receive controlling
  • Integrated STUN, TURN and ICE NAT Traversal
  • Comes with sample SIP Proxy Server to provide in bundle with the Conaito SIP Client a ready up own SIP VoIP and Instant Messaging network solution.
  • P2P support for directly connections between 2 SIP clients without SIP Server
  • Outbound proxy server support
  • Line Hold/Un-hold support
  • Call forwarding and rejection
  • Call transfer support
  • Select media input/output devices - on-the-fly (as well during a conversation/conference)
  • Microphone and Speaker volume with Mute (including level indicator)
  • Auto-answer
  • DND (Do Not Disturb)
  • Adaptive Jitter buffer
  • PLC (Packet Lost Concealment)
  • AGC (auto gain controller)
  • AES (Acoustic echo cancellation or suppression)
  • Noise cancellation or suppression
  • DTMF tones support (generation/detection)
  • Recording voice conversation into PCM WAVE and mp3 (.wav and .mp3) file
  • Playing PCM WAVE and mp3 (.wav and .mp3) files to the remote end
  • Audio file memory cache
  • Extended SIP URL functions
  • Comes as ActiveX control (Webdemo with ready-up signed CAB included) and native DLL with .NET Interface (no ActiveX registration necessary) for easy usage in .NET development
  • Registration on SIP Server (SIP Registrar)
  • Log file on/off setting
  • Keep-alive packets to NAT/firewall
  • Fully-customizable user interface
  • Production-ready Microsoft Authenticode Certificate certified
  • Works with all kind of Internet connections
  • Friendly to NAT and other firewalls
  • Royalty free licensing
  • No Yearly/Monthly fee
  • Very easy to incorporate
  • SDK comes in bundle with ActiveX control (Webdemo with ready-up signed CAB included), native DLL with .NET Interface for easy usage in .NET development (no ActiveX registration necessary)
  • Fully sample applications for various programming languages such as sample source code for C#, VB.NET, C++, VB 6.0, Delphi and HTML/JavaScript (Webdemo) for ActiveX, DLL and .NET version
  • For .NET framework as well and all development environments with native DLL, .NET or ActiveX support

Easy, familiar, event-driven call control ActiveX, DLL and .NET

  • Easy to use; quick development
  • Powerful .NET Interface for easy .NET development (no ActiveX registration necessary)
  • Support for .NET framework as well and all development environments with native DLL, .NET or ActiveX support
  • Very easy to incorporate

Rich call control feature set

  • Multi-party voice conference support (Conference split and join, locally mixed conferences)
  • Multi-line support (multiple simultaneous calls)
  • SIP Instant messaging
  • Locally mixed conferences
  • Hold/Mute
  • Call transfer and redirect
  • Call forwarding and rejection

Industry leading SIP support

  • RFC3261 compliant SIP stack
  • RFC2833 out-of-band DTMF signaling
  • Integrated STUN, TURN and ICE support

Comprehensive configuration support

  • Select media input/output devices - on-the-fly (as well during a conversation/conference)
  • Configurable ports (RTP, SIP UDP, SIP TCP, STUN, TURN, ICE)
  • SIP proxy

Advanced digital voice processing features

  • AGC (auto gain controller)
  • AES (Acoustic echo cancellation or suppression)
  • Noise cancellation or suppression

… and much more!

Having the above features available makes it simple to develop any type of voip-video-enabled application, like e.g. a SIP video softphone, IVR solution, teaching tool, live support, voip video chat, meeting tool or any other type of application which requires users being able to talk, see each other and type messages to each other.

For Conaito VoIP Video SIP clients to be able to interact with each other they must connect to a SIP gateway or SIP based IP-Telephony service provider.

Just relax!

Please, don't hesitate trying our VoIP Video SIP SDK at once and get yourself, as well as your customers, the exciting experience of easy, fast and high quality standard applications which voip-video-enable your application.

We hope you enjoy the Conaito VoIP Video SIP SDK – A powerful and highly versatile VoIP Video SDK to accelerate development of SIP applications.

Conaito Technologies

http://www.conaito.com


Development environment
Send Feedback

The Conaito VoIP Video SIP SDK provides the documentation, samples and related libraries you need to integrate with other applications or websites.

It runs on Windows and includes a ActiveX, native DLL with .NET interface that can be used from any programming language like Visual C# .NET, Visual Basic .NET, Visual C++ .NET, Visual C++, Visual Basic, Borland Delphi and JavaScript/HTML etc.

The contents and the supported development environments include all of the necessary software components for building systems based on Conaito VoIP Video SIP SDK including documented operational software applications, examples (with source code), explanations as well as necessary service programs, libraries and components.

The supported development environments include:

  • Visual C# .NET
  • Visual Basic .NET
  • Visual C++ .NET
  • ASP.NET
  • ASP, JSP, PHP
  • JavaScript/HTML
  • Visual C++
  • Visual Basic
  • Borland Delphi
  • and all development environments with native DLL, .NET or ActiveX support

System requirements: Operating system: Windows


Licensing
Send Feedback

Software Product: Conaito VoIP Video SIP SDK

Author: Conaito Technologies

Web: http://www.conaito.com

Email: support@conaito.com

The Conaito VoIP Video SIP SDK is available as a trial version which expires after 30 days.

Hassle-free and Simplicity Licensing

We love hassle-free and simplicity licensing, that's why our licenses comes already out of the box with a unlimited deployment, unlimited developer and royalty free distribution license. No more hassle of annual fees and feature limitations because of lower budgets from single developers and small company's. That's it. No catch, no fine print.

Further information can be found in our [image] license section.

Support and Maintenance Subscription

When you buy a license, you automatically get a subscription which entitles you to product updates and support while your subscription is active. The subscription does not affect your license: once you have bought a license, it is yours forever and you can continue to run the licensed version of the product for as long as it is useful to you. If your support and maintenance subscription has expired and you want to continue getting upgrades and hot fixes it can be renewed by purchasing a "Support and Maintenance Subscription Renewal". Learn more

Educators and educational institutions can purchase the Conaito VoIP Video SIP Client SDK at discounted prices. Please [image] contact us for more information.

Pricing of the Conaito VoIP Video SIP SDK can be found in the " [image] Pricing" section of the [image] conaito.com website.

Have a question?

Contact our [image] Live Support, email us at: sales@conaito.com or see our [image] FAQ

Conaito Technologies

http://www.conaito.com


License Agreement
Send Feedback

Software Product: Conaito VoIP Video SIP SDK

Author: Conaito Technologies

Web: http://www.conaito.com

Email: support@conaito.com

This License Agreement defines the terms and conditions under which you (the Licensee) are permitted by conaito.com (Conaito Technologies - the Licensor) to use the Conaito VoIP Video SIP SDK.

1. Definitions

1.1 "Software Development Kit" shall mean and include the software programs and files needed to integrate the Conaito Technologies software components with a software application, including documentation, examples, include files, declarations, source code, utility programs and Conaito VoIP Video SIP SDK components.

1.2 "Application Program" shall mean and include one or more software programs created by the Licensee which use the Conaito Technologies Software components.

2. License grant

2.1 Licensor hereby grants to the Licensee, and Licensee hereby accepts, subject to the terms and conditions set forth in this Agreement, a non-exclusive license to use Software Development Kit subject to the terms of this Agreement. The term "license" as used in this Agreement shall mean and include:

2.1.1 The right to use Software Development Kit under a:

  • Product
  • Service
  • Website (Domain/Url)

2.1.2 The right to redistribute one copy of the Redistributable Software with each copy of the Licensee's Application Program.

3. Restrictions

3.1 In accepting the license granted by Licensor, Licensee agrees that it shall not

3.1.1 Include the Redistributable Software with a product which is itself a software development kit, software component, or software library;

3.1.2 Permit its end-users to redistribute the Redistributable Software;

3.1.3 Loan or rent Software Development Kit to a third party;

3.1.4 Attempt to disassemble or reverse-engineer software included with the Software Development Kit.

3.1.5 Pass the license key, which you have received from Conaito Technologies, to any user.

4. Term of Agreement

4.1 The term of this Agreement shall commence at the time Licensee receives Software Development Kit and shall continue in effect indefinitely unless terminated as specified in Termination of Agreement, below.

5. Termination of Agreement

5.1 The Licensee may terminate this Agreement at any time by destroying all copies of Software Development Kit. In the event of a material default by the Licensee or the Licensee's agent or representative, of any provision of this Agreement, the Licensor may terminate this Agreement upon thirty (30) days written notice, and the Licensee also has thirty (30) days of notice for termination. Upon termination of the Agreement, the Licensee shall either destroy all licensed copies of Software Development Kit, and all backups, or return them to Licensor. This obligation shall survive the termination of this Agreement.

6. Copyright and proprietary information

6.1 Licensee acknowledges that Software Development Kit and all supporting documentation constitute valuable property of Licensor and that all title and ownership rights in Software Development Kit and related materials remain exclusively with Licensor.

6.2 Licensor reserves all rights with respect to Software Development Kit under all applicable laws for the protection of proprietary information, including, but not limited to, trade secrets, copyrights, trademarks, and patents.

6.3 Except as otherwise provided in this Agreement, Licensee shall not cause or permit unauthorized copying, reproduction, or disclosure of any portion of the Software Development Kit or supporting documentation, or the delivery or distribution of any part thereof to any third person or entity, for any purpose whatsoever, without the prior written permission of Licensor. This restriction shall continue to bind Licensee and its agents and representatives beyond the termination of this Agreement.

Indemnification

7.1 Licensee shall indemnify and defend against any and all claims, including claims by third parties or employees of Licensee, which arise directly or indirectly out of Licensee's use or operation of the Software Development Kit or Redistributable Software.

7.2 The Licensor shall indemnify and hold the Licensee harmless from loss, damage, or liability for direct infringement of any United States, Canadian, or European Union member state patent or copyright with respect to the Software Development Kit or Redistributable Software, provided that the Software Development Kit or Redistributable Software have not been modified and provided the Licensor is promptly notified by the Licensee in writing of any infringement and is permitted to defend, compromise or settle such suit or claim, and provided the Licensee gives to the Licensor such available information, assistance and authority as the Licensor deems necessary to the defense of such suit or claim. Should the use of the Software Development Kit or Redistributable Software be enjoined, or in the event that the Licensor desires to minimize its liabilities hereunder, the Licensor shall have the right, at its sole option and expense to:

7.2.1 Procure for the Licensee the right to continue the use of the Software Development Kit or Redistributable Software; or,

7.2.2 Replace the Software Development Kit or Redistributable Software with a non-infringing product; or,

7.2.3 Modify the Software Development Kit or Redistributable Software so that it becomes non-infringing; or,

7.2.4 Refund to the Licensee the purchase price paid, if any, by the Licensee for the Software Development Kit.

DISCLAIMER OF WARRANTY

THIS SOFTWARE DEVELOPMENT KIT IS SOLD "AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OR MERCHANTABILITY. THIS SOFTWARE DEVELOPMENT KIT IS SOLD WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES WHATSOEVER. BECAUSE OF THE DIVERSITY OF CONDITIONS AND HARDWARE UNDER WHICH THIS SOFTWARE DEVELOPMENT KIT MAY BE USED, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. THE USER IS ADVISED TO TEST THE SOFTWARE DEVELOPMENT KIT AND APPLICATIONS MAKING USE OF IT THOROUGHLY BEFORE RELYING ON IT. THE USER MUST ASSUME THE ENTIRE RISK OF USING THE SOFTWARE DEVELOPMENT KIT.

ANY LIABILITY OF SELLER OR MANUFACTURER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF THE PURCHASE PRICE.

Our support team ARE AVAILABLE TO answer your questions.

Conaito Technologies [image] http://www.conaito.com

Third-party licenses

sipXsdp, sipXmedia, sipXport, sipXmediaAdapter

Copyright (C) 2007 SIPfoundry Inc. Licensed by SIPfoundry under the LGPL license.

Copyright (C) 2007 Plantronics Licensed to SIPfoundry under a Contributor Agreement.

Copyright (C) 2007 SIPez LLC. Licensed to SIPfoundry under a Contributor Agreement.

SpanDSP - a series of DSP components for telephony

Copyright (C) 2006 Steve Underwood

plgtones, plgspeex, plgpcmapcmu, plgilbc, plggsm, plgg729, plgg726, plgg722

Copyright (C) 2007-2008 SIPez LLC. Licensed to SIPfoundry under a Contributor Agreement.

Copyright (C) 2007-2008 SIPfoundry Inc. Licensed by SIPfoundry under the LGPL license.

GNU Lesser General Public License, version 2.1

     GNU LESSER GENERAL PUBLIC LICENSE
              Version 2.1, February 1999

 Copyright (C) 1991, 1999 Free Software Foundation, Inc.
     59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
 Everyone is permitted to copy and distribute verbatim copies
 of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL.  It also counts
 as the successor of the GNU Library Public License, version 2, hence
 the version number 2.1.]

               Preamble

  The licenses for most software are designed to take away your
freedom to share and change it.  By contrast, the GNU General Public
Licenses are intended to guarantee your freedom to share and change
free software--to make sure the software is free for all its users.

  This license, the Lesser General Public License, applies to some
specially designated software packages--typically libraries--of the
Free Software Foundation and other authors who decide to use it.  You
can use it too, but we suggest you first think carefully about whether
this license or the ordinary General Public License is the better
strategy to use in any particular case, based on the explanations below.

  When we speak of free software, we are referring to freedom of use,
not price.  Our General Public Licenses are designed to make sure that
you have the freedom to distribute copies of free software (and charge
for this service if you wish); that you receive source code or can get
it if you want it; that you can change the software and use pieces of
it in new free programs; and that you are informed that you can do
these things.

  To protect your rights, we need to make restrictions that forbid
distributors to deny you these rights or to ask you to surrender these
rights.  These restrictions translate to certain responsibilities for
you if you distribute copies of the library or if you modify it.

  For example, if you distribute copies of the library, whether gratis
or for a fee, you must give the recipients all the rights that we gave
you.  You must make sure that they, too, receive or can get the source
code.  If you link other code with the library, you must provide
complete object files to the recipients, so that they can relink them
with the library after making changes to the library and recompiling
it.  And you must show them these terms so they know their rights.

  We protect your rights with a two-step method: (1) we copyright the
library, and (2) we offer you this license, which gives you legal
permission to copy, distribute and/or modify the library.

  To protect each distributor, we want to make it very clear that
there is no warranty for the free library.  Also, if the library is
modified by someone else and passed on, the recipients should know
that what they have is not the original version, so that the original
author's reputation will not be affected by problems that might be
introduced by others.

  Finally, software patents pose a constant threat to the existence of
any free program.  We wish to make sure that a company cannot
effectively restrict the users of a free program by obtaining a
restrictive license from a patent holder.  Therefore, we insist that
any patent license obtained for a version of the library must be
consistent with the full freedom of use specified in this license.

  Most GNU software, including some libraries, is covered by the
ordinary GNU General Public License.  This license, the GNU Lesser
General Public License, applies to certain designated libraries, and
is quite different from the ordinary General Public License.  We use
this license for certain libraries in order to permit linking those
libraries into non-free programs.

  When a program is linked with a library, whether statically or using
a shared library, the combination of the two is legally speaking a
combined work, a derivative of the original library.  The ordinary
General Public License therefore permits such linking only if the
entire combination fits its criteria of freedom.  The Lesser General
Public License permits more lax criteria for linking other code with
the library.

  We call this license the "Lesser" General Public License because it
does Less to protect the user's freedom than the ordinary General
Public License.  It also provides other free software developers Less
of an advantage over competing non-free programs.  These disadvantages
are the reason we use the ordinary General Public License for many
libraries.  However, the Lesser license provides advantages in certain
special circumstances.

  For example, on rare occasions, there may be a special need to
encourage the widest possible use of a certain library, so that it becomes
a de-facto standard.  To achieve this, non-free programs must be
allowed to use the library.  A more frequent case is that a free
library does the same job as widely used non-free libraries.  In this
case, there is little to gain by limiting the free library to free
software only, so we use the Lesser General Public License.

  In other cases, permission to use a particular library in non-free
programs enables a greater number of people to use a large body of
free software.  For example, permission to use the GNU C Library in
non-free programs enables many more people to use the whole GNU
operating system, as well as its variant, the GNU/Linux operating
system.

  Although the Lesser General Public License is Less protective of the
users' freedom, it does ensure that the user of a program that is
linked with the Library has the freedom and the wherewithal to run
that program using a modified version of the Library.

  The precise terms and conditions for copying, distribution and
modification follow.  Pay close attention to the difference between a
"work based on the library" and a "work that uses the library".  The
former contains code derived from the library, whereas the latter must
be combined with the library in order to run.

         GNU LESSER GENERAL PUBLIC LICENSE
   TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

  0. This License Agreement applies to any software library or other
program which contains a notice placed by the copyright holder or
other authorized party saying it may be distributed under the terms of
this Lesser General Public License (also called "this License").
Each licensee is addressed as "you".

  A "library" means a collection of software functions and/or data
prepared so as to be conveniently linked with application programs
(which use some of those functions and data) to form executables.

  The "Library", below, refers to any such software library or work
which has been distributed under these terms.  A "work based on the
Library" means either the Library or any derivative work under
copyright law: that is to say, a work containing the Library or a
portion of it, either verbatim or with modifications and/or translated
straightforwardly into another language.  (Hereinafter, translation is
included without limitation in the term "modification".)

  "Source code" for a work means the preferred form of the work for
making modifications to it.  For a library, complete source code means
all the source code for all modules it contains, plus any associated
interface definition files, plus the scripts used to control compilation
and installation of the library.

  Activities other than copying, distribution and modification are not
covered by this License; they are outside its scope.  The act of
running a program using the Library is not restricted, and output from
such a program is covered only if its contents constitute a work based
on the Library (independent of the use of the Library in a tool for
writing it).  Whether that is true depends on what the Library does
and what the program that uses the Library does.

  1. You may copy and distribute verbatim copies of the Library's
complete source code as you receive it, in any medium, provided that
you conspicuously and appropriately publish on each copy an
appropriate copyright notice and disclaimer of warranty; keep intact
all the notices that refer to this License and to the absence of any
warranty; and distribute a copy of this License along with the
Library.

  You may charge a fee for the physical act of transferring a copy,
and you may at your option offer warranty protection in exchange for a
fee.

  2. You may modify your copy or copies of the Library or any portion
of it, thus forming a work based on the Library, and copy and
distribute such modifications or work under the terms of Section 1
above, provided that you also meet all of these conditions:

    a) The modified work must itself be a software library.

    b) You must cause the files modified to carry prominent notices
    stating that you changed the files and the date of any change.

    c) You must cause the whole of the work to be licensed at no
    charge to all third parties under the terms of this License.

    d) If a facility in the modified Library refers to a function or a
    table of data to be supplied by an application program that uses
    the facility, other than as an argument passed when the facility
    is invoked, then you must make a good faith effort to ensure that,
    in the event an application does not supply such function or
    table, the facility still operates, and performs whatever part of
    its purpose remains meaningful.

    (For example, a function in a library to compute square roots has
    a purpose that is entirely well-defined independent of the
    application.  Therefore, Subsection 2d requires that any
    application-supplied function or table used by this function must
    be optional: if the application does not supply it, the square
    root function must still compute square roots.)

These requirements apply to the modified work as a whole.  If
identifiable sections of that work are not derived from the Library,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
sections when you distribute them as separate works.  But when you
distribute the same sections as part of a whole which is a work based
on the Library, the distribution of the whole must be on the terms of
this License, whose permissions for other licensees extend to the
entire whole, and thus to each and every part regardless of who wrote
it.

Thus, it is not the intent of this section to claim rights or contest
your rights to work written entirely by you; rather, the intent is to
exercise the right to control the distribution of derivative or
collective works based on the Library.

In addition, mere aggregation of another work not based on the Library
with the Library (or with a work based on the Library) on a volume of
a storage or distribution medium does not bring the other work under
the scope of this License.

  3. You may opt to apply the terms of the ordinary GNU General Public
License instead of this License to a given copy of the Library.  To do
this, you must alter all the notices that refer to this License, so
that they refer to the ordinary GNU General Public License, version 2,
instead of to this License.  (If a newer version than version 2 of the
ordinary GNU General Public License has appeared, then you can specify
that version instead if you wish.)  Do not make any other change in
these notices.

  Once this change is made in a given copy, it is irreversible for
that copy, so the ordinary GNU General Public License applies to all
subsequent copies and derivative works made from that copy.

  This option is useful when you wish to copy part of the code of
the Library into a program that is not a library.

  4. You may copy and distribute the Library (or a portion or
derivative of it, under Section 2) in object code or executable form
under the terms of Sections 1 and 2 above provided that you accompany
it with the complete corresponding machine-readable source code, which
must be distributed under the terms of Sections 1 and 2 above on a
medium customarily used for software interchange.

  If distribution of object code is made by offering access to copy
from a designated place, then offering equivalent access to copy the
source code from the same place satisfies the requirement to
distribute the source code, even though third parties are not
compelled to copy the source along with the object code.

  5. A program that contains no derivative of any portion of the
Library, but is designed to work with the Library by being compiled or
linked with it, is called a "work that uses the Library".  Such a
work, in isolation, is not a derivative work of the Library, and
therefore falls outside the scope of this License.

  However, linking a "work that uses the Library" with the Library
creates an executable that is a derivative of the Library (because it
contains portions of the Library), rather than a "work that uses the
library".  The executable is therefore covered by this License.
Section 6 states terms for distribution of such executables.

  When a "work that uses the Library" uses material from a header file
that is part of the Library, the object code for the work may be a
derivative work of the Library even though the source code is not.
Whether this is true is especially significant if the work can be
linked without the Library, or if the work is itself a library.  The
threshold for this to be true is not precisely defined by law.

  If such an object file uses only numerical parameters, data
structure layouts and accessors, and small macros and small inline
functions (ten lines or less in length), then the use of the object
file is unrestricted, regardless of whether it is legally a derivative
work.  (Executables containing this object code plus portions of the
Library will still fall under Section 6.)

  Otherwise, if the work is a derivative of the Library, you may
distribute the object code for the work under the terms of Section 6.
Any executables containing that work also fall under Section 6,
whether or not they are linked directly with the Library itself.

  6. As an exception to the Sections above, you may also combine or
link a "work that uses the Library" with the Library to produce a
work containing portions of the Library, and distribute that work
under terms of your choice, provided that the terms permit
modification of the work for the customer's own use and reverse
engineering for debugging such modifications.

  You must give prominent notice with each copy of the work that the
Library is used in it and that the Library and its use are covered by
this License.  You must supply a copy of this License.  If the work
during execution displays copyright notices, you must include the
copyright notice for the Library among them, as well as a reference
directing the user to the copy of this License.  Also, you must do one
of these things:

    a) Accompany the work with the complete corresponding
    machine-readable source code for the Library including whatever
    changes were used in the work (which must be distributed under
    Sections 1 and 2 above); and, if the work is an executable linked
    with the Library, with the complete machine-readable "work that
    uses the Library", as object code and/or source code, so that the
    user can modify the Library and then relink to produce a modified
    executable containing the modified Library.  (It is understood
    that the user who changes the contents of definitions files in the
    Library will not necessarily be able to recompile the application
    to use the modified definitions.)

    b) Use a suitable shared library mechanism for linking with the
    Library.  A suitable mechanism is one that (1) uses at run time a
    copy of the library already present on the user's computer system,
    rather than copying library functions into the executable, and (2)
    will operate properly with a modified version of the library, if
    the user installs one, as long as the modified version is
    interface-compatible with the version that the work was made with.

    c) Accompany the work with a written offer, valid for at
    least three years, to give the same user the materials
    specified in Subsection 6a, above, for a charge no more
    than the cost of performing this distribution.

    d) If distribution of the work is made by offering access to copy
    from a designated place, offer equivalent access to copy the above
    specified materials from the same place.

    e) Verify that the user has already received a copy of these
    materials or that you have already sent this user a copy.

  For an executable, the required form of the "work that uses the
Library" must include any data and utility programs needed for
reproducing the executable from it.  However, as a special exception,
the materials to be distributed need not include anything that is
normally distributed (in either source or binary form) with the major
components (compiler, kernel, and so on) of the operating system on
which the executable runs, unless that component itself accompanies
the executable.

  It may happen that this requirement contradicts the license
restrictions of other proprietary libraries that do not normally
accompany the operating system.  Such a contradiction means you cannot
use both them and the Library together in an executable that you
distribute.

  7. You may place library facilities that are a work based on the
Library side-by-side in a single library together with other library
facilities not covered by this License, and distribute such a combined
library, provided that the separate distribution of the work based on
the Library and of the other library facilities is otherwise
permitted, and provided that you do these two things:

    a) Accompany the combined library with a copy of the same work
    based on the Library, uncombined with any other library
    facilities.  This must be distributed under the terms of the
    Sections above.

    b) Give prominent notice with the combined library of the fact
    that part of it is a work based on the Library, and explaining
    where to find the accompanying uncombined form of the same work.

  8. You may not copy, modify, sublicense, link with, or distribute
the Library except as expressly provided under this License.  Any
attempt otherwise to copy, modify, sublicense, link with, or
distribute the Library is void, and will automatically terminate your
rights under this License.  However, parties who have received copies,
or rights, from you under this License will not have their licenses
terminated so long as such parties remain in full compliance.

  9. You are not required to accept this License, since you have not
signed it.  However, nothing else grants you permission to modify or
distribute the Library or its derivative works.  These actions are
prohibited by law if you do not accept this License.  Therefore, by
modifying or distributing the Library (or any work based on the
Library), you indicate your acceptance of this License to do so, and
all its terms and conditions for copying, distributing or modifying
the Library or works based on it.

  10. Each time you redistribute the Library (or any work based on the
Library), the recipient automatically receives a license from the
original licensor to copy, distribute, link with or modify the Library
subject to these terms and conditions.  You may not impose any further
restrictions on the recipients' exercise of the rights granted herein.
You are not responsible for enforcing compliance by third parties with
this License.

  11. If, as a consequence of a court judgment or allegation of patent
infringement or for any other reason (not limited to patent issues),
conditions are imposed on you (whether by court order, agreement or
otherwise) that contradict the conditions of this License, they do not
excuse you from the conditions of this License.  If you cannot
distribute so as to satisfy simultaneously your obligations under this
License and any other pertinent obligations, then as a consequence you
may not distribute the Library at all.  For example, if a patent
license would not permit royalty-free redistribution of the Library by
all those who receive copies directly or indirectly through you, then
the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any
particular circumstance, the balance of the section is intended to apply,
and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any
patents or other property right claims or to contest validity of any
such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system which is
implemented by public license practices.  Many people have made
generous contributions to the wide range of software distributed
through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing
to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to
be a consequence of the rest of this License.

  12. If the distribution and/or use of the Library is restricted in
certain countries either by patents or by copyrighted interfaces, the
original copyright holder who places the Library under this License may add
an explicit geographical distribution limitation excluding those countries,
so that distribution is permitted only in or among countries not thus
excluded.  In such case, this License incorporates the limitation as if
written in the body of this License.

  13. The Free Software Foundation may publish revised and/or new
versions of the Lesser General Public License from time to time.
Such new versions will be similar in spirit to the present version,
but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number.  If the Library
specifies a version number of this License which applies to it and
"any later version", you have the option of following the terms and
conditions either of that version or of any later version published by
the Free Software Foundation.  If the Library does not specify a
license version number, you may choose any version ever published by
the Free Software Foundation.

  14. If you wish to incorporate parts of the Library into other free
programs whose distribution conditions are incompatible with these,
write to the author to ask for permission.  For software which is
copyrighted by the Free Software Foundation, write to the Free
Software Foundation; we sometimes make exceptions for this.  Our
decision will be guided by the two goals of preserving the free status
of all derivatives of our free software and of promoting the sharing
and reuse of software generally.

               NO WARRANTY

  15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE.  THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
LIBRARY IS WITH YOU.  SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME
THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

  16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN
WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY
AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU
FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE
LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING
RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A
FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF
SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
DAMAGES.

            END OF TERMS AND CONDITIONS

PortAudio - Portable Audio I/O Library

Copyright (c) 1999-2002 Ross Bencina, Phil Burk

Revised BSD License

PortAudio Portable Real-Time Audio Library
Copyright (c) 1999-2011 Ross Bencina, Phil Burk

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and
associated documentation files (the "Software"), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge, publish, distribute,
sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or
substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT
NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Speex

Copyright (C) 2007-2008 Jean-Marc Valin

Copyright (C) 2008 Thorvald Natvig

Speex License

Redistribution and use in source and binary forms, with or without modification, are permitted
provided that the following conditions are met:

+ Redistributions of source code must retain the above copyright notice, this list of conditions and
  the following disclaimer.
+ Redistributions in binary form must reproduce the above copyright notice, this list of conditions
  and the following disclaimer in the documentation and/or other materials provided with the
  distribution.
+ Neither the name of the Xiph.org Foundation nor the names of its contributors may be used to
  endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA,
OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

recon, reflow, reTurn

Copyright (c) 2007-2008, Plantronics, Inc.

Revised BSD License

 Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions are
 met:

 1. Redistributions of source code must retain the above copyright
    notice, this list of conditions and the following disclaimer.

 2. Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in the
    documentation and/or other materials provided with the distribution.

 3. Neither the name of Plantronics nor the names of its contributors
    may be used to endorse or promote products derived from this
    software without specific prior written permission.

 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
 "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
 LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
 A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
 OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
 SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
 LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
 DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
 THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
 (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Crypto++

Crypto++

Compilation Copyright (c) 1995-2010 by Wei Dai.  All rights reserved.
This copyright applies only to this software distribution package
as a compilation, and does not imply a copyright on any particular
file in the package.

All individual files in this compilation are placed in the public domain by
Wei Dai and other contributors.

I would like to thank the following authors for placing their works into
the public domain:

Joan Daemen - 3way.cpp
Leonard Janke - cast.cpp, seal.cpp
Steve Reid - cast.cpp
Phil Karn - des.cpp
Andrew M. Kuchling - md2.cpp, md4.cpp
Colin Plumb - md5.cpp
Seal Woods - rc6.cpp
Chris Morgan - rijndael.cpp
Paulo Baretto - rijndael.cpp, skipjack.cpp, square.cpp
Richard De Moliner - safer.cpp
Matthew Skala - twofish.cpp
Kevin Springle - camellia.cpp, shacal2.cpp, ttmac.cpp, whrlpool.cpp, ripemd.cpp

Permission to use, copy, modify, and distribute this compilation for
any purpose, including commercial applications, is hereby granted
without fee, subject to the following restrictions:

1. Any copy or modification of this compilation in any form, except
in object code form as part of an application software, must include
the above copyright notice and this license.

2. Users of this software agree that any modification or extension
they provide to Wei Dai will be considered public domain and not
copyrighted unless it includes an explicit copyright notice.

3. Wei Dai makes no warranty or representation that the operation of the
software in this compilation will be error-free, and Wei Dai is under no
obligation to provide any services, by way of maintenance, update, or
otherwise.  THE SOFTWARE AND ANY DOCUMENTATION ARE PROVIDED "AS IS"
WITHOUT EXPRESS OR IMPLIED WARRANTY INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE. IN NO EVENT WILL WEI DAI OR ANY OTHER CONTRIBUTOR BE LIABLE FOR
DIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

4. Users will not use Wei Dai or any other contributor's name in any
publicity or advertising, without prior written consent in each case.

5. Export of this software from the United States may require a
specific license from the United States Government.  It is the
responsibility of any person or organization contemplating export
to obtain such a license before exporting.

6. Certain parts of this software may be protected by patents.  It
is the users' responsibility to obtain the appropriate
licenses before using those parts.

If this compilation is used in object code form in an application
software, acknowledgement of the author is not required but would be
appreciated. The contribution of any useful modifications or extensions
to Wei Dai is not required but would also be appreciated.

ares

Copyright 1998 by the Massachusetts Institute of Technology.

Ares License

Copyright 1998 by the Massachusetts Institute of Technology.

Permission to use, copy, modify, and distribute this
software and its documentation for any purpose and without
fee is hereby granted, provided that the above copyright
notice appear in all copies and that both that copyright
notice and this permission notice appear in supporting
documentation, and that the name of M.I.T. not be used in
advertising or publicity pertaining to distribution of the
software without specific, written prior permission.
M.I.T. makes no representations about the suitability of
this software for any purpose.  It is provided "as is"
without express or implied warranty.

ASIO, Boost

ASIO, Boost License

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization
obtaining a copy of the software and accompanying documentation covered by
this license (the "Software") to use, reproduce, display, distribute,
execute, and transmit the Software, and to prepare derivative works of the
Software, and to permit third-parties to whom the Software is furnished to
do so, all subject to the following:

The copyright notices in the Software and this entire statement, including
the above license grant, this restriction and the following disclaimer,
must be included in all copies of the Software, in whole or in part, and
all derivative works of the Software, unless such copies or derivative
works are solely in the form of machine-executable object code generated by
a source language processor.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
DEALINGS IN THE SOFTWARE.

libGSM

Copyright 1992 by Jutta Degener and Carsten Bormann, Technische Universitaet Berlin

Copyright 1992, 1993, 1994 by Jutta Degener and Carsten Bormann,
Technische Universitaet Berlin

Any use of this software is permitted provided that this notice is not
removed and that neither the authors nor the Technische Universitaet Berlin
are deemed to have made any representations as to the suitability of this
software for any purpose nor are held responsible for any defects of
this software.  THERE IS ABSOLUTELY NO WARRANTY FOR THIS SOFTWARE.

As a matter of courtesy, the authors request to be informed about uses
this software has found, about bugs in this software, and about any
improvements that may be of general interest.

Berlin, 28.11.1994
Jutta Degener
Carsten Bormann

iLBC Speech Coder ANSI-C Source Code

Copyright (C) The Internet Society (2004). All Rights Reserved.

libSRTP

Copyright (c) 2001-2006, Cisco Systems, Inc. All rights reserved.

libSRTP License

Copyright (c) 2001-2006, Cisco Systems, Inc.
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:

+ Redistributions of source code must retain the above copyright
  notice, this list of conditions and the following disclaimer.

+ Redistributions in binary form must reproduce the above
  copyright notice, this list of conditions and the following
  disclaimer in the documentation and/or other materials provided
  with the distribution.

+ Neither the name of the Cisco Systems, Inc. nor the names of its
  contributors may be used to endorse or promote products derived
  from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGE.

PCRE Perl-Compatible Regular Expressions

Copyright (c) 1997-2004 University of Cambridge. All rights reserved.

PCRE Library License

Copyright (c) 1997-2004 University of Cambridge

-----------------------------------------------------------------------------
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

    + Redistributions of source code must retain the above copyright notice,
      this list of conditions and the following disclaimer.

    + Redistributions in binary form must reproduce the above copyright
      notice, this list of conditions and the following disclaimer in the
      documentation and/or other materials provided with the distribution.

    + Neither the name of the University of Cambridge nor the names of its
      contributors may be used to endorse or promote products derived from
      this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
-----------------------------------------------------------------------------

rutil, resiprocate, DUM

Copyright (c) 2000 Vovida Networks, Inc. All rights reserved.

Vovida License

The Vovida Software License, Version 1.0

Copyright (c) 2000 Vovida Networks, Inc.  All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:

1. Redistributions of source code must retain the above copyright
   notice, this list of conditions and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in
   the documentation and/or other materials provided with the
   distribution.

3. The names "VOCAL", "Vovida Open Communication Application Library",
   and "Vovida Open Communication Application Library (VOCAL)" must
   not be used to endorse or promote products derived from this
   software without prior written permission. For written
   permission, please contact vocal@vovida.org.

4. Products derived from this software may not be called "VOCAL", nor
   may "VOCAL" appear in their name, without prior written
   permission of Vovida Networks, Inc.

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND
NON-INFRINGEMENT ARE DISCLAIMED.  IN NO EVENT SHALL VOVIDA
NETWORKS, INC. OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT DAMAGES
IN EXCESS OF $1,000, NOR FOR ANY INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

====================================================================

This software consists of voluntary contributions made by Vovida
Networks, Inc. and many individuals on behalf of Vovida Networks,
Inc.  For more information on Vovida Networks, Inc., please see
<http://www.vovida.org/>.


Getting Started
Topics Send Feedback

With the Conaito VoIP Video SIP SDK you may easily establish calls to regular phones (PSTN) from your desktop and Web applications. You can utilize it to develop IVR or more complex SIP Server/Media center solutions. The SDK comes with new sample SIP Proxy Server to provide in bundle with the Conaito SIP Client a ready up SIP VoIP and Instant Messaging network solution.

Typical scenario - How to make a call:

  1. Build SIPActiveX object (specify required properties such as LoginID, Password, RegistrationProxy, LicenseKey etc.)
  2. Initialize SIPActiveX.
  3. Register with SIP Proxy server. Register method takes no parameters because all SIP user account settings must be set before calling Initialize method.
  4. Handle calls.
  5. Unregister on SIP Proxy Server (see UnRegister method for more information).
  6. Shutdown SIPActiveX.

Usage GUI applications:

  1. Register Conaito SIP Client ActiveX control (in Web applications the control is registered automatically - CAB is used).
  2. Register the control with your development environment.
  3. Put the control on main form. Set it's "Visible" property to "false".

Transports: The core SIP stack provides following transports:

  • UDP (configurable by UDPPort)
  • TCP (configurable by TCPPort)

Networking: The Conaito VoIP Video SIP SDK is fully compatible with most typical SIP servers (Asterisk, Sip EXpress e.t.c.). It supports both NAT traversing (STUN, ICE) and reliable TCP for the signaling protocol. Also it's usable for sending text messages, play and record conferences (WAV) and DTMF tones.

Media: You may use 8000/16000 Hz sampling codecs (G711 A-Law, G711 U-Law, Speex, Speex-wb, GSM6.10, iLBC and g729 & g723 Codec support). The SDK also provides sending and receiving of DTMF tones, playing ring-tone is also supported. You can play WAV files and record conversations in WAV format.

Topics
Name
Description
Microsoft Visual Studio Quick Start

  1. Open Microsoft Visual Studio
  2. Add VoIP Video SIP SDK ActiveX to Toolbox

  3. Now you can place VoIP Video SIP SDK ActiveX at form

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.

Borland Delphi Quick Start

  1. Open Borland Delphi
  2. Import VoIP Video SIP SDK ActiveX

  3. Install VoIP Video SIP SDK ActiveX

  4. Now you have the component at palette and you can put it on form

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.

Microsoft Visual Basic 6.0 Quick Start

  1. Open Microsoft Visual Basic 6.0
  2. Open new windows project: Standard EXE

  3. Add "VoIP Video SIP SDK" to Toolbox

  4. Put VoIP Video SIP ActiveX at form:

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.

Links
Topics


Microsoft Visual Studio Quick Start
Getting Started Send Feedback
  1. Open Microsoft Visual Studio
  2. Add VoIP Video SIP SDK ActiveX to Toolbox

  3. Now you can place VoIP Video SIP SDK ActiveX at form

Run application.

There will be empty form with SDK on it.

That’s it. We have added SDK to our application.

Group

Getting Started

Links
Getting Started


Borland Delphi Quick Start
Getting Started Send Feedback
  1. Open Borland Delphi
  2. Import VoIP Video SIP SDK ActiveX

  3. Install VoIP Video SIP SDK ActiveX

  4. Now you have the component at palette and you can put it on form

Run application.

There will be empty form with SDK on it.

That’s it. We have added SDK to our application.

Group

Getting Started

Links
Getting Started


Microsoft Visual Basic 6.0 Quick Start
Getting Started Send Feedback
  1. Open Microsoft Visual Basic 6.0
  2. Open new windows project: Standard EXE

  3. Add "VoIP Video SIP SDK" to Toolbox

  4. Put VoIP Video SIP ActiveX at form:

Run application.

There will be empty form with SDK on it.

That’s it. We have added SDK to our application.

Group

Getting Started

Links
Getting Started


Reference
Topics See Also Send Feedback

Conaito VoIP Video SIP SDK

Description

Conaito VoIP Video SIP SDK - a powerful tool to build VoIP SIP applications

See Also

Methods Properties Events

Topics
Name | Description
Methods | SIP SDK methods
Properties | SIP SDK properties
Events | SIP SDK events
CallState | Call state
VideoFrameFormat | Video frame format.
Links
Topics, See Also


Methods
Reference Topics See Also Send Feedback

SIP SDK methods

Description

SIP SDK methods

  • Initialize - Initialize SIP SDK
  • WebInitialize - Initialize SIP SDK with encrypted parameters
  • Shutdown - Shutdown SIP SDK
  • Register - Register with SIP proxy
  • UnRegister - Un-register from SIP proxy
  • Connect - Make call to remote participant
  • Disconnect - Disconnect active call or reject incoming
  • AcceptCall - Accept incoming call
  • TransferCall - Blind (unattended) transfer active call to given destination
  • RedirectCall - Consultative (attended) transfer active call to the target call
  • Hold - Place call on hold
  • Unhold - Take call off hold
  • EnableKeepAlive - Enable Keep-Alive signaling
  • DisableKeepAlive - Disable Keep-Alive signaling
  • EnableSTUN - Enable STUN
  • DisableSTUN - Disable STUN
  • EnableTURN - Enable TURN
  • DisableTURN - Disable TURN
  • SendDTMF - Send DTMF signal
  • StartPlaying - Start playing file
  • StartPlayingAtLine - Start playing file at given line
  • StopPlaying - Stop playing file
  • StopPlayingAtLine - Stop playing file at given line
  • StartRecording - Record call to file
  • StopRecording - Stop recording call to file
  • GetOutDevName - Get name for output device at position index
  • GetInDevName - Get name for input device at position index
  • GetCaptureDevName - Get name for video capture device at position index
  • SetLicenseKey - Set license key
  • SetWebLicense - Set Web license key
  • EncryptSipSettings - Encrypt SIP settings
  • SendPagerMessage - Send pager message to the destination URI
  • PostPagerMessage - Post pager message to the destination URI asynchronously
  • ConferenceJoin - Add call to conference
  • ConferenceRemove - Remove call from conference
  • SelectAllVoiceCodecs - Select all voice codecs
  • SelectVoiceCodec - Select voice codec
  • DeselectAllVoiceCodecs - De-select all voice codecs
  • DeselectVoiceCodec - De-select voice codec
  • GetVoiceCodecName - Get voice codec name
  • SelectAllVideoCodecs - Select all video codecs
  • SelectVideoCodec - Select video codec
  • DeselectAllVideoCodecs - De-select all video codecs
  • DeselectVideoCodec - De-select video codec
  • GetVideoCodecName - Get video codec name
  • StoreConfiguration - Store SIP SDK configuration
  • LoadConfiguration - Load SIP SDK configuration
  • AddAdditionalDNSServer - Add additional DNS server that will be attempted to be discovered
  • AddSipAccount - Add new SIP account
  • RemoveSipAccount - Remove current SIP account
  • GetSipAccountIndex - Get index of SIP account
  • SetAudioCodecIndex - Set audio codec index
  • SetVideoCodecIndex - Set video codec index
  • StartVideo - Start sending video
  • StopVideo - Stop sending video
  • GetCaptureDevName - Get name of video capture device
  • URLGetDisplayName - Parse display name from SIP URI
  • URLGetUserName - Parse user name from SIP URI
  • URLGetHost - Parse host name from SIP URI
  • URLGetPort - Parse port number from SIP URI
  • URLGetAOR - Parse AOR from SIP URI
See Also

VoIP Video SIP SDK

Group

Reference

Topics
Name | Description
Initialize Method | Initialize SIP SDK
WebInitialize Method | Initialize SIP SDK with encrypted parameters
Shutdown Method | Shutdown SIP SDK
Register Method | Register with SIP proxy
UnRegister Method | Un-register from SIP proxy
Connect Method | Make call to remote participant
Disconnect Method | Disconnect active call or reject incoming
AcceptCall Method | Accept incoming call
TransferCall Method | Blind (unattended) transfer active call to given destination
RedirectCall Method | Consultative (attended) transfer active call to the target call
Hold Method | Place call on hold
Unhold Method | Take call off hold
EnableKeepAlive Method | Enable Keep-Alive signaling
DisableKeepAlive Method | Disable Keep-Alive signaling
EnableSTUN Method | Enable STUN
DisableSTUN Method | Disable STUN
EnableTURN Method | Enable TURN
DisableTURN Method | Disable TURN
SendDTMF Method | Send DTMF signal
StartPlaying Method | Start playing file
StartPlayingAtLine Method | Start playing file at given line
StopPlaying Method | Stop playing file
StopPlayingAtLine Method | Stop playing file at given line
StartRecording Method | Record call to file
StopRecording Method | Stop recording call to file
GetOutDevName Method | Get name for output device at position index
GetInDevName Method | Get name for input device at position index
SetLicenseKey Method | This method is used to set license key (fullversion)
SetWebLicense Method | This method is used to set license key (fullversion) for website usage.
EncryptSipSettings Method | This method is used to encrypt SIP settings for WebInitialize.
SendPagerMessage Method | Send pager message to the destination URI
PostPagerMessage Method | Post pager message to the destination URI asynchronously
ConferenceJoin Method | Add call to conference
ConferenceRemove Method | Remove call from conference
SelectAllVoiceCodecs Method | Select all voice codecs
SelectVoiceCodec Method | Select voice codec
DeselectAllVoiceCodecs Method | De-select all voice codecs
DeselectVoiceCodec Method | De-select voice codec
GetVoiceCodecName Method | Get voice codec name
StoreConfiguration Method | Store SIP SDK configuration
LoadConfiguration Method | Load SIP SDK configuration
AddAdditionalDNSServer Method | Add additional DNS server that will be attempted to be discovered
URLGetDisplayName Method | Parse display name from SIP URI
URLGetUserName Method | Parse user name from SIP URI
URLGetHost Method | Parse host name from SIP URI
URLGetPort Method | Parse port number from SIP URI
URLGetAOR Method | Parse AOR from SIP URI
GetCaptureDevName Method | Get name for video capture device at position index
SelectAllVideoCodecs Method | Select all video codecs
SelectVideoCodec Method | Select video codec
DeselectAllVideoCodecs Method | De-select all video codecs
DeselectVideoCodec Method | De-select video codec
GetVideoCodecName Method | Get video codec name
AddSipAccount Method | Add new SIP account
RemoveSipAccount Method | Remove current SIP account
GetSipAccountIndex Method | Get index of SIP account
StopVideo Method | Stop sending video
SetAudioCodecIndex Method | Set audio codec index
SetVideoCodecIndex Method | Set video codec index
StartVideo Method | Start sending video
Links
Reference, Topics, See Also


Initialize Method
Methods See Also Send Feedback

Initialize SIP SDK

C++
HRESULT Initialize(BSTR sListenIP);
C#
void Initialize(string sListenIP);
Parameters
Parameters | Description
sListenIP | Listen IP
Description

Initialize SIP SDK

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


WebInitialize Method
Methods See Also Send Feedback

Initialize SIP SDK with encrypted parameters

C++
HRESULT WebInitialize(BSTR sListenIP, BSTR sEncryptedSettings);
C#
void WebInitialize(string sListenIP, string sEncryptedSettings);
Parameters
Parameters | Description
sListenIP | Listen IP
sEncryptedSettings | Encrypted settings
Description

Initialize SIP SDK with encrypted parameters

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Shutdown Method
Methods See Also Send Feedback

Shutdown SIP SDK

C++
HRESULT Shutdown();
C#
void Shutdown();
Description

Shutdown SIP SDK

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Register Method
Methods See Also Send Feedback

Register with SIP proxy

C++
HRESULT Register();
C#
void Register();
Description

Register with SIP proxy

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


UnRegister Method
Methods See Also Send Feedback

Un-register from SIP proxy

C++
HRESULT UnRegister();
C#
void UnRegister();
Description

Un-register from SIP proxy

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Connect Method
Methods See Also Send Feedback

Make call to remote participant

C++
HRESULT Connect(BSTR sRemoteURI);
C#
void Connect(string sRemoteURI);
Parameters
Parameters | Description
sRemoteURI | Destination SIP URI (example: "john.doe@voip.com")
Description

Make call to remote participant

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Disconnect Method
Methods See Also Send Feedback

Disconnect active call or reject incoming

C++
HRESULT Disconnect();
C#
void Disconnect();
Description

Disconnect active call or reject incoming

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


AcceptCall Method
Methods See Also Send Feedback

Accept incoming call

C++
HRESULT AcceptCall();
C#
void AcceptCall();
Description

Accept incoming call

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


TransferCall Method
Methods See Also Send Feedback

Blind (unattended) transfer active call to given destination

C++
HRESULT TransferCall(BSTR sDestinationURI);
C#
void TransferCall(string sDestinationURI);
Parameters
Parameters | Description
sDestinationURI | Destination SIP URI (example: "john.doe@voip.com")
Description

Blind (unattended) transfer active call to given destination

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


RedirectCall Method
Methods See Also Send Feedback

Consultative (attended) transfer active call to the target call

C++
HRESULT RedirectCall(INT nDestinationLine);
C#
void RedirectCall(INT nDestinationLine);
Parameters
Parameters | Description
nDestinationLine | Destination line
Description

Consultative (attended) transfer active call to the target call

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Hold Method
Methods See Also Send Feedback

Place call on hold

C++
HRESULT Hold();
C#
void Hold();
Description

Place call on hold

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Unhold Method
Methods See Also Send Feedback

Take call off hold

C++
HRESULT Unhold();
C#
void Unhold();
Description

Take call off hold

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


EnableKeepAlive Method
Methods See Also Send Feedback

Enable Keep-Alive signaling

C++
HRESULT EnableKeepAlive(INT nSeconds);
C#
void EnableKeepAlive(int nSeconds);
Parameters
Parameters | Description
nSeconds | Keep-Alive interval in seconds
Description

Enable Keep-Alive signaling

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DisableKeepAlive Method
Methods See Also Send Feedback

Disable Keep-Alive signaling

C++
HRESULT DisableKeepAlive();
C#
void DisableKeepAlive();
Description

Disable Keep-Alive signaling

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


EnableSTUN Method
Methods See Also Send Feedback

Enable STUN

C++
HRESULT EnableSTUN(BSTR sServer, INT nPort);
C#
void EnableSTUN(string sServer, int nPort);
Parameters
Parameters | Description
sServer | STUN server host name or IP
nPort | STUN server port number
Description

Enable STUN

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DisableSTUN Method
Methods See Also Send Feedback

Disable STUN

C++
HRESULT DisableSTUN();
C#
void DisableSTUN();
Description

Disable STUN

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


EnableTURN Method
Methods See Also Send Feedback

Enable TURN

C++
HRESULT EnableTURN(BSTR sServer, INT nPort, BSTR sUsername, BSTR sPassword);
C#
void EnableTURN(string sServer, int nPort, string sUsername, string sPassword);
Parameters
Parameters | Description
sServer | TURN server host name or IP
nPort | TURN server port number
sUsername | Username on TURN server
sPassword | Password on TURN server
Description

Enable TURN

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DisableTURN Method
Methods See Also Send Feedback

Disable TURN

C++
HRESULT DisableTURN();
C#
void DisableTURN();
Description

Disable TURN

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SendDTMF Method
Methods See Also Send Feedback

Send DTMF signal

C++
HRESULT SendDTMF(BSTR sDigit);
C#
void SendDTMF(string sDigit);
Description

Send DTMF signal

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StartPlaying Method
Methods See Also Send Feedback

Start playing file

C++
HRESULT StartPlaying(BSTR sFileName);
C#
void StartPlaying(string sFileName);
Parameters
Parameters | Description
sFileName | Path to WAV file to be played
Description

Start playing file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StartPlayingAtLine Method
Methods See Also Send Feedback

Start playing file at given line

C++
HRESULT StartPlayingAtLine(BSTR sFileName, INT nLineNo);
C#
void StartPlayingAtLine(string sFileName, int nLineNo);
Parameters
Parameters | Description
sFileName | Path to WAV file to be played
nLineNo | Line number
Description

Start playing file at given line

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StopPlaying Method
Methods See Also Send Feedback

Stop playing file

C++
HRESULT StopPlaying();
C#
void StopPlaying();
Description

Stop playing file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StopPlayingAtLine Method
Methods See Also Send Feedback

Stop playing file at given line

C++
HRESULT StopPlayingAtLine(INT nLineNo);
C#
void StopPlayingAtLine(int nLineNo);
Parameters
Parameters | Description
nLineNo | Line number
Description

Stop playing file at given line

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StartRecording Method
Methods See Also Send Feedback

Record call to file

C++
HRESULT StartRecording(BSTR sFileName);
C#
void StartRecording(string sFileName);
Parameters
Parameters | Description
sFileName | Path to WAV file to be recorded
Description

Record call to file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StopRecording Method
Methods See Also Send Feedback

Stop recording call to file

C++
HRESULT StopRecording();
C#
void StopRecording();
Description

Stop recording call to file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetOutDevName Method
Methods See Also Send Feedback

Get name for output device at position index

C++
HRESULT GetOutDevName(INT nIndex, BSTR* psDevName);
C#
string GetOutDevName(int nIndex);
Parameters
Parameters | Description
nIndex | Output device index
Returns

Name for output device at position index

Description

Get name for output device at position index

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetInDevName Method
Methods See Also Send Feedback

Get name for input device at position index

C++
HRESULT GetInDevName(INT nIndex, BSTR* psDevName);
C#
string GetInDevName(int nIndex);
Parameters
Parameters | Description
nIndex | Input device index
Returns

Name for input device at position index

Description

Get name for input device at position index

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SetLicenseKey Method
Methods See Also Send Feedback

This method is used to set license key (fullversion)

C++
HRESULT SetLicenseKey(BSTR sCustomerID, BSTR sLicenseKey);
C#
void SetLicenseKey(string sCustomerID, string sLicenseKey);
Parameters
Parameters | Description
sCustomerID | Customer's ID (provided with fullversion license)
sLicenseKey | Customer's License Key (provided with fullversion license)
Description

It initializes the component with licence key (fullversion)

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SetWebLicense Method
Methods See Also Send Feedback

This method is used to set license key (fullversion) for website usage.

C++
HRESULT SetWebLicense(BSTR sCustomerId, BSTR sWebKey);
C#
void SetWebLicense(string sCustomerId, string sWebKey);
Parameters
Parameters | Description
sCustomerID | Customer's ID (provided with fullversion license)
sLicenseKey | Customer's Web License Key (provided with fullversion license)
Description

It initializes the component with licence key (fullversion) for website usage. The Web license key is binded on the provided Domain (URL).

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


EncryptSipSettings Method
Methods See Also Send Feedback

This method is used to encrypt SIP settings for WebInitialize.

C++
HRESULT EncryptSipSettings(BSTR sCustomerId, BSTR sWebKey, BSTR sRealm, BSTR sOutboundProxy,
                           BSTR sRegistrationProxy, BSTR sUserId, BSTR sLoginId, BSTR sPassword, BSTR *psEncryptedSettings);
C#
string EncryptSipSettings(string sCustomerId, string sWebKey, string sRealm, string sOutboundProxy,
                          string sRegistrationProxy, string sUserId, string sLoginId, string sPassword);
Parameters
Parameters | Description
sCustomerId | Customer ID
sWebKey | Web license key
sRealm | Realm
sOutboundProxy | Outbound proxy
sRegistrationProxy | SIP registration proxy
sUserId | User ID
sLoginId | Login ID
sPassword | Password
Returns

Encrypted SIP settings as String for WebInitialize

Description

This method is used to encrypt SIP settings for WebInitialize.

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SendPagerMessage Method
Methods See Also Send Feedback

Send pager message to the destination URI

C++
HRESULT SendPagerMessage(BSTR sDestinationURI, BSTR sMessageText, BSTR sSubject, BSTR* psResponseCodeText);
C#
string SendPagerMessage(string sDestinationURI, string sMessageText, string sSubject);
Parameters
Parameters | Description
sDestinationURI | Destination SIP URI
sMessageText | Message body
sSubject | Message subject
Returns

Response SIP code and description as String. Incoming text message return status text, first line is integer status code (e.g "2xx" in case of success) and second is status description (e.g. "OK" in case of success) Sample status text: "408 Request timeout" 408 is integer status code second line "Request timeout" is response description; first line is "code" and next are "error description".

Description

Send pager message to the destination URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


PostPagerMessage Method
Methods See Also Send Feedback

Post pager message to the destination URI asynchronously

C++
HRESULT PostPagerMessage(BSTR sDestinationURI, BSTR sMessageText, BSTR sSubject);
C#
void PostPagerMessage(string sDestinationURI, string sMessageText, string sSubject);
Parameters
Parameters | Description
sDestinationURI | Destination SIP URI
sMessageText | Message body
sSubject | Message subject
Description

Post pager message to the destination URI asynchronously

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


ConferenceJoin Method
Methods See Also Send Feedback

Add call to conference

C++
HRESULT ConferenceJoin();
C#
void ConferenceJoin();
Description

Add call to conference

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


ConferenceRemove Method
Methods See Also Send Feedback

Remove call from conference

C++
HRESULT ConferenceRemove();
C#
void ConferenceRemove();
Description

Remove call from conference

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SelectAllVoiceCodecs Method
Methods See Also Send Feedback

Select all voice codecs

C++
HRESULT SelectAllVoiceCodecs();
C#
void SelectAllVoiceCodecs();
Description

Select all voice codecs

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SelectVoiceCodec Method
Methods See Also Send Feedback

Select voice codec

C++
HRESULT SelectVoiceCodec(INT nCodecNo);
C#
void SelectVoiceCodec(INT nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Description

Select voice codec

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DeselectAllVoiceCodecs Method
Methods See Also Send Feedback

De-select all voice codecs

C++
HRESULT DeselectAllVoiceCodecs();
C#
void DeselectAllVoiceCodecs();
Description

De-select all voice codecs

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DeselectVoiceCodec Method
Methods See Also Send Feedback

De-select voice codec

C++
HRESULT DeselectVoiceCodec(INT nCodecNo);
C#
void DeselectVoiceCodec(int nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Description

De-select voice codec

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetVoiceCodecName Method
Methods See Also Send Feedback

Get voice codec name

C++
HRESULT GetVoiceCodecName(INT nCodecNo, BSTR* psCodecName);
C#
string GetVoiceCodecName(int nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Returns

Voice codec name

Description

Get voice codec name

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StoreConfiguration Method
Methods See Also Send Feedback

Store SIP SDK configuration

C++
HRESULT StoreConfiguration(BSTR sFilePath);
C#
void StoreConfiguration(string sFilePath);
Parameters
Parameters | Description
sFilePath | Path to SIP SDK file
Description

Save SIP SDK configuration file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


LoadConfiguration Method
Methods See Also Send Feedback

Load SIP SDK configuration

C++
HRESULT LoadConfiguration(BSTR sFilePath);
C#
void LoadConfiguration(string sFilePath);
Parameters
Parameters | Description
sFilePath | Path to SIP SDK file
Description

Load SIP SDK configuration file

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


AddAdditionalDNSServer Method
Methods See Also Send Feedback

Add additional DNS server that will be attempted to be discovered

C++
HRESULT AddAdditionalDNSServer(BSTR sDNSServerIPAddress);
C#
void AddAdditionalDNSServer(string sDNSServerIPAddress);
Parameters
Parameters | Description
sDNSServerIPAddress | Additional DNS server that will be attempted to be discovered
Description

Add additional DNS server that will be attempted to be discovered

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


URLGetDisplayName Method
Methods See Also Send Feedback

Parse display name from SIP URI

C++
HRESULT URLGetDisplayName(BSTR sURI, BSTR* psDisplayName);
C#
void URLGetDisplayName(string sURI);
Parameters
Parameters | Description
sURI | SIP URI
Returns

Display name from SIP URI

Description

Parse display name from SIP URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


URLGetUserName Method
Methods See Also Send Feedback

Parse user name from SIP URI

C++
HRESULT URLGetUserName(BSTR sURI, BSTR* psUserName);
C#
string URLGetUserName(string sURI);
Parameters
Parameters | Description
sURI | SIP URI
Returns

User name from SIP URI

Description

Parse user name from SIP URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


URLGetHost Method
Methods See Also Send Feedback

Parse host name from SIP URI

C++
HRESULT URLGetHost(BSTR sURI, BSTR* psHost);
C#
string URLGetHost(string sURI);
Parameters
Parameters | Description
sURI | SIP URI
Returns

Host name from SIP URI

Description

Parse host name from SIP URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


URLGetPort Method
Methods See Also Send Feedback

Parse port number from SIP URI

C++
HRESULT URLGetPort(BSTR sURI, INT* pnPort);
C#
int URLGetPort(string sURI);
Parameters
Parameters | Description
sURI | SIP URI
Returns

Port number from SIP URI

Description

Parse port number from SIP URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


URLGetAOR Method
Methods See Also Send Feedback

Parse AOR from SIP URI

C++
HRESULT URLGetAOR(BSTR sURI, BSTR* psAOR);
C#
string URLGetAOR(string sURI);
Parameters
Parameters | Description
sURI | SIP URI
Returns

AOR from SIP URI

Description

Parse AOR from SIP URI

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetCaptureDevName Method
Methods See Also Send Feedback

Get name for video capture device at position index

C++
HRESULT GetCaptureDevName(INT nIndex, BSTR* psDevName);
C#
string GetCaptureDevName(int nIndex);
Parameters
Parameters | Description
nIndex | Video capture device index
Returns

Name for video capture device at position index

Description

Get name for video capture device at position index

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SelectAllVideoCodecs Method
Methods See Also Send Feedback

Select all video codecs

C++
HRESULT SelectAllVideoCodecs();
C#
void SelectAllVideoCodecs();
Description

Select all video codecs

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SelectVideoCodec Method
Methods See Also Send Feedback

Select video codec

C++
HRESULT SelectVideoCodec(INT nCodecNo);
C#
void SelectVideoCodec(INT nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Description

Select video codec

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DeselectAllVideoCodecs Method
Methods See Also Send Feedback

De-select all video codecs

C++
HRESULT DeselectAllVideoCodecs();
C#
void DeselectAllVideoCodecs();
Description

De-select all video codecs

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


DeselectVideoCodec Method
Methods See Also Send Feedback

De-select video codec

C++
HRESULT DeselectVideoCodec(INT nCodecNo);
C#
void DeselectVideoCodec(int nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Description

De-select video codec

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetVideoCodecName Method
Methods See Also Send Feedback

Get video codec name

C++
HRESULT GetVideoCodecName(INT nCodecNo, BSTR* psCodecName);
C#
string GetVideoCodecName(int nCodecNo);
Parameters
Parameters | Description
nCodecNo | Codec's index
Returns

Video codec name

Description

Get video codec name

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


AddSipAccount Method
Methods See Also Send Feedback

Add new SIP account

C++
HRESULT AddSipAccount();
C#
void AddSipAccount();
Description

Add new SIP account

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


RemoveSipAccount Method
Methods See Also Send Feedback

Remove current SIP account

C++
HRESULT RemoveSipAccount();
C#
void RemoveSipAccount();
Description

Remove current SIP account

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


GetSipAccountIndex Method
Methods See Also Send Feedback

Get index of SIP account

C++
HRESULT GetSipAccountIndex(BSTR sLocalURI, INT* pnIndex);
C#
int GetSipAccountIndex(string sLocalURI);
Parameters
Parameters | Description
sLocalURI | local SIP account URI
Returns

Index of SIP account

Description

Get index of SIP account

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StopVideo Method
Methods See Also Send Feedback

Stop sending video

C++
HRESULT StopVideo(INT nLine);
C#
int StopVideo(int nLine);
Parameters
Parameters | Description
nLine | Line index
Description

Stop sending video

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SetAudioCodecIndex Method
Methods See Also Send Feedback

Set audio codec index

C++
HRESULT SetAudioCodecIndex(INT nOldIndex, INT nNewIndex);
C#
int SetAudioCodecIndex(int nOldIndex, int nNewIndex);
Parameters
Parameters | Description
nOldIndex | Old index of the codec
nNewIndex | New index of the codec
Description

Set audio codec index

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


SetVideoCodecIndex Method
Methods See Also Send Feedback

Set video codec index

C++
HRESULT SetVideoCodecIndex(INT nOldIndex, INT nNewIndex);
C#
int SetVideoCodecIndex(int nOldIndex, int nNewIndex);
Parameters
Parameters | Description
nOldIndex | Old index of the codec
nNewIndex | New index of the codec
Description

Set video codec index

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


StartVideo Method
Methods See Also Send Feedback

Start sending video

C++
HRESULT StartVideo(INT nLine);
C#
int StartVideo(int nLine);
Parameters
Parameters | Description
nLine | Line index
Description

Start sending video

Notes

Disabled in audio-only edition

See Also

Methods VoIP Video SIP SDK

Group

Methods

Links
Methods, See Also


Properties
Reference Topics See Also Send Feedback

SIP SDK properties

Description

SIP SDK properties

  • LastError - Last error description
  • IsPlaying - Indicates whether WAV file is being played on active phone line
  • PhoneLine - Active phone line index
  • MaxPhoneLines - Total count of phone lines
  • RegisterExpiration - Expiration period for registration
  • UDPPort - UDP port
  • TCPPort - TCP port
  • ForwardURI - Forward URI
  • NATKeepAlive - Keep-Alive interval for NAT traversal
  • RtpPortStart - Starting port for inbound RTP traffic
  • OutDevNum - Number of output devices available
  • InDevNum - Number of input devices available
  • DndEnabled - Enable/Disable DND (Do Not Disturb)
  • OutputDeviceName - Name for output device
  • InputDeviceName - Name for input device
  • IsInitialized - True if SIP SDK was successfully initialized
  • PlayRingtone - Enable/Disable playing ring tones
  • AGC - Enable/Disable AGC (Automatic Gain Control)
  • AEC - Enable/Disable AEC (Acoustic Echo Cancellation)
  • NoiseReduction - Enable/Disable Noise Reduction
  • EchoTail - Length (in ms) of the echo canceling filter (also known as tail length)
  • SpeakerVolume - Speaker volume (0..100)
  • MicrophoneVolume - Microphone volume (0..100)
  • SpeakerMuted - Speaker mute state
  • MicrophoneMuted - Microphone mute state
  • SpeakerEnergy - Volume from speaker volume meter (0-100)
  • MicrophoneEnergy - Volume from microphone volume meter (0-100)
  • VoiceCodecCount - Count of voice codecs
  • VideoCodecCount - Count of video codecs
  • CallState - Call state at given line
  • RemoteURI - Remote URI at given line
  • LineResponseCode - SIP response code (if available)
  • LineResponseText - SIP response text (if available)
  • RegistrationResponseCode - SIP response code (if available)
  • RegistrationResponseText - SIP response text (if available)
  • LogEnabled - Enable/Disable logging
  • DisplayName - Display name
  • UserID - User ID
  • LoginID - Authentication ID
  • Password - Password
  • Realm - Realm for which the login ID and password are valid. Empty for automatic realm
  • RegistrationProxy - SIP registration proxy
  • OutboundProxy - Outbound-Proxy
  • SipAccountCount - Count of SIP accounts
  • ActiveSipAccount - Active SIP account
  • AcceptLanguage - Accept Language used in SIP messages
  • NegotiatedCodecName - Negotiated codec name
  • LocalIPsCount - Number of local IPs found by the system
  • LocalIP - Local IP address
  • NetworkAdapter - Network adapter name
  • Identity - Information about the UAC originating the request
  • RingtoneFile - Default ring/alert tone audio file
  • CameraInUse - Indicates whether camera is used by other application
  • PreviewWindow - Video preview window
  • OutputWindow - Video output window
  • VideoMaxBitrate - Max video bitrate
  • VideoFrameSize - Video frame size
  • AutoStartSendingVideo - Automatically start sending video
  • CaptureDevNum - Number of video capture devices
  • CaptureDeviceName - Selected video capture device
See Also

VoIP Video SIP SDK

Group

Reference

Topics
Name | Description
LastError Property | Last error description
IsPlaying Property | Indicates whether WAV file is being played on active phone line
PhoneLine Property | Active phone line index
MaxPhoneLines Property | Total count of phone lines
RegisterExpiration Property | Expiration period for registration in seconds
UDPPort Property | UDP port
TCPPort Property | TCP port
ForwardURI Property | Forward URI
NATKeepAlive Property | Keep-Alive interval for NAT traversal, in seconds
RtpPortStart Property | Starting port for inbound RTP traffic
OutDevNum Property | Number of output devices available
InDevNum Property | Number of input devices available
DndEnabled Property | Enable/Disable DND (Do Not Disturb)
OutputDeviceName Property | Name for output device
InputDeviceName Property | Name for input device
IsInitialized Property | True if SIP SDK was successfully initialized
PlayRingtone Property | Enable/Disable playing ring tones
AGC Property | Enable/Disable AGC (Automatic Gain Control)
AEC Property | Enable/Disable AEC (Acoustic Echo Cancellation)
NoiseReduction Property | Enable/Disable Noise Reduction
EchoTail Property | Length (in ms) of the echo canceling filter (also known as tail length)
SpeakerVolume Property | Speaker volume (0..100)
MicrophoneVolume Property | Microphone volume (0..100)
SpeakerMuted Property | Speaker mute state
MicrophoneMuted Property | Microphone mute state
SpeakerEnergy Property | Volume from speaker volume meter (0-100)
MicrophoneEnergy Property | Volume from microphone volume meter (0-100)
VoiceCodecCount Property | Count of voice codecs
CallState Property | Call state at given line
RemoteURI Property | Remote URI at given line
LineResponseCode Property | SIP response code (if available)
LineResponseText Property | SIP response text (if available)
RegistrationResponseCode Property | SIP response code (if available)
RegistrationResponseText Property | SIP response text (if available)
LogEnabled Property | Enable/Disable logging
DisplayName Property | Display name
UserID Property | User ID
LoginID Property | Authentication ID
Password Property | Password
Realm Property | Realm for which the login ID and password are valid. Empty for automatic realm
RegistrationProxy Property | SIP registration proxy
OutboundProxy Property | Outbound proxy
AcceptLanguage Property | Accept Language used in SIP messages
NegotiatedCodecName Property | Negotiated codec name
NegotiatedPayloadType Property | Negotiated payload type
LocalIPsCount Property | Number of local IPs found by the system
LocalIP Property | Local IP address
NetworkAdapter Property | Network adapter name
Identity Property | Information about the UAC originating the request
RingtoneFile Property | Default ring/alert tone audio file
VideoCodecCount Property | Count of video codecs
CameraInUse Property | Indicates whether camera is used by other application
PreviewWindow Property | Video preview window
OutputWindow Property | Video output window
CaptureDevNum Property | Number of video capture devices
CaptureDeviceName Property | Selected video capture device
SipAccountCount Property | SIP account count
ActiveSipAccount Property | Active SIP account
VideoFrameSize Property | Video frame size
VideoMaxBitrate Property | Max video bitrate
AutoStartSendingVideo Property | Automatically start sending video
Links
Reference, Topics, See Also


LastError Property
Properties See Also Send Feedback

Last error description

C++
HRESULT get_LastError(BSTR* psLastError);
C#
readonly string LastError;
Description

Last error description

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


IsPlaying Property
Properties See Also Send Feedback

Indicates whether WAV file is being played on active phone line

C++
HRESULT get_IsPlaying(VARIANT_BOOL* pbIsPlaying);
C#
readonly bool IsPlaying;
Description

Indicates whether WAV file is being played on active phone line

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


PhoneLine Property
Properties See Also Send Feedback

Active phone line index

C++
HRESULT get_PhoneLine(INT* pnPhoneLine);
HRESULT put_PhoneLine(INT nPhoneLine);
C#
int PhoneLine;
Description

Active phone line index

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


MaxPhoneLines Property
Properties See Also Send Feedback

Total count of phone lines

C++
HRESULT get_MaxPhoneLines(INT* pnMaxPhoneLines);
HRESULT put_MaxPhoneLines(INT nMaxPhoneLines);
C#
int MaxPhoneLines;
Description

Total count of phone lines

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RegisterExpiration Property
Properties See Also Send Feedback

Expiration period for registration in seconds

C++
HRESULT get_RegisterExpiration(INT* pnRegisterExpiration);
HRESULT put_RegisterExpiration(INT nRegisterExpiration);
C#
int RegisterExpiration;
Description

Expiration period for registration in seconds

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


UDPPort Property
Properties See Also Send Feedback

UDP port

C++
HRESULT get_UDPPort(INT* pnUDPPort);
HRESULT put_UDPPort(INT nUDPPort);
C#
int UDPPort;
Description

UDP port

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


TCPPort Property
Properties See Also Send Feedback

TCP port

C++
HRESULT get_TCPPort(INT* pnTCPPort);
HRESULT put_TCPPort(INT nTCPPort);
C#
int TCPPort;
Description

TCP port

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


ForwardURI Property
Properties See Also Send Feedback

Forward URI

C++
HRESULT get_ForwardURI(BSTR* psForwardURI);
HRESULT put_ForwardURI(BSTR sForwardURI);
C#
string ForwardURI;
Description

Forward URI

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


NATKeepAlive Property
Properties See Also Send Feedback

Keep-Alive interval for NAT traversal, in seconds

C++
HRESULT get_NATKeepAlive(INT* pnNATKeepAlive);
HRESULT put_NATKeepAlive(INT nNATKeepAlive);
C#
int NATKeepAlive;
Description

Keep-Alive interval for NAT traversal, in seconds

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RtpPortStart Property
Properties See Also Send Feedback

Starting port for inbound RTP traffic

C++
HRESULT get_RtpPortStart(INT* pnRtpPortStart);
HRESULT put_RtpPortStart(INT nRtpPortStart);
C#
int RtpPortStart;
Description

SIP SDK uses ports starting at RtpPortStart and ending at (RtpPortStart + 2 * MaxConnections) - 1

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


OutDevNum Property
Properties See Also Send Feedback

Number of output devices available

C++
HRESULT get_OutDevNum(INT* pnOutDevNum);
C#
readonly int OutDevNum;
Description

Number of output devices available

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


InDevNum Property
Properties See Also Send Feedback

Number of input devices available

C++
HRESULT get_InDevNum(INT* pnInDevNum);
C#
readonly int InDevNum;
Description

Number of input devices available

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


DndEnabled Property
Properties See Also Send Feedback

Enable/Disable DND (Do Not Disturb)

C++
HRESULT get_DndEnabled(VARIANT_BOOL* pbEnabled);
HRESULT put_DndEnabled(VARIANT_BOOL bEnabled);
C#
bool DndEnabled;
Description

Enable/Disable DND (Do Not Disturb)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


OutputDeviceName Property
Properties See Also Send Feedback

Name for output device

C++
HRESULT get_OutputDeviceName();
HRESULT put_OutputDeviceName();
C#
string OutputDeviceName;
Description

Name for output device

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


InputDeviceName Property
Properties See Also Send Feedback

Name for input device

C++
HRESULT get_InputDeviceName(BSTR* psInputDeviceName);
HRESULT put_InputDeviceName(BSTR sInputDeviceName);
C#
string InputDeviceName;
Description

Name for input device

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


IsInitialized Property
Properties See Also Send Feedback

True if SIP SDK was successfully initialized

C++
HRESULT get_IsInitialized(VARIANT_BOOL* pbIsInitialized);
HRESULT put_IsInitialized(VARIANT_BOOL bIsInitialized);
C#
readonly bool IsInitialized;
Description

True if SIP SDK was successfully initialized

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


PlayRingtone Property
Properties See Also Send Feedback

Enable/Disable playing ring tones

C++
HRESULT get_PlayRingtone(VARIANT_BOOL* pbPlayRingtone);
HRESULT put_PlayRingtone(VARIANT_BOOL bPlayRingtone);
C#
bool PlayRingtone;
Description

Enable/Disable playing ring tones

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


AGC Property
Properties See Also Send Feedback

Enable/Disable AGC (Automatic Gain Control)

C++
HRESULT get_AGC(VARIANT_BOOL* pbEnabled);
HRESULT put_AGC(VARIANT_BOOL bEnabled);
C#
bool AGC;
Description

Enable/Disable AGC (Automatic Gain Control)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


AEC Property
Properties See Also Send Feedback

Enable/Disable AEC (Acoustic Echo Cancellation)

C++
HRESULT get_AEC(VARIANT_BOOL* pbEnabled);
HRESULT put_AEC(VARIANT_BOOL bEnabled);
C#
bool AEC;
Description

Enable/Disable AEC (Acoustic Echo Cancellation)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


NoiseReduction Property
Properties See Also Send Feedback

Enable/Disable Noise Reduction

C++
HRESULT get_NoiseReduction(VARIANT_BOOL* pbEnabled);
HRESULT put_NoiseReduction(VARIANT_BOOL bEnabled);
C#
bool NoiseReduction;
Description

Enable/Disable Noise Reduction

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


EchoTail Property
Properties See Also Send Feedback

Length (in ms) of the echo canceling filter (also known as tail length)

C++
HRESULT get_EchoTail();
HRESULT put_EchoTail();
C#
int EchoTail;
Description

Length (in ms) of the echo canceling filter (also known as tail length)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


SpeakerVolume Property
Properties See Also Send Feedback

Speaker volume (0..100)

C++
HRESULT get_SpeakerVolume(INT* pnVolume);
HRESULT put_SpeakerVolume(INT nVolume);
C#
int SpeakerVolume;
Description

Speaker volume (0..100)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


MicrophoneVolume Property
Properties See Also Send Feedback

Microphone volume (0..100)

C++
HRESULT get_MicrophoneVolume(INT* pnVolume);
HRESULT put_MicrophoneVolume(INT nVolume);
C#
int MicrophoneVolume;
Description

Microphone volume (0..100)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


SpeakerMuted Property
Properties See Also Send Feedback

Speaker mute state

C++
HRESULT get_SpeakerMuted(VARIANT_BOOL* pbMuted);
HRESULT put_SpeakerMuted(VARIANT_BOOL bMuted);
C#
bool SpeakerMuted;
Description

Speaker mute state

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


MicrophoneMuted Property
Properties See Also Send Feedback

Microphone mute state

C++
HRESULT get_MicrophoneMuted(VARIANT_BOOL* pbMuted);
HRESULT put_MicrophoneMuted(VARIANT_BOOL bMuted);
C#
bool MicrophoneMuted;
Description

Microphone mute state

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


SpeakerEnergy Property
Properties See Also Send Feedback

Volume from speaker volume meter (0-100)

C++
HRESULT get_SpeakerEnergy(DOUBLE* pbLevel);
C#
readonly double SpeakerEnergy;
Description

Volume from speaker volume meter (0-100)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


MicrophoneEnergy Property
Properties See Also Send Feedback

Volume from microphone volume meter (0-100)

C++
HRESULT get_MicrophoneEnergy(DOUBLE* pbLevel);
C#
readonly double MicrophoneEnergy;
Description

Volume from microphone volume meter (0-100)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


VoiceCodecCount Property
Properties See Also Send Feedback

Count of voice codecs

C++
HRESULT get_VoiceCodecCount();
C#
readonly int VoiceCodecCount;
Description

Count of voice codecs

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


CallState Property
Properties See Also Send Feedback

Call state at given line

C++
HRESULT get_CallState(INT nLine, CallState* pcsCallState);
C#
CallState get_CallState(int nLine);
Description

Call state at given line

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RemoteURI Property
Properties See Also Send Feedback

Remote URI at given line

C++
HRESULT get_RemoteURI(INT nLine, BSTR* psRemoteURI);
C#
string get_RemoteURI(int nLine);
Description

Remote URI at given line

See Also

Properties VoIP Video SIP SDK CallState

Group

Properties

Links
Properties, See Also


LineResponseCode Property
Properties See Also Send Feedback

SIP response code (if available)

C++
HRESULT get_LineResponseCode(INT nLine, INT* pnResponseCode);
C#
readonly int get_LineResponseCode(int nLine);
Description

SIP response code (if available)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


LineResponseText Property
Properties See Also Send Feedback

SIP response text (if available)

C++
HRESULT get_LineResponseText(nLine, BSTR* psResponseText);
C#
readonly string get_LineResponseText(int nLine);
Description

SIP response text (if available)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RegistrationResponseCode Property
Properties See Also Send Feedback

SIP response code (if available)

C++
HRESULT get_RegistrationResponseCode(INT* pnResponseCode);
C#
readonly int RegistrationResponseCode;
Description

SIP response code (if available)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RegistrationResponseText Property
Properties See Also Send Feedback

SIP response text (if available)

C++
HRESULT get_RegistrationResponseText(BSTR* psResponseText);
C#
readonly string RegistrationResponseText;
Description

SIP response text (if available)

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


LogEnabled Property
Properties See Also Send Feedback

Enable/Disable logging

C++
HRESULT get_LogEnabled(VARIANT_BOOL* pbLogEnabled);
HRESULT put_LogEnabled(VARIANT_BOOL bLogEnabled);
C#
bool LogEnabled;
Description

Enable/Disable logging

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


DisplayName Property
Properties See Also Send Feedback

Display name

C++
HRESULT get_DisplayName(BSTR* psDisplayName);
HRESULT put_DisplayName(BSTR sDisplayName);
C#
string DisplayName;
Description

Display name

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


UserID Property
Properties See Also Send Feedback

User ID

C++
HRESULT get_UserID(BSTR* psUserID);
HRESULT put_UserID(BSTR sUserID);
C#
string UserID;
Description

User ID

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


LoginID Property
Properties See Also Send Feedback

Authentication ID

C++
HRESULT get_LoginID(BSTR* psLoginID);
HRESULT put_LoginID(BSTR sLoginID);
C#
string LoginID;
Description

Authentication ID

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


Password Property
Properties See Also Send Feedback

Password

C++
HRESULT get_Password(BSTR* psPassword);
HRESULT put_Password(BSTR sPassword);
C#
string Password;
Description

Password

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


Realm Property
Properties See Also Send Feedback

Realm for which the login ID and password are valid. Empty for automatic realm

C++
HRESULT get_Realm(BSTR* psRealm);
HRESULT put_Realm(BSTR sRealm);
C#
string Realm;
Description

Realm for which the login ID and password are valid. Empty for automatic realm

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RegistrationProxy Property
Properties See Also Send Feedback

SIP registration proxy

C++
HRESULT get_RegistrationProxy(BSTR* psRegistrationProxy);
HRESULT put_RegistrationProxy(BSTR sRegistrationProxy);
C#
string RegistrationProxy;
Description

SIP registration proxy

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


OutboundProxy Property
Properties See Also Send Feedback

Outbound proxy

C++
HRESULT get_OutboundProxy(BSTR* psOutboundProxy);
HRESULT put_OutboundProxy(BSTR sOutboundProxy);
C#
string OutboundProxy;
Description

Outbound proxy

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


AcceptLanguage Property
Properties See Also Send Feedback

Accept Language used in SIP messages

C++
HRESULT get_AcceptLanguage(BSTR* psAcceptLanguage);
HRESULT put_AcceptLanguage(BSTR sAcceptLanguage);
C#
string AcceptLanguage;
Description

Accept Language used in SIP messages

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


NegotiatedCodecName Property
Properties See Also Send Feedback

Negotiated codec name

C++
HRESULT get_NegotiatedCodecName(INT nLine, BSTR* psCodecName);
C#
string get_NegotiatedCodecName(int nLine);
Description

Negotiated codec name

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


NegotiatedPayloadType Property
Properties See Also Send Feedback

Negotiated payload type

C++
HRESULT get_NegotiatedPayloadType(INT nLine, INT* pnPayloadType);
C#
get_NegotiatedPayloadType(int nLine);
Description

Negotiated payload type

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


LocalIPsCount Property
Properties See Also Send Feedback

Number of local IPs found by the system

C++
HRESULT get_LocalIPsCount(INT* pnLocalIPsCount);
C#
readonly int LocalIPsCount;
Description

Number of local IPs found by the system

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


LocalIP Property
Properties See Also Send Feedback

Local IP address

C++
HRESULT get_LocalIP(INT nIndex, BSTR* psLocalIP);
C#
string get_LocalIP(int nIndex);
Description

Local IP address

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


NetworkAdapter Property
Properties See Also Send Feedback

Network adapter name

C++
HRESULT get_NetworkAdapter(INT nIndex, BSTR* psNetworkAdapter);
C#
string get_NetworkAdapter(int nIndex);
Description

Network adapter name

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


Identity Property
Properties See Also Send Feedback

Information about the UAC originating the request

C++
HRESULT get_Identity(BSTR* psIdentity);
HRESULT put_Identity(BSTR sIdentity);
C#
string Identity;
Description

Information about the UAC originating the request

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


RingtoneFile Property
Properties See Also Send Feedback

Default ring/alert tone audio file

C++
HRESULT get_RingtoneFile(BSTR* psRingtoneFile);
HRESULT put_RingtoneFile(BSTR sRingtoneFile);
C#
string RingtoneFile;
Description

Default ring/alert tone audio file

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


VideoCodecCount Property
Properties See Also Send Feedback

Count of video codecs

C++
HRESULT get_VideoCodecCount();
C#
readonly int VideoCodecCount;
Description

Count of video codecs

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


CameraInUse Property
Properties See Also Send Feedback

Indicates whether camera is used by other application

C++
HRESULT get_CameraInUse(VARIANTBOOL* pbCameraInUse);
C#
bool get_CameraInUse(int nLine);
Description

Indicates whether camera is used by other application

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


PreviewWindow Property
Properties See Also Send Feedback

Video preview window

C++
HRESULT get_PreviewWindow(BSTR* psPreviewWindow);
HRESULT put_PreviewWindow(BSTR sPreviewWindow);
C#
string PreviewWindow;
Description

Video preview window

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


OutputWindow Property
Properties See Also Send Feedback

Video output window

C++
HRESULT get_OutputWindow(BSTR* psOutputWindow);
HRESULT put_OutputWindow(BSTR sOutputWindow);
C#
string OutputWindow;
Description

Video output window

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


CaptureDevNum Property
Properties See Also Send Feedback

Number of video capture devices

C++
HRESULT get_CaptureDevNum(INT* psCaptureDevNum);
C#
readonly int CaptureDevNum;
Description

Number of video capture devices

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


CaptureDeviceName Property
Properties See Also Send Feedback

Selected video capture device

C++
HRESULT get_CaptureDeviceName(BSTR* psCaptureDeviceName);
HRESULT put_CaptureDeviceName(BSTR sCaptureDeviceName);
C#
string CaptureDeviceName;
Description

Selected video capture device

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


SipAccountCount Property
Properties See Also Send Feedback

SIP account count

C++
HRESULT get_SipAccountCount(INT* pnCount);
C#
readonly int SipAccountCount;
Description

SIP account count

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


ActiveSipAccount Property
Properties See Also Send Feedback

Active SIP account

C++
HRESULT get_ActiveSipAccount(INT* pnActiveSipAccount);
HRESULT put_ActiveSipAccount(INT nActiveSipAccount);
C#
int ActiveSipAccount;
Description

Active SIP account

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


VideoFrameSize Property
Properties See Also Send Feedback

Video frame size

C++
HRESULT get_VideoFrameSize(VideoFrameFormat* pvffVideoFrameSize);
HRESULT put_VideoFrameSize(VideoFrameFormat vffVideoFrameSize);
C#
VideoFrameFormat VideoFrameSize;
Description

Video frame size

Notes

Disabled in audio-only edition

See Also

Video frame format Max video bitrate Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


VideoMaxBitrate Property
Properties See Also Send Feedback

Max video bitrate

C++
HRESULT get_VideoMaxBitrate(INT* pnVideoMaxBitrate);
HRESULT put_VideoMaxBitrate(INT nVideoMaxBitrate);
C#
int VideoMaxBitrate;
Description

Max video bitrate

Notes

Disabled in audio-only edition

See Also

Video frame format Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


AutoStartSendingVideo Property
Properties See Also Send Feedback

Automatically start sending video

C++
HRESULT get_AutoStartSendingVideo(VARIANT_BOOL* pbAutoStartSendingVideo);
HRESULT put_AutoStartSendingVideo(VARIANT_BOOL bAutoStartSendingVideo);
C#
bool AutoStartSendingVideo;
Description

Automatically start sending video

Notes

Disabled in audio-only edition

See Also

Properties VoIP Video SIP SDK

Group

Properties

Links
Properties, See Also


Events
Reference Topics See Also Send Feedback

SIP SDK events

Description

SIP SDK events

  • OnStunSuccess - STUN binding has been obtained successfully
  • OnStunFailure - Unable to obtain STUN binding
  • OnRegistrationSuccess - Successfully registered
  • OnRegistrationFailure - Failed to register
  • OnUnregistration - Successfully un-registered
  • OnReregistration - Successfully re-registered
  • OnAlerting - Call has been accepted and the application should alert the end user
  • OnConnected - Call has been setup between the local and remote party
  • OnRedirectSuccess - The transfer was completed successfully
  • OnRedirectFailure - Failed to transfer call
  • OnDTMF - DTMF detected
  • OnTerminatedLine - Call was disconnected or failed to connect
  • OnConnectingLine - Connecting to remote participant
  • OnPlayfileStop - File has completed playing or was aborted
  • OnHold - Call is locally held
  • OnRemoteHold - The remote party is on hold
  • OnPIMIncomingMessage - Incoming text message
  • OnLocalMediaStarted - Local media is being sent to the remote party
  • OnLocalMediaStoped - Local media is no longer being sent to the remote party
  • OnRemoteMediaStarted - Remote media is ready to be received
  • OnRemoteMediaStoped - Remote media has been stopped due to a hold or call tear down
  • OnPostPagerMessageResult - Result of asynchronous message post
  • OnOutgoingSipRequest - Outgoing SIP request message. You must handle this event as soon as possible
  • OnOutgoingSipResponse - Outgoing SIP response message. You must handle this event as soon as possible
  • OnIncomingSipRequest - Incoming SIP request message. You must handle this event as soon as possible
  • OnIncomingSipResponse - Incoming SIP response message. You must handle this event as soon as possible
See Also

VoIP Video SIP SDK

Group

Reference

Topics
Name | Description
OnStunSuccess Event | STUN binding has been obtained successfully
OnStunFailure Event | Unable to obtain STUN binding
OnRegistrationSuccess Event | Successfully registered
OnRegistrationFailure Event | Failed to register
OnUnregistration Event | Successfully un-registered
OnReregistration Event | Successfully re-registered
OnAlerting Event | Call has been accepted and the application should alert the end user
OnConnected Event | Call has been setup between the local and remote party
OnRedirectSuccess Event | The transfer was completed successfully
OnRedirectFailure Event | Failed to transfer call
OnDTMF Event | DTMF detected
OnTerminatedLine Event | Call was disconnected or failed to connect
OnConnectingLine Event | Connecting to remote participant
OnPlayfileStop Event | File has completed playing or was aborted
OnHold Event | Call is locally held
OnRemoteHold Event | The remote party is on hold
OnPIMIncomingMessage Event | Incoming text message
OnLocalMediaStarted Event | Local media is being sent to the remote party
OnLocalMediaStoped Event | Local media is no longer being sent to the remote party
OnRemoteMediaStarted Event | Remote media is ready to be received
OnRemoteMediaStoped Event | Remote media has been stopped due to a hold or call tear down
OnPostPagerMessageResult Event | Result of asynchronous message post
OnOutgoingSipRequest Event | Outgoing SIP request message. You must handle this event as soon as possible
OnOutgoingSipResponse Event | Outgoing SIP response message. You must handle this event as soon as possible
OnIncomingSipRequest Event | Incoming SIP request message. You must handle this event as soon as possible
OnIncomingSipResponse Event | Incoming SIP response message. You must handle this event as soon as possible
Links
Reference, Topics, See Also


OnStunSuccess Event
Events See Also Send Feedback

STUN binding has been obtained successfully

C++
__event void OnStunSuccess();
C#
event void OnStunSuccess();
Description

STUN binding has been obtained successfully

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnStunFailure Event
Events See Also Send Feedback

Unable to obtain STUN binding

C++
__event void OnStunFailure();
C#
event void OnStunFailure();
Description

Unable to obtain STUN binding

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRegistrationSuccess Event
Events See Also Send Feedback

Successfully registered

C++
__event void OnRegistrationSuccess(BSTR sLocalURI);
C#
event void OnRegistrationSuccess(string sLocalURI);
Parameters
Parameters | Description
sLocalURI | Local participant SIP URI
Description

Successfully registered

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRegistrationFailure Event
Events See Also Send Feedback

Failed to register

C++
__event void OnRegistrationFailure(BSTR sLocalURI, INT nCause);
C#
event void OnRegistrationFailure(string sLocalURI, int nCause);
Parameters
Parameters | Description
sLocalURI | Local participant SIP URI
nCause | Failure code
Description

Failed to register

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnUnregistration Event
Events See Also Send Feedback

Successfully un-registered

C++
__event void OnUnregistration(BSTR sLocalURI);
C#
event void OnUnregistration(string sLocalURI);
Parameters
Parameters | Description
sLocalURI | Local participant SIP URI
Description

Successfully un-registered

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnReregistration Event
Events See Also Send Feedback

Successfully re-registered

C++
__event void OnReregistration(BSTR sLocalURI, INT nRetries);
C#
event void OnReregistration(string sLocalURI, int nRetries);
Parameters
Parameters | Description
nRetries | Number of retries
sLocalURI | Local participant SIP URI
Description

Successfully re-registered

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnAlerting Event
Events See Also Send Feedback

Call has been accepted and the application should alert the end user

C++
__event void OnAlerting(BSTR sFromURI, BSTR sLocalURI, INT nLine);
C#
event void OnAlerting(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Call has been accepted and the application should alert the end user

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnConnected Event
Events See Also Send Feedback

Call has been setup between the local and remote party

C++
__event void OnConnected(BSTR sFromURI, BSTR sLocalURI, INT nLine);
C#
event void OnConnected(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Call has been setup between the local and remote party

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRedirectSuccess Event
Events See Also Send Feedback

The transfer was completed successfully

C++
__event void OnRedirectSuccess(BSTR sLocalURI, INT nLine);
C#
event void OnRedirectSuccess(string sLocalURI, int nLine);
Parameters
Parameters | Description
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

The transfer was completed successfully

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRedirectFailure Event
Events See Also Send Feedback

Failed to transfer call

C++
__event void OnRedirectFailure(BSTR sLocalURI, INT nLine);
C#
event void OnRedirectFailure(string sLocalURI, int nLine);
Parameters
Parameters | Description
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Failed to transfer call

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnDTMF Event
Events See Also Send Feedback

DTMF detected

C++
__event void OnDTMF(BSTR sFromURI, BSTR sLocalURI, INT nLine, INT nSignal);
C#
event void OnDTMF(string sFromURI, string sLocalURI, int nLine, int nSignal);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
nSignal | DTMF signal
Description

DTMF detected

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnTerminatedLine Event
Events See Also Send Feedback

Call was disconnected or failed to connect

C++
__event void OnTerminatedLine(BSTR sFromURI, BSTR sLocalURI, INT nStatusCode, BSTR sStatusText, INT nLine);
C#
event void OnTerminatedLine(string sFromURI, string sLocalURI, int nStatusCode, string sStatusText, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
sStatusText | Call end description
nStatusCode | Call end code
nLine | Phone line number
Description

Call was disconnected or failed to connect

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnConnectingLine Event
Events See Also Send Feedback

Connecting to remote participant

C++
__event void OnConnectingLine(BSTR sFromURI, BSTR sLocalURI, INT nLine);
C#
event void OnConnectingLine(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Connecting to remote participant

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnPlayfileStop Event
Events See Also Send Feedback

File has completed playing or was aborted

C++
__event void OnPlayfileStop(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnPlayfileStop(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

File has completed playing or was aborted

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnHold Event
Events See Also Send Feedback

Call is locally held

C++
__event void OnHold(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnHold(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Call is locally held

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRemoteHold Event
Events See Also Send Feedback

The remote party is on hold

C++
__event void OnRemoteHold(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnRemoteHold(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

The remote party is on hold

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnPIMIncomingMessage Event
Events See Also Send Feedback

Incoming text message

C++
__event void OnPIMIncomingMessage(BSTR sFromURI, BSTR sSubject, BSTR sMessage);
C#
event void OnPIMIncomingMessage(string sFromURI, string sSubject, string sMessage);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sSubject | Message subject
sMessage | Message body
Description

Incoming text message

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnLocalMediaStarted Event
Events See Also Send Feedback

Local media is being sent to the remote party

C++
__event void OnLocalMediaStarted(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnLocalMediaStarted(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Local media is being sent to the remote party

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnLocalMediaStoped Event
Events See Also Send Feedback

Local media is no longer being sent to the remote party

C++
__event void OnLocalMediaStoped(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnLocalMediaStoped(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Local media is no longer being sent to the remote party

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRemoteMediaStarted Event
Events See Also Send Feedback

Remote media is ready to be received

C++
__event void OnRemoteMediaStarted(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnRemoteMediaStarted(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Remote media is ready to be received

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnRemoteMediaStoped Event
Events See Also Send Feedback

Remote media has been stopped due to a hold or call tear down

C++
__event void OnRemoteMediaStoped(BSTR sFromURI, BSTR sLocalURI, int nLine);
C#
event void OnRemoteMediaStoped(string sFromURI, string sLocalURI, int nLine);
Parameters
Parameters | Description
sFromURI | Remote participant SIP URI
sLocalURI | Local participant SIP URI
nLine | Phone line number
Description

Remote media has been stopped due to a hold or call tear down

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnPostPagerMessageResult Event
Events See Also Send Feedback

Result of asynchronous message post

C++
__event void OnPostPagerMessageResult(BSTR sRemoteURI, BSTR sMessageText, INT nStatusCode, BSTR sStatusText);
C#
event void OnPostPagerMessageResult(sRemoteURI, BSTR sMessageText, INT nStatusCode, BSTR sStatusText);
Parameters
Parameters | Description
sRemoteURI | Remote participant SIP URI
sMessageText | Message body
nStatusCode | SIP status code
sStatusText | SIP status description
Description

Result of asynchronous message post

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnOutgoingSipRequest Event
Events See Also Send Feedback

Outgoing SIP request message. You must handle this event as soon as possible

C++
__event void OnOutgoingSipRequest(BSTR sRemoteAddress, INT nRemotePort, BSTR* psSIPMessage);
C#
event void OnOutgoingSipRequest(string sRemoteAddress, int nRemotePort, ref string psSIPMessage);
Parameters
Parameters | Description
sRemoteAddress | Remote address
nRemotePort | Remote port
psSIPMessage | SIP request message
Description

Outgoing SIP request message. You must handle this event as soon as possible

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnOutgoingSipResponse Event
Events See Also Send Feedback

Outgoing SIP response message. You must handle this event as soon as possible

C++
__event void OnOutgoingSipResponse(BSTR sRemoteAddress, INT nRemotePort, BSTR* psSIPMessage);
C#
event void OnOutgoingSipResponse(string sRemoteAddress, int nRemotePort, ref string psSIPMessage);
Parameters
Parameters | Description
sRemoteAddress | Remote address
nRemotePort | Remote port
psSIPMessage | SIP request message
Description

Outgoing SIP response message. You must handle this event as soon as possible

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnIncomingSipRequest Event
Events See Also Send Feedback

Incoming SIP request message. You must handle this event as soon as possible

C++
__event void OnIncomingSipRequest(BSTR sRemoteAddress, INT nRemotePort, BSTR* psSIPMessage);
C#
event void OnIncomingSipRequest(string sRemoteAddress, int nRemotePort, ref string psSIPMessage);
Parameters
Parameters | Description
sRemoteAddress | Remote address
nRemotePort | Remote port
psSIPMessage | SIP request message
Description

Incoming SIP request message. You must handle this event as soon as possible

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


OnIncomingSipResponse Event
Events See Also Send Feedback

Incoming SIP response message. You must handle this event as soon as possible

C++
__event void OnIncomingSipResponse(BSTR sRemoteAddress, INT nRemotePort, BSTR* psSIPMessage);
C#
event void OnIncomingSipResponse(string sRemoteAddress, int nRemotePort, ref string psSIPMessage);
Parameters
Parameters | Description
sRemoteAddress | Remote address
nRemotePort | Remote port
psSIPMessage | SIP request message
Description

Incoming SIP response message. You must handle this event as soon as possible

See Also

Events VoIP Video SIP SDK

Group

Events

Links
Events, See Also


CallState
Reference Send Feedback

Call state

C++
enum CallState {
   CallState_Inbound,
   CallState_Outbound,
   CallState_Connected,
   CallState_Conferenced,
   CallState_LocalHeld,
   CallState_RemoteHeld,
   CallState_Transferring,
   CallState_Free,
};
C#
enum CallState {
   CallState_Inbound,
   CallState_Outbound,
   CallState_Connected,
   CallState_Conferenced,
   CallState_LocalHeld,
   CallState_RemoteHeld,
   CallState_Transferring,
   CallState_Free,
};
Description

Enum Items:

  • CallState_Inbound - Incoming call
  • CallState_Outbound - Outgoing call
  • CallState_Connected - Connected
  • CallState_Conferenced - Conferenced
  • CallState_LocalHeld - Call is put on local hold
  • CallState_RemoteHeld - Call is put on remote hold
  • CallState_Transfering - Call is being transfered
  • CallState_Free - Free
Group

Reference

Links
Reference


VideoFrameFormat
Reference Send Feedback

Video frame format.

C++
enum VideoFrameFormat {
   VideoFrameFormat_SQCIF,
   VideoFrameFormat_QCIF,
   VideoFrameFormat_QVGA,
   VideoFrameFormat_CIF,
   VideoFrameFormat_VGA,
   VideoFrameFormat_4CIF,
   VideoFrameFormat_16CIF,
};
C#
enum VideoFrameFormat {
   VideoFrameFormat_SQCIF,
   VideoFrameFormat_QCIF,
   VideoFrameFormat_QVGA,
   VideoFrameFormat_CIF,
   VideoFrameFormat_VGA,
   VideoFrameFormat_4CIF,
   VideoFrameFormat_16CIF,
};
Description

Enum Items:

  • VideoFrameFormat_SQCIF - 128 X 96
  • VideoFrameFormat_QCIF - 176 X 144
  • VideoFrameFormat_QVGA - 320 X 240
  • VideoFrameFormat_CIF - 352 X 288
  • VideoFrameFormat_VGA - 640 X 480
  • VideoFrameFormat_4CIF - 704 X 576
  • VideoFrameFormat_16CIF - 1408 X 1152
Group

Reference

Links
Reference


Technical support
Send Feedback

In case you would like to download latest version of Conaito VoIP Video SIP SDK , find out relative information, or license this SDK, please visit [image] our website

Our technical support staff will provide timely service on your problems encountered during using our product.

Please provide the following information when you submit your questions:

  • The installed version of Conaito VoIP Video SIP SDK
  • The installed type and version of your operation system
  • The details of the problem you encounter. And if it is possible, please inform us how to reproduce this problem
  • Please provide your license informations in case you have a licensed SDK

and our technical support staff will deal with your problem with priority.

At the meanwhile, it's our pleasure and honor to receive any comments and suggestions from you.


Our Service for your Solutions
Send Feedback

There is no doubt that "Voice over IP" telephony applications are increasing in importance. The strong demand is reflected in the steep upward trends in take-up. Significant costs can be saved and profits increased through VoIP. We offer a professional support for your projects and solutions to help you realize these benefits. Our experienced development team can assist you modify one of our SDKs or help with advice on how to design your own solutions within other applications.

There are many advantages to be gained for your business, or your own customers, through a range of possible solutions including:

  • Direct voice access

The convenience of free and instantaneous direct voice contact with individuals

  • Voice messaging

Leaving messages to be listened to at the receiver’s convenience.

  • Virtual workgroups

Creating focused group work involving individuals who are in different locations. This is the best way to keep everyone up to date on developments and involving substantial cost savings in travel.

  • Virtual workplaces

Virtual workgroups operate in virtual workplaces and this results in significant savings in real estate rental or upkeep.

  • Meeting & conferences

Convenient group reviews and discussions, rapid resolution of group issues, can involve corporate or mixed customer-company groups, significant levels of saving of costs such as travel and accommodation.

  • Education, schools and eLearning

Particularly useful in supporting home-based learning and economising on student travel and accommodation costs and even books! This can help increase the numbers wishing to use such a basis for education. Teachers can serve a larger number of students without involving buildings, classrooms and associated maintenance and can themselves save costs of travel.

  • eCommuting

Major savings can be gained with staff working from home but using “free” data and voice communications. Such eCommuting reduces the real estate burden on companies; particularly important in service industries.

  • Online support

Particularly useful in supporting home-based learning and economising on student travel and accommodation costs and even books! This can help increase the numbers wishing to use such a basis for education. Teachers can serve a larger number of students without involving buildings, classrooms and associated maintenance and can themselves save costs of travel.

A large range of online support issues are better resolved using voice communications. In many conventional arrangements customers have to pay for line time when using telephonic support and VoIP eliminates this cost. There are many other potential applications and benefits. Try imaging how VoIP might improve some aspect of your business operations or competitive position as well as help your customers. Let this potential for innovation inspire you to create better ideas! Why not contact us to review your requirements or explore possibilities by benefiting from our extended experience.

The Conaito Team


See Also
AcceptCall Method
See Also


See Also
AcceptLanguage Property
See Also


See Also
ActiveSipAccount Property
See Also


See Also
AddAdditionalDNSServer Method
See Also


See Also
AddSipAccount Method
See Also


See Also
AEC Property
See Also


See Also
AGC Property
See Also


See Also
AutoStartSendingVideo Property
See Also


See Also
CameraInUse Property
See Also


See Also
CaptureDeviceName Property
See Also


See Also
CaptureDevNum Property
See Also


See Also
ConferenceJoin Method
See Also


See Also
ConferenceRemove Method
See Also


See Also
Connect Method
See Also


See Also
DeselectAllVideoCodecs Method
See Also


See Also
DeselectAllVoiceCodecs Method
See Also


See Also
DeselectVideoCodec Method
See Also


See Also
DeselectVoiceCodec Method
See Also


See Also
DisableKeepAlive Method
See Also


See Also
DisableSTUN Method
See Also


See Also
DisableTURN Method
See Also


See Also
Disconnect Method
See Also


See Also
DisplayName Property
See Also


See Also
DndEnabled Property
See Also


See Also
EchoTail Property
See Also


See Also
EnableKeepAlive Method
See Also


See Also
EnableSTUN Method
See Also


See Also
EnableTURN Method
See Also


See Also
EncryptSipSettings Method
See Also


See Also
ForwardURI Property
See Also


See Also
CallState Property
See Also


See Also
GetCaptureDevName Method
See Also


See Also
GetInDevName Method
See Also


See Also
GetOutDevName Method
See Also


See Also
GetSipAccountIndex Method
See Also


Topics
Getting Started
Topics
Name
Description
Microsoft Visual Studio Quick Start

  1. Open Microsoft Visual Studio
  2. Add VoIP Video SIP SDK ActiveX to Toolbox

  3. Now you can place VoIP Video SIP SDK ActiveX at form

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.

Borland Delphi Quick Start

  1. Open Borland Delphi
  2. Import VoIP Video SIP SDK ActiveX

  3. Install VoIP Video SIP SDK ActiveX

  4. Now you have the component at palette and you can put it on form

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.

Microsoft Visual Basic 6.0 Quick Start

  1. Open Microsoft Visual Basic 6.0
  2. Open new windows project: Standard EXE

  3. Add "VoIP Video SIP SDK" to Toolbox

  4. Put VoIP Video SIP ActiveX at form:

Run application.
There will be empty form with SDK on it.
That’s it. We have added SDK to our application.


See Also
GetVideoCodecName Method
See Also


See Also
GetVoiceCodecName Method
See Also


See Also
Hold Method
See Also


See Also
Identity Property
See Also


See Also
InDevNum Property
See Also


See Also
Initialize Method
See Also


See Also
InputDeviceName Property
See Also


See Also
IsInitialized Property
See Also


See Also
IsPlaying Property
See Also


See Also
LastError Property
See Also


See Also
LineResponseCode Property
See Also


See Also
LineResponseText Property
See Also


See Also
LoadConfiguration Method
See Also


See Also
LocalIP Property
See Also


See Also
LocalIPsCount Property
See Also


See Also
LogEnabled Property
See Also


See Also
LoginID Property
See Also


See Also
MaxPhoneLines Property
See Also


See Also
MicrophoneEnergy Property
See Also


See Also
MicrophoneMuted Property
See Also


See Also
MicrophoneVolume Property
See Also


See Also
NATKeepAlive Property
See Also


See Also
NegotiatedCodecName Property
See Also


See Also
NegotiatedPayloadType Property
See Also


See Also
NetworkAdapter Property
See Also


See Also
NoiseReduction Property
See Also


See Also
OnAlerting Event
See Also


See Also
OnConnected Event
See Also


See Also
OnConnectingLine Event
See Also


See Also
OnDTMF Event
See Also


See Also
OnHold Event
See Also


See Also
OnIncomingSipRequest Event
See Also


See Also
OnIncomingSipResponse Event
See Also


See Also
OnLocalMediaStarted Event
See Also


See Also
OnLocalMediaStoped Event
See Also


See Also
OnOutgoingSipRequest Event
See Also


See Also
OnOutgoingSipResponse Event
See Also


See Also
OnPIMIncomingMessage Event
See Also


See Also
OnPlayfileStop Event
See Also


See Also
OnPostPagerMessageResult Event
See Also


See Also
OnRedirectFailure Event
See Also


See Also
OnRedirectSuccess Event
See Also


See Also
OnRegistrationFailure Event
See Also


See Also
OnRegistrationSuccess Event
See Also


See Also
OnRemoteHold Event
See Also


See Also
OnRemoteMediaStarted Event
See Also


See Also
OnRemoteMediaStoped Event
See Also


See Also
OnReregistration Event
See Also


See Also
OnStunFailure Event
See Also


See Also
OnStunSuccess Event
See Also


See Also
OnTerminatedLine Event
See Also


See Also
OnUnregistration Event
See Also


See Also
OutboundProxy Property
See Also


See Also
OutDevNum Property
See Also


See Also
OutputDeviceName Property
See Also


See Also
OutputWindow Property
See Also


See Also
Password Property
See Also


See Also
PhoneLine Property
See Also


See Also
PlayRingtone Property
See Also


See Also
PostPagerMessage Method
See Also


See Also
PreviewWindow Property
See Also


See Also
Realm Property
See Also


See Also
RedirectCall Method
See Also


See Also
Register Method
See Also


See Also
RegisterExpiration Property
See Also


See Also
RegistrationProxy Property
See Also


See Also
RegistrationResponseCode Property
See Also


See Also
RegistrationResponseText Property
See Also


See Also
RemoteURI Property
See Also


See Also
RemoveSipAccount Method
See Also


See Also
RingtoneFile Property
See Also


See Also
RtpPortStart Property
See Also


See Also
SelectAllVideoCodecs Method
See Also


See Also
SelectAllVoiceCodecs Method
See Also


See Also
SelectVideoCodec Method
See Also


See Also
SelectVoiceCodec Method
See Also


See Also
SendDTMF Method
See Also


See Also
SendPagerMessage Method
See Also


See Also
SetAudioCodecIndex Method
See Also


See Also
SetLicenseKey Method
See Also


See Also
SetVideoCodecIndex Method
See Also


See Also
SetWebLicense Method
See Also


See Also
Shutdown Method
See Also


See Also
Reference
See Also


Topics
Reference
Topics
Name | Description
Methods | SIP SDK methods
Properties | SIP SDK properties
Events | SIP SDK events
CallState | Call state
VideoFrameFormat | Video frame format.


See Also
Events
See Also

VoIP Video SIP SDK


Topics
Events
Topics
Name | Description
OnStunSuccess Event | STUN binding has been obtained successfully
OnStunFailure Event | Unable to obtain STUN binding
OnRegistrationSuccess Event | Successfully registered
OnRegistrationFailure Event | Failed to register
OnUnregistration Event | Successfully un-registered
OnReregistration Event | Successfully re-registered
OnAlerting Event | Call has been accepted and the application should alert the end user
OnConnected Event | Call has been setup between the local and remote party
OnRedirectSuccess Event | The transfer was completed successfully
OnRedirectFailure Event | Failed to transfer call
OnDTMF Event | DTMF detected
OnTerminatedLine Event | Call was disconnected or failed to connect
OnConnectingLine Event | Connecting to remote participant
OnPlayfileStop Event | File has completed playing or was aborted
OnHold Event | Call is locally held
OnRemoteHold Event | The remote party is on hold
OnPIMIncomingMessage Event | Incoming text message
OnLocalMediaStarted Event | Local media is being sent to the remote party
OnLocalMediaStoped Event | Local media is no longer being sent to the remote party
OnRemoteMediaStarted Event | Remote media is ready to be received
OnRemoteMediaStoped Event | Remote media has been stopped due to a hold or call tear down
OnPostPagerMessageResult Event | Result of asynchronous message post
OnOutgoingSipRequest Event | Outgoing SIP request message. You must handle this event as soon as possible
OnOutgoingSipResponse Event | Outgoing SIP response message. You must handle this event as soon as possible
OnIncomingSipRequest Event | Incoming SIP request message. You must handle this event as soon as possible
OnIncomingSipResponse Event | Incoming SIP response message. You must handle this event as soon as possible


See Also
Methods
See Also

VoIP Video SIP SDK


Topics
Methods
Topics
Name | Description
Initialize Method | Initialize SIP SDK
WebInitialize Method | Initialize SIP SDK with encrypted parameters
Shutdown Method | Shutdown SIP SDK
Register Method | Register with SIP proxy
UnRegister Method | Un-register from SIP proxy
Connect Method | Make call to remote participant
Disconnect Method | Disconnect active call or reject incoming
AcceptCall Method | Accept incoming call
TransferCall Method | Blind (unattended) transfer active call to given destination
RedirectCall Method | Consultative (attended) transfer active call to the target call
Hold Method | Place call on hold
Unhold Method | Take call off hold
EnableKeepAlive Method | Enable Keep-Alive signaling
DisableKeepAlive Method | Disable Keep-Alive signaling
EnableSTUN Method | Enable STUN
DisableSTUN Method | Disable STUN
EnableTURN Method | Enable TURN
DisableTURN Method | Disable TURN
SendDTMF Method | Send DTMF signal
StartPlaying Method | Start playing file
StartPlayingAtLine Method | Start playing file at given line
StopPlaying Method | Stop playing file
StopPlayingAtLine Method | Stop playing file at given line
StartRecording Method | Record call to file
StopRecording Method | Stop recording call to file
GetOutDevName Method | Get name for output device at position index
GetInDevName Method | Get name for input device at position index
SetLicenseKey Method | This method is used to set license key (fullversion)
SetWebLicense Method | This method is used to set license key (fullversion) for website usage.
EncryptSipSettings Method | This method is used to encrypt SIP settings for WebInitialize.
SendPagerMessage Method | Send pager message to the destination URI
PostPagerMessage Method | Post pager message to the destination URI asynchronously
ConferenceJoin Method | Add call to conference
ConferenceRemove Method | Remove call from conference
SelectAllVoiceCodecs Method | Select all voice codecs
SelectVoiceCodec Method | Select voice codec
DeselectAllVoiceCodecs Method | De-select all voice codecs
DeselectVoiceCodec Method | De-select voice codec
GetVoiceCodecName Method | Get voice codec name
StoreConfiguration Method | Store SIP SDK configuration
LoadConfiguration Method | Load SIP SDK configuration
AddAdditionalDNSServer Method | Add additional DNS server that will be attempted to be discovered
URLGetDisplayName Method | Parse display name from SIP URI
URLGetUserName Method | Parse user name from SIP URI
URLGetHost Method | Parse host name from SIP URI
URLGetPort Method | Parse port number from SIP URI
URLGetAOR Method | Parse AOR from SIP URI
GetCaptureDevName Method | Get name for video capture device at position index
SelectAllVideoCodecs Method | Select all video codecs
SelectVideoCodec Method | Select video codec
DeselectAllVideoCodecs Method | De-select all video codecs
DeselectVideoCodec Method | De-select video codec
GetVideoCodecName Method | Get video codec name
AddSipAccount Method | Add new SIP account
RemoveSipAccount Method | Remove current SIP account
GetSipAccountIndex Method | Get index of SIP account
StopVideo Method | Stop sending video
SetAudioCodecIndex Method | Set audio codec index
SetVideoCodecIndex Method | Set video codec index
StartVideo Method | Start sending video


See Also
Properties
See Also

VoIP Video SIP SDK


Topics
Properties
Topics
Name | Description
LastError Property | Last error description
IsPlaying Property | Indicates whether WAV file is being played on active phone line
PhoneLine Property | Active phone line index
MaxPhoneLines Property | Total count of phone lines
RegisterExpiration Property | Expiration period for registration in seconds
UDPPort Property | UDP port
TCPPort Property | TCP port
ForwardURI Property | Forward URI
NATKeepAlive Property | Keep-Alive interval for NAT traversal, in seconds
RtpPortStart Property | Starting port for inbound RTP traffic
OutDevNum Property | Number of output devices available
InDevNum Property | Number of input devices available
DndEnabled Property | Enable/Disable DND (Do Not Disturb)
OutputDeviceName Property | Name for output device
InputDeviceName Property | Name for input device
IsInitialized Property | True if SIP SDK was successfully initialized
PlayRingtone Property | Enable/Disable playing ring tones
AGC Property | Enable/Disable AGC (Automatic Gain Control)
AEC Property | Enable/Disable AEC (Acoustic Echo Cancellation)
NoiseReduction Property | Enable/Disable Noise Reduction
EchoTail Property | Length (in ms) of the echo canceling filter (also known as tail length)
SpeakerVolume Property | Speaker volume (0..100)
MicrophoneVolume Property | Microphone volume (0..100)
SpeakerMuted Property | Speaker mute state
MicrophoneMuted Property | Microphone mute state
SpeakerEnergy Property | Volume from speaker volume meter (0-100)
MicrophoneEnergy Property | Volume from microphone volume meter (0-100)
VoiceCodecCount Property | Count of voice codecs
CallState Property | Call state at given line
RemoteURI Property | Remote URI at given line
LineResponseCode Property | SIP response code (if available)
LineResponseText Property | SIP response text (if available)
RegistrationResponseCode Property | SIP response code (if available)
RegistrationResponseText Property | SIP response text (if available)
LogEnabled Property | Enable/Disable logging
DisplayName Property | Display name
UserID Property | User ID
LoginID Property | Authentication ID
Password Property | Password
Realm Property | Realm for which the login ID and password are valid. Empty for automatic realm
RegistrationProxy Property | SIP registration proxy
OutboundProxy Property | Outbound proxy
AcceptLanguage Property | Accept Language used in SIP messages
NegotiatedCodecName Property | Negotiated codec name
NegotiatedPayloadType Property | Negotiated payload type
LocalIPsCount Property | Number of local IPs found by the system
LocalIP Property | Local IP address
NetworkAdapter Property | Network adapter name
Identity Property | Information about the UAC originating the request
RingtoneFile Property | Default ring/alert tone audio file
VideoCodecCount Property | Count of video codecs
CameraInUse Property | Indicates whether camera is used by other application
PreviewWindow Property | Video preview window
OutputWindow Property | Video output window
CaptureDevNum Property | Number of video capture devices
CaptureDeviceName Property | Selected video capture device
SipAccountCount Property | SIP account count
ActiveSipAccount Property | Active SIP account
VideoFrameSize Property | Video frame size
VideoMaxBitrate Property | Max video bitrate
AutoStartSendingVideo Property | Automatically start sending video


See Also
SipAccountCount Property
See Also


See Also
SpeakerEnergy Property
See Also


See Also
SpeakerMuted Property
See Also


See Also
SpeakerVolume Property
See Also


See Also
StartPlaying Method
See Also


See Also
StartPlayingAtLine Method
See Also


See Also
StartRecording Method
See Also


See Also
StartVideo Method
See Also


See Also
StopPlaying Method
See Also


See Also
StopPlayingAtLine Method
See Also


See Also
StopRecording Method
See Also


See Also
StopVideo Method
See Also


See Also
StoreConfiguration Method
See Also


See Also
TCPPort Property
See Also


See Also
TransferCall Method
See Also


See Also
UDPPort Property
See Also


See Also
Unhold Method
See Also


See Also
UnRegister Method
See Also


See Also
URLGetAOR Method
See Also


See Also
URLGetDisplayName Method
See Also


See Also
URLGetHost Method
See Also


See Also
URLGetPort Method
See Also


See Also
URLGetUserName Method
See Also


See Also
UserID Property
See Also


See Also
VideoCodecCount Property
See Also


See Also
VideoFrameSize Property
See Also


See Also
VideoMaxBitrate Property
See Also


See Also
VoiceCodecCount Property
See Also


See Also
WebInitialize Method
See Also


Contents
Introduction
Welcome
Development environment
Licensing
License Agreement
Getting Started
Microsoft Visual Studio Quick Start
Borland Delphi Quick Start
Microsoft Visual Basic 6.0 Quick Start
Reference
Methods
Initialize Method
WebInitialize Method
Shutdown Method
Register Method
UnRegister Method
Connect Method
Disconnect Method
AcceptCall Method
TransferCall Method
RedirectCall Method
Hold Method
Unhold Method
EnableKeepAlive Method
DisableKeepAlive Method
EnableSTUN Method
DisableSTUN Method
EnableTURN Method
DisableTURN Method
SendDTMF Method
StartPlaying Method
StartPlayingAtLine Method
StopPlaying Method
StopPlayingAtLine Method
StartRecording Method
StopRecording Method
GetOutDevName Method
GetInDevName Method
SetLicenseKey Method
SetWebLicense Method
EncryptSipSettings Method
SendPagerMessage Method
PostPagerMessage Method
ConferenceJoin Method
ConferenceRemove Method
SelectAllVoiceCodecs Method
SelectVoiceCodec Method
DeselectAllVoiceCodecs Method
DeselectVoiceCodec Method
GetVoiceCodecName Method
StoreConfiguration Method
LoadConfiguration Method
AddAdditionalDNSServer Method
URLGetDisplayName Method
URLGetUserName Method
URLGetHost Method
URLGetPort Method
URLGetAOR Method
GetCaptureDevName Method
SelectAllVideoCodecs Method
SelectVideoCodec Method
DeselectAllVideoCodecs Method
DeselectVideoCodec Method
GetVideoCodecName Method
AddSipAccount Method
RemoveSipAccount Method
GetSipAccountIndex Method
StopVideo Method
SetAudioCodecIndex Method
SetVideoCodecIndex Method
StartVideo Method
Properties
LastError Property
IsPlaying Property
PhoneLine Property
MaxPhoneLines Property
RegisterExpiration Property
UDPPort Property
TCPPort Property
ForwardURI Property
NATKeepAlive Property
RtpPortStart Property
OutDevNum Property
InDevNum Property
DndEnabled Property
OutputDeviceName Property
InputDeviceName Property
IsInitialized Property
PlayRingtone Property
AGC Property
AEC Property
NoiseReduction Property
EchoTail Property
SpeakerVolume Property
MicrophoneVolume Property
SpeakerMuted Property
MicrophoneMuted Property
SpeakerEnergy Property
MicrophoneEnergy Property
VoiceCodecCount Property
CallState Property
RemoteURI Property
LineResponseCode Property
LineResponseText Property
RegistrationResponseCode Property
RegistrationResponseText Property
LogEnabled Property
DisplayName Property
UserID Property
LoginID Property
Password Property
Realm Property
RegistrationProxy Property
OutboundProxy Property
AcceptLanguage Property
NegotiatedCodecName Property
NegotiatedPayloadType Property
LocalIPsCount Property
LocalIP Property
NetworkAdapter Property
Identity Property
RingtoneFile Property
VideoCodecCount Property
CameraInUse Property
PreviewWindow Property
OutputWindow Property
CaptureDevNum Property
CaptureDeviceName Property
SipAccountCount Property
ActiveSipAccount Property
VideoFrameSize Property
VideoMaxBitrate Property
AutoStartSendingVideo Property
Events
OnStunSuccess Event
OnStunFailure Event
OnRegistrationSuccess Event
OnRegistrationFailure Event
OnUnregistration Event
OnReregistration Event
OnAlerting Event
OnConnected Event
OnRedirectSuccess Event
OnRedirectFailure Event
OnDTMF Event
OnTerminatedLine Event
OnConnectingLine Event
OnPlayfileStop Event
OnHold Event
OnRemoteHold Event
OnPIMIncomingMessage Event
OnLocalMediaStarted Event
OnLocalMediaStoped Event
OnRemoteMediaStarted Event
OnRemoteMediaStoped Event
OnPostPagerMessageResult Event
OnOutgoingSipRequest Event
OnOutgoingSipResponse Event
OnIncomingSipRequest Event
OnIncomingSipResponse Event
CallState
VideoFrameFormat
Support and service
Technical support
Our Service for your Solutions


Index
A | B | C | D | E | F | G | H | I | L | M | N | O | P | R | S | T | U | V | W
A
AcceptCall Method
AcceptLanguage Property
ActiveSipAccount Property
AddAdditionalDNSServer Method
AddSipAccount Method
AEC Property
AGC Property
AutoStartSendingVideo Property
B
Borland Delphi Quick Start
C
CallState
CallState Property
CameraInUse Property
CaptureDeviceName Property
CaptureDevNum Property
ConferenceJoin Method
ConferenceRemove Method
Connect Method
D
DeselectAllVideoCodecs Method
DeselectAllVoiceCodecs Method
DeselectVideoCodec Method
DeselectVoiceCodec Method
Development environment
DisableKeepAlive Method
DisableSTUN Method
DisableTURN Method
Disconnect Method
DisplayName Property
DndEnabled Property
E
EchoTail Property
EnableKeepAlive Method
EnableSTUN Method
EnableTURN Method
EncryptSipSettings Method
Events
F
ForwardURI Property
G
GetCaptureDevName Method
GetInDevName Method
GetOutDevName Method
GetSipAccountIndex Method
Getting Started
GetVideoCodecName Method
GetVoiceCodecName Method
H
Hold Method
I
Identity Property
InDevNum Property
Initialize Method
InputDeviceName Property
IsInitialized Property
IsPlaying Property
L
LastError Property
License Agreement
Licensing
LineResponseCode Property
LineResponseText Property
LoadConfiguration Method
LocalIP Property
LocalIPsCount Property
LogEnabled Property
LoginID Property
M
MaxPhoneLines Property
Methods
MicrophoneEnergy Property
MicrophoneMuted Property
MicrophoneVolume Property
Microsoft Visual Basic 6.0 Quick Start
Microsoft Visual Studio Quick Start
N
NATKeepAlive Property
NegotiatedCodecName Property
NegotiatedPayloadType Property
NetworkAdapter Property
NoiseReduction Property
O
OnAlerting Event
OnConnected Event
OnConnectingLine Event
OnDTMF Event
OnHold Event
OnIncomingSipRequest Event
OnIncomingSipResponse Event
OnLocalMediaStarted Event
OnLocalMediaStoped Event
OnOutgoingSipRequest Event
OnOutgoingSipResponse Event
OnPIMIncomingMessage Event
OnPlayfileStop Event
OnPostPagerMessageResult Event
OnRedirectFailure Event
OnRedirectSuccess Event
OnRegistrationFailure Event
OnRegistrationSuccess Event
OnRemoteHold Event
OnRemoteMediaStarted Event
OnRemoteMediaStoped Event
OnReregistration Event
OnStunFailure Event
OnStunSuccess Event
OnTerminatedLine Event
OnUnregistration Event
Our Service for your Solutions
OutboundProxy Property
OutDevNum Property
OutputDeviceName Property
OutputWindow Property
P
Password Property
PhoneLine Property
PlayRingtone Property
PostPagerMessage Method
PreviewWindow Property
Properties
R
Realm Property
RedirectCall Method
Reference
Register Method
RegisterExpiration Property
RegistrationProxy Property
RegistrationResponseCode Property
RegistrationResponseText Property
RemoteURI Property
RemoveSipAccount Method
RingtoneFile Property
RtpPortStart Property
S
SelectAllVideoCodecs Method
SelectAllVoiceCodecs Method
SelectVideoCodec Method
SelectVoiceCodec Method
SendDTMF Method
SendPagerMessage Method
SetAudioCodecIndex Method
SetLicenseKey Method
SetVideoCodecIndex Method
SetWebLicense Method
Shutdown Method
SipAccountCount Property
SpeakerEnergy Property
SpeakerMuted Property
SpeakerVolume Property
StartPlaying Method
StartPlayingAtLine Method
StartRecording Method
StartVideo Method
StopPlaying Method
StopPlayingAtLine Method
StopRecording Method
StopVideo Method
StoreConfiguration Method
T
TCPPort Property
Technical support
TransferCall Method
U
UDPPort Property
Unhold Method
UnRegister Method
URLGetAOR Method
URLGetDisplayName Method
URLGetHost Method
URLGetPort Method
URLGetUserName Method
UserID Property
V
VideoCodecCount Property
VideoFrameFormat
VideoFrameSize Property
VideoMaxBitrate Property
VoiceCodecCount Property
W
WebInitialize Method
Welcome