Introduction

Introduction - conaito VoiceMail SDK

Powerful solution for recording and sending voice messages from your websites

We describe below an overview of the features of the conaito VoiceMail SDK.

The conaito VoiceMail SDK is designed for web developers and allows to record and send voice messages from web sites to any existing e-mail client software, even to free web based e-mail like Hotmail and Yahoo. The recipient receives the usual e-mail message with link to Mp3 audio file. Recipients can listen the Mp3 file by any existing Mp3 player. Mp3 players are installed almost on the each computer, so, no problem with playback!

Also, it is possible to save recorded audio file on the client computer and open it from there. To playback the recorded MP3 audio from the server the recording applet works in the streaming mode.

The conaito VoiceMail SDK uses native methods to sound capture, LAME MP3 encoding/decoding and playback in the DLL, which will be installed on the computer when user uses the applet for the first time. The recording applet is digitally signed.

The conaito VoiceMail SDK is compatible with Windows 98/NT/2000/ME/XP/2003/Vista, MacOS X and with Microsoft Internet Explorer 4.0 and up, Netscape 7, FireFox, Mozilla, Opera browsers. On the Mac with Safari and Opera.

  • Potential applications of conaito VoiceMail SDK

  • Private and/or company websites can be enhanced by adding add voicemail capabilities so that visitors or customers can leave voice messages add voicemail capabilities to your website so that your visitors or customers can leave voice messages
  • Email business card can be embedded in emails so that recipients can click on your "Leave a voice message" link/button and send you a voicemail
  • Voice overs can be sent for intros to media such as a text document or even flash slide show and these can be personalised for each recipient
  • Greeting cards can be enhanced by adding recorded voice messages
  • eBay auction inserts can have "Ask us" buttons to enable customer to send queries in an simple and easy fashion
  • web based voicemail services can be set up for customers
  • VoIP services can be enhanced with voice messaging
  • And much more!

  • Key Features

  • Record, send by Email and play mp3 file direct from website (without any need for an additional player)
  • Recording Level Indicator
  • NAT (Router) & Firewall friendly (upload recorded Mp3 with HTTP post)
  • Comes with RTR (ready-to-run) samples
  • Freely changeable Interface design
  • Supports multi-language environment
  • Works on the most popular web browsers and web server
  • Works with all kinds of Internet connections
  • Comes with valid Microsoft Authenticode Certificate
  • Very easy to incorporate

Please, don't hesitate trying our VoiceMail SDK at once and get yourself, as well as your customers, the exciting experience of easy, fast and high quality standard applications which can convert record and send high quality VoiceMails in MP3 format!

  • conaito VoiceMail functionality

The idea of voice mail is very simple. Web voice mail application creates the text and voice messages and send them to web server via HTTP by POST method. On the server side the server scripts create usual e-mail message body with text message and with link to Mp3 file (voice message). Mp3 file is stored on the server. Server script passes the e-mail message body to Mail Transfer Agent, which send it to recepient. Recepient receives the e-mail message with text and link to Mp3 file and downloads and/or play Mp3 file. Also, it is possible to save recorded audio file on the client computer and open it from there. To playback the recorded MP3 audio from the server the recording applet works in the streaming mode.

To voice message recording the Mp3 audio recording applet is used. The functionality of recording applet is following:

  • Audio capture from sound card. The sampling frequencies are 8000Hz, 11025Hz, 16000Hz, 22050Hz, 24000Hz, 32000Hz, 44100Hz, 48000Hz.
  • LAME Mp3 audio encoding/decoding.
  • Playback of the recorded Mp3 file for sound quality and content evaluation.
  • Uploading of Mp3 file to web server via HTTP. The server scripts (PHP, ASP or ASP.NET) is used to receive Mp3 file on the server. Also, it is possible to save/open/delete audio file on the client computer.
  • Send VoiceMail with Link to the recorded Mp3 voice message. Also, is it possible to playback of the Mp3 files from the web server in the streaming mode.

Demo version allows to record 20 sec only.

The Mp3 audio recording applet is developed in Java 1.1. So, the applet works with Microsoft Java 1.1

(i.e. Recording applet works on the target browsers with default browser JVM installation) and with Java plug-in 1.4-1.6. The recording applet uses native methods for sound capture and LAME Mp3 encoding/decoding. They are developed in C++ and implemented as DLL (jaudioMp3Win.tar and jaudioMp3Mac.tar). The DLL will be installed on the client computer if the applet is being used for the first time. The recording applet is digitally signed. For digitally signing the comodo certificate is used.

  • conaito VoiceMail SDK package

  • Audio recording applet (RPAppletMp3.cab, RPAppletMp3.jar).
  • Sound capture/playback, LAME Mp3 encoding/decoding DLL (jaudioMp3Win.tar for Windows and jaudioMp3Mac.tar lib for Mac).
  • Ready-to-run Examples, Server Scripts written in PHP, JAVA, ASP and ASP.NET (VB.NET and C#).
  • Examples with JavaScript interface and with Java applet interface. (It includes the source code of Interface applet).
  • Documentation.

  • Target platform

Target OS Platform: Windows 98/NT/2000/ME/XP/2003/Vista and MacOS X.

Target browsers: Windows: Microsoft Internet Explorer 4.0 and up, Netscape 7, FireFox, Mozilla, Opera. On the Mac with Safari and Opera.

Web Servers: Any (PHP, ASP or ASP.NET support required).

All of the necessary software components for building systems based on conaito VoiceMail SDK including documented examples (with source code)

We hope you enjoy the conaito VoiceMail SDK – the Powerful solution for recording and sending voice messages from your websites.

Our conaito Support Team gladly answers your questions.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2008, conaito Technologies - www.conaito.com. All rights reserved.

This help file has been generated by the freeware version of HelpNDoc


What´s new?

conaito VoiceMail SDK

What´s new and changes in the version 2.4 - 05/2008

  • Better Cross Browser support
  • New secure signed (conaito Technologies) SDK - 3 years
  • Now Recording with 24000Hz and 48000Hz supported
  • SDK is now more stable
  • A few bugs was fixed.

What´s new and changes in the version 2.3 - 09/2007

  • Better Windows Vista and IE7, Firefox supported.
  • A few bugs was fixed.

What´s new and changes in the version 2.2 - 04/2007

  • Now Windows Vista and IE7 are supported.
  • A few bugs was fixed.

What´s new and changes in the version 2.1 - 01/2007

  • Mac computers support was added. Currently, applet works on the Power and Intel Mac.
  • More target browsers support.
  • Local functions (save, open, delete) added.
  • Input signal level graphical indicator was added (included in the recording applet). So, user can see the level of input signal and tune it by Windows or Mac sound volume control software.
  • Java interface applet example with source code.
  • ASP.NET Upload component source code provided with the SDK.
  • A few bugs was fixed.
  • Rewritten documentation.


Licensing

The Licensing

  • Licensing for non-ASP (application service provider) - Single Domain based

We provide a 'Single License' to a 'Single Domain'. You are limited to use the Single License under your Single Domain name. So, if you will use the conaito VoiceMail on two different Domains, then you would have to buy two license keys. conaito Technologies grants to you a non-exclusive license at cost US$399 to utilize the Software in the networked Web documents and 6 monthes support.

Note! You must add to web site with conaito VoiceMail the link to http://www.conaito.com/ and text “Voice Mail powered by conaito Technologies” or something else with the same sense. If you do not willing to mention the conaito Technologies, you must pay additional US$300 (one time payment).

The exclusive selling of the conaito VoiceMail SDK or distribute the conaito VoiceMail SDK in conjunction with any service and/or product is not permitted.

Permit other companies and/or individuals to use the conaito VoiceMail SDK without our Agreement is not allowed.

Here you can find more Information about our reseller program .

  • Licensing for ASP (application service provider) - Single Domain based

We provide a 'Single License' to a 'Single Domain'. You are limited to use the Single License under your Single Domain name. So, if you will use the conaito VoiceMail on two different Domains, then you would have to buy two license keys. conaito Technologies grants to you a non-exclusive license at cost US$399 per year (annual payment) to utilize the Software in the networked web documents and

6 monthes support.

Note! You must add to web site with conaito VoiceMail the link to http://www.conaito.com/ and text “Voice Mail powered by conaito Technologies” or something else with the same sense. If you do not willing to mention the conaito Technologies, you must pay additional US$300 (one time payment).

The exclusive selling of the conaito VoiceMail SDK or distribute the conaito VoiceMail SDK in conjunction with any service and/or product is not permitted.

Permit other companies and/or individuals to use the conaito VoiceMail SDK without our Agreement is not allowed.

Here you can find more Information about our reseller program .

  • Support and Maintenance

conaito Technologies grants to utilize the Software in the networked Web documents and 6 monthes support. The Support and Maintenance subscription provides you with eMail and technical support for our VoiceMail SDK products. In addition your subscription provides all new product releases and updates while your subscription is active.

VoiceMail SDK products can be purchased with either a 6 months or 1 year of support and maintenance subscription. If your support and maintenance agreement has expired you can renew it by purchasing a "Subscription Renewal" within 30 days after expiration.


License Agreement

Please, read the following terms and conditions before using the conaito VoiceMail software (the "Software") provided by conaito Technologies. If you do not agree with these terms, do not download and/or use the Software. If you would like to change the license conditions and adapt them to your business, please, contact us .

1. LICENSE GRANT

conaito Technologies grants to you a non-exclusive license at cost US$399 to utilize the Software in the networked Web documents and 6 monthes support. It is a subject to the following conditions:

1.1 You may

Utilize the Software in the single Web Site of company or person which licensed the Software. If you intend to use the Software for the Application Service Providing (ASP) purposes, please, contact us .

1.2 You may not

1.2.1 distribute the Software in conjunction with any service and/or product; and

1.2.2 modify, translate, reverse engineer, decompile, disassemble or create derivative works based on the Software; and

1.2.3 permit other companies and/or individuals to use the Software.

1.3 You must

add to web site with conaito VoiceMail the link to http://www.conaito.com/ and text “VoiceMail powered by conaito Technologies” or something else with the same sense. If you do not willing to mention the conaito Technologies, you must pay additional US$300 (one time payment).

2. "AS IS" WARRANTY

THE SOFTWARE AND THE SERVICES ARE PROVIDED "AS IS," WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING WITHOUT LIMITATION, WARRANTIES OF PERFORMANCE, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT.

3. TITLE

conaito Technologies retains all title, ownership rights, and intellectual property rights to the Software.

4. TERMINATION

The license will terminate automatically if you fail to comply with the limitations described herein. On termination of this license, you must destroy all copies of the Software in your possession or control.

5. LIMITATION OF LIABILITY

UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, CONTRACT, OR OTHERWISE, SHALL COPIA OR ITS LICENSORS BE LIABLE TO YOU OR ANY OTHER PERSON FOR ANY DIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN IF COPIA SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY.


Ready-to-Run Demo

Ready-to-Run Demo - Quick Installation conaito VoiceMail SDK

PHP Example RTR (Ready-to-Run):

  • Please use the files from the VoiceMail SDK 'Examples/PHP' folder - 'PHP VoiceMail Ready-to-Run'.

  • Make sure your Web server supports PHP and it's 'mail' function.

  • Upload all files from the VoiceMail SDK folder 'PHP VoiceMail ready-to-run' to your webserver and set write permissions.

  • To start the VoiceMail setup, open the ("index.php") on your webserver (setup starts if no confic.php exists, otherwise starts the conaito VoiceMail demo) After the successfull setup the configuration file ("config.php") is created. To get run the setup for another time you must delete the configuration file first.

  • To test the conaito VoiceMail, open the 'index.php' in your browser.

ASP Example RTR (Ready-to-Run):

  • Please use the files from the VoiceMail SDK 'Examples/ASP folder' - 'ASP VoiceMail Ready-to-Run'.

  • Make sure your Web server supports ASP and a working CDOSYS, CDONTS, Jmail, Persits AspEmail or AspMail email component installed.

  • Edit the 'inc_confic.asp' and make your settings.

  • Upload all files from the VoiceMail SDK folder 'ASP VoiceMail ready-to-run' to your webserver.

  • Set write permissions on the 'voicefiles' folder.

  • To test the conaito VoiceMail, open the 'index.asp' in your browser.

ASP.NET Example (Recording/Upload Sample):

  • Please use the files from the VoiceMail SDK 'Examples/ASP.NET' folder.

  • Edit the 'index.aspx' and make your settings (applet params e.g. "ServerScript").

  • Upload all files from the VoiceMail SDK Examples/ASP.NET folder to your webserver.

  • Set write permissions on the 'voicefiles' folder.

  • To test the conaito VoiceMail, open the 'index.aspx' in your browser.

Note! You can put applet and dll files in the other folders then mentioned above, but you must keep in mind the following:

  • Applet files RPAppletMp3.cab, RPAppletMp3.jar must be on the server in the same folder with web page which call the applet. If they in the different folders – full path to applet must be indicated in the CODEBASE applet parameter.

  • Sound capture and encoding dll - jaudioMp3Win.tar and jaudioMp3Mac.tar, allways must be in the same directory with applet.


Manual Installation

Manual Installation conaito VoiceMail SDK

Manual Installation for PHP Example:

  • Create on the server the directory '/voicefiles' in the root of the web server. For example: www.conaito.com/voicefiles/ . Please, for begining, create these folders in the root of web server! After applet works properly, you may change the folders location.
    Note! It may be will require the changes in the server script.

  • Please use the files from the VoiceMail SDK 'Examples/PHP' folder - 'PHP VoiceMail Manual Installation'.

  • Make changes in the mail.php in the applet call. In the "ServerScript" parameter you have to indicate your web domain instead of www.conaito.com. You should correct the following parameter:
  • $USERDIR="/"; // the folder inside the voicefiles folder to store mp3 files
  • $VoiceServerFolder = "/voicefiles/"; // the path to 'voicefiles' folder
  • $retrive="http://www.conaito.com/retrive.php"; //the URL of server uploader script
  • $appletCodebase="."; // path to applet's archive files. '.' means the same path as mail.php has
  • To find out deeper information about $VoiceServerFolder and $USERDIR parametra settings please, read the How applet uploads mp3 file to server section .

  • Make sure your Web server supports PHP and it's 'mail' function.
    Make changes to the sendmail.php. You should correct the $FullPathToVoiceFileDir parameter:

Example: $FullPathToVoiceFileDir="http://www.conaito.com/voicefiles/";

In all parameter you have to indicate your web domain instead of www.conaito.com.

  • Put into root folder the following files:
  • index.php - start page which call the mail page (mail.php).
  • mail.php - example page which call the recording applet. Interface created by JavaScript possibilities
  • retrive.php - server script for the receiving of audio files and saving them on the server. The server script will create subfolder in the '/voicefiles' folder with name which is defined in the mail.php in the UserServerFolder variable and save voice file there. If subfolder with UserServerFolder name already exist, the voice file will be saved there.
  • RPAppletMp3.cab, RPAppletMp3.jar – recording applet.
  • jaudioMp3Win.tar, jaudioMp3Mac.tar - dlls. They contain audio capturing/playback and LAME Mp3 encoder/decoder for Windows and Mac platforms.
  • sendmail.php - server script for sending emails.

  • Server script must have the permission to save the voice files on the server. Please, check it.
    To set permissions use chmod 755 instruction. Your web server administrator can do it.

  • To test the conaito VoiceMail, open the 'index.php' in your browser.

Note! You can put applet and dll files in the other folders then mentioned above, but you must keep in mind the following:

  • Applet files RPAppletMp3.cab, RPAppletMp3.jar must be on the server in the same folder with web page which call the applet. If they in the different folders – full path to applet must be indicated in the CODEBASE applet parameter.

  • Sound capture and encoding dll - jaudioMp3Win.tar and jaudioMp3Mac.tar, allways must be in the same directory with applet.


System Requirements

In order to run the conaito VoiceMail SDK, you must ensure that your computer meets the following minimum software and hardware requirements.

Requirement |
Target OS Platform | Windows 98/NT/2000/ME/XP/2003/Vista and MacOS X
Web Server | Any (PHP,ASP or ASP.NET support required)
Supported Browsers | Windows: Microsoft Internet Explorer 4.0 and up, Netscape 7, FireFox, Mozilla, Opera Mac: Safari and Opera
Java | Microsoft Java 1.1 and Sun Java plug-in 1.4 -1.6.


How applet uploads mp3

How applet uploads mp3 file to server

Please, read the following attentively before you'll try to make any changes to your configuration!

Please use for this manual settings the files from the VoiceMail SDK 'Examples/PHP' folder - 'PHP VoiceMail Manual Installation'.

Example: <PARAM NAME = "BlockSize" VALUE = "20480">

Applet uploads voice file in the folder, defined by VoiceServerFolder and UserServerFolder parameters like http://www.yourhost.com/recorder/VoiceServerFolder/UserServerFolder/, where /recorder/ is the folder that contains retrive.php.

VoiceServerFolder applet parameter defines folder reletively folder which contains retrive.php.

UserServerFolder applet parameter defines folder which is in the VoiceServerFolder.

Please, read two examples of defining VoiceServerFolder parameter.

  • Example 1

Files on server:

http://yourserver.com/recorder/mail.php

http://yourserver.com/recorder/retrive.php

http://yourserver.com/voicefiles - folder for voice files

So, you should define such applet parameters:

<PARAM NAME = "VoiceServerFolder" VALUE = "/../voicefiles/">

<PARAM NAME = "UserServerFolder" VALUE = "smth">

So, voice files would be written in

http://yourserver.com/recorder/../voicefiles/smth/ directory, that is the same to

http://yourserver.com/voicefiles/smth/

  • Example 2

Files on server:

http://yourserver.com/recorder/mp3recorder/mail.php

http://yourserver.com/recorder/mp3recorder/retrive.php

http://yourserver.com/music/voicefiles - folder for voice files

You should define such applet parameters:

<PARAM NAME = "VoiceServerFolder" VALUE = "/../../music/voicefiles/">

<PARAM NAME = "UserServerFolder" VALUE = "smth">

So, voice files would be written in

http://yourserver.com/recorder/mp3recorder/../../music/voicefiles/smth/ directory, that is the same to

http://yourserver.com/music/voicefiles/smth/

  • Example 3

Files on server:

http://yourserver.com/recorder/mp3recorder/mail.php

http://yourserver.com/recorder/mp3recorder/retrive.php

http://yourserver.com/music/voicefiles - folder for voice files If you don't want to make folder inside voicefiles directory,

you should define such parameters:

<PARAM NAME = "VoiceServerFolder" VALUE = "/../../music/">

<PARAM NAME = "UserServerFolder" VALUE = "voicefiles">

So, voice files would be written in

http://yourserver.com/recorder/mp3recorder/../../music/voicefiles/ directory, that is the same to

http://yourserver.com/music/voicefiles/

By default, you should put your 'mail.php' file and 'retrive.php' file in the same directory on server, but you can also put them into different directories. To make that you should define VoiceServerFolder parameters in 'mail.php' and 'retrive.php' separately. In 'mail.php' you should define VoiceServerFolder according to the place of 'mail.php', in 'retrive.php' you should define VoiceServerFolder accoreding to the place of retrive.php. Please look through the examples to understand more.

  • Example 4

Files on server:

http://yourserver.com/recorder/mp3recorder/mail.php

http://yourserver.com/retrive/retrive.php http://yourserver.com/music/voicefiles - folder for voice files

You should define such applet parameters:

<PARAM NAME = "VoiceServerFolder" VALUE = "/../../music/voicefiles/">

<PARAM NAME = "UserServerFolder" VALUE = "smth">

In retrive.php you should replace lines below

if(isset($_POST["VoiceServerFolder"])) $VoiceLocal = $_POST["VoiceServerFolder"];

else $VoiceLocal="/../voicefiles/";

by

$VoiceLocal ="/../music/voicefiles/";

So, voice files would be written by retrive.php to

http://yourserver.com/retrive/../music/voicefiles/smth/ directory, that is the same to

http://yourserver.com/music/voicefiles/smth/

And applet'll read them from

http://yourserver.com/recorder/mp3recorder/../../music/voicefiles/smth/ directory, that is the same to

http://yourserver.com/music/voicefiles/smth/

  • Example 5

Files on server:

http://yourserver.com/recorder/mp3recorder/mail.php

http://yourserver.com/script/retrive.php http://yourserver.com/voicefiles - folder for voice files

If you don't want to make folder inside voicefiles directory, you should define such parameters

<PARAM NAME = "VoiceServerFolder" VALUE = "/../../">

<PARAM NAME = "UserServerFolder" VALUE = "voicefiles">

In retrive.php you should replace lines below

if(isset($_POST["VoiceServerFolder"])) $VoiceLocal = $_POST["VoiceServerFolder"];

else $VoiceLocal="/../voicefiles/";

by

$VoiceLocal ="/../";

So, voice files would be written by retrive.php to

http://yourserver.com/retrive/../voicefiles/ directory, that is the same to

http://yourserver.com/voicefiles/ And applet'll read them from

http://yourserver.com/recorder/mp3recorder/../../voicefiles/ directory, that is the same to

http://yourserver.com/voicefiles/


How to send variables

How to send variables to server with audio file

You can add your own variables to send with voicefile in two ways:

1. Applet parameters using

1. Declare your variables names in UserPostVariables applet parameter:

Example: <PARAM NAME = "UserPostVariables" VALUE = "Username,Country">

2. Define every variable with it's applet parameter

Example: <PARAM NAME = "Username" VALUE = "Tom"> <PARAM NAME = "Country" VALUE = "Germany">

3. NOTE! Every declared in UserPostVariables parameter variables should have it's own parameter with it's value.

2. Setparameter applet method using

You can call Setparameter (String name, String value) method from javascript and set your variable.

Processing on server

You can process received with voicefile variables in server scripts. For example, this code will print all received variables:

PHP Example:

while(list($key,$val)=each($_POST))

{

AddLogs($errfile,"POST variable received >".$key." = ".$val);

}

Additional Information

Voicefile and all variables are retrieved by server script by POST request

Once you've set up variable you cannot undefine or redefine it.


How to register

How to register the conaito VoiceMail SDK

To register the conaito VoiceMail SDK you have to register the Mp3 audio recording applet only.

The Mp3 audio recording applet can be used as demo or full functional applet. To use applets as demo applet, you must add to applet parameters the following parameter (it is added in the example):

<PARAM NAME = "Registration" VALUE = "Demo">

Applet also works as demo if "Registration" parameter is absent.

In demo mode the applets will work with limited to 20 sec recording (playback) time.

It is single difference between demo and full functional applet mode.

To use conaito VoiceMail as full functional you must:

Order the conaito VoiceMail SDK from conaito web site www.conaito.com . Note! Usual license allows to use conaito VoiceMail on the one web site. Therefore, applet are associated with web domain of web site where applet is used.

Send to order@conaito.com the domain name of your web site where applet will be used. Conaito will generate registration key, which based on the domain name and send it to you. Registration key is the *.txt file. It contains encrypted key and non-encrypted information.

Put the *.txt file on the server in the same folder with applets (*.cab, *jar files).

Change the Registration applet parameter:

<PARAM NAME = "Registration" VALUE = "RegistrationKeyFileName.txt">


Troubleshooting

  • I can not record the audio message

1. You push the “Record” button but recording applet does not record the sound. Alert window with “Error Object does not support this property or method” message appears.

Reasons:

a) Probably, the recording applet is not downloaded from the server to the client machine. For successful downloading the RPAppletMp3.cab and RPAppletMp3.jar must be located on the server in the same directory with web page which calls the applet. The RPAppletMp3.cab and RPAppletMp3.jar can be placed also in the other directory, but in the recording applet call in the CODEBASE must be indicated the full path to RPAppletMp3.cab and RPAppletMp3.jar: For instanse: CODEBASE=http://yourserver.com/mail/

At first, please, create the directories as in the documentation and examples is recommended. Then, when applet works properly, you can re-create directories as you want, correspondingly to your web application.

b) Please, check if the jaudioMp3Win.tar and jaudioMp3Mac.tar is installed on your computer. It is installed automatically when you use the applet for the first time. On the server the jaudioMp3Win.tar and jaudioMp3Mac.tar must be located in the same directory with RPAppletMp3.cab and RPAppletMp3.jar. Probably, you were wrong and jaudioMp3Win.tar and jaudioMp3Mac.tar is located in the other directory.

If audio recording still does not work, please, copy the Java console content and send to our support.You can find the Java console in the Internet Explorer browser in the View menu at the bottom (cup of coffee icon). If you do not see the Java console there, please, in the menu go to Tools->Internet option ->Advanced and choose in the Microsoft VM section the “Java console enabled”. In the Netscape 7 browser you can see the Java console in the Tools->Web Development.

  • I can not upload the audio file to server

1. You recorded the audio message and can playback it from your local computer succesfully. You entered the name of file and push the “Send” button, in the status line you see “Uploading audio message...”, but after uploading the alert window appears with “Your message could not be uploaded” message.

Reasons:

a) Upload Server script is written in PHP, ASP or ASP.NET (DLL), so be sure your web server support one of them.

b) Check the permissions of the '/voicefiles' directory.

c) Check the parameter of the applet.

d) Be sure if server script has write access to the '/voicefiles' directory.


Applet interface

Mp3 applet interface

conaito VoiceMail SDK

Controls:

To control the Mp3 recording applet it has a few methods which can be accessible from outside, in particular from JavaScript and Java. These methods allow to implement the following controls:

  • Record – to start the record
  • Pause - to pause the record and playback
  • Play – to playback the recorded audio file from the client computer for sound quality and content evaluation
  • Stop – to stop the record and playback
  • Send – to upload recorded the audio file to server. Name of audio file must be entered in the “Please enter file name” field or created by JavaScript possibilities and passed to UPLOAD_RP() JavaScript method
  • Listen – to playback from the web server in streaming mode. The name of the audio file must be entered in the “Listen from Web-server” field or created by JavaScript possibilities and passed to WEBPLAY_RP() method
  • Status line – to indicate the status messages
  • Timer – to indicate the current time / maximal recording time in the recording mode, current time / audio message duration in the playback mode
  • Input level indicator – to indicate the input volume of audio signal

The controls interact with the recording applet via JavaScript or Java. We offer 2 examples:
1. Controls which created by JavaScript. In this case the JavaScript methods call the corresponding Java methods from applet;

2. Controls which created as Java applet which interact with recording applet. In this case 2 applets will be used – Mp3 audio recording applet and interface applet. Source code of interface applet is included to Mp3 audio recording SDK package. So, applet interface can be customized.

Table 1: Public recording applet methods which are accessible outside of applet

Applet methods | Applet action
RECORD ( ) | Start the recording/encoding of audio data
PLAYBACK ( ) | Start the playback from client PC
PAUSE ( ) | Record/Playback pause
STOP_RP ( ) | Stop the record/playback
UPLOAD (String filename) | Uploads audio file from client PC to web server. Server script receives the audio file on the server
WEBPLAY (String filename) | Playback the recorded audio file from the server.
SAVE (String filename, String filename) | Save the recorded audio file on the client computer.
OPEN (String filename, String filename) | Open the audio file from the client computer.
DELETE ( ) | Delete the audio files from the client computer which was recorded during current session.

Table 2: JavaScript methods which are accessible from recording applet

Applet methods | Applet action
SetStatus_RP (s, num) | Applet sends status message to JavaScript s – message, num – message number in the Table 5.
SetTimer_RP (s) | Applet sends current recording/playback time to JavaScript
confirmRecord (s,num) | Confirm re-recording s – message, num – message number in the Table 5.
addName (s) | Adds audio file name to list of files for listening from web server.
report_RP (s) | Pop-up message

Table 3: Recording applet parameters

Applet parameter name

Parameter value

Parameter description

"ServerScript"

e.g. "http://www.conaito.com/voicefiles/retrive.php"

Server script URL

"VoiceServerFolder"

e.g. "http://www.conaito.com/voicefiles/" or
"/../voicefiles/"

URL of directory in which the audio files are stored. URL is necessary to playback from server.

"Sampling_frequency"

See table 4, 1st column

Audio sampling frequency

"Bitrate"

See table 4.

In the table 4 available bitrates are defined at each sampling frequency. Bitrate is in kbps.

"TimeLimit "

1...N

N – is maximal recording time in seconds. It is hardcoded in the license file.

"Registration"

a) “Demo”

b) Name of file with registration key. For example, “RegKey.txt”

a) Applet works as demo, the maximal recording time is 20 sec. If Registration parameter is absent, applet works as demo, too.

b) The registration key file you will receive after licensing. File must be located on the server in the same directory with applet.

"OverRecord"

“true/false”

True – over recording is available without warning message.

False (or parameter is absent) - over recording is available with warning message only.

"BlockSize"

E.g. 1024

Applet uploads audiofile block by block. This parameter defines the size of block in bytes.

"InterfaceType"

JS or Java

Applet can use controls which created by JavaScript (JS) or interface applet (Java).

"UserPostVariables"

Variable names. Ex: "Username,Country"

Number on variable names to upload to server with voice file.
Please, see How to send variables to server with audio file

"UserServerFolder"

e.g. "User1_personal_folder"

Defines the subfolder which is in the VoiceServerFolder.

"indicatorWidth"

e.g. 330

Defines the horizontal size of input level indicator, in pixels.

"backgroudColor", "indicatorLevel1", "indicatorLevel2", "indicatorLevel3"

e.g. "c0c0c0",
"4664f0",
"28c814",
"f03250"

Colors of input level indicator components.
Please, see How to customize the input level indicator

Table 4: Available Bitrates

Sampling frequencies, Hz | Bitrates, kbps
8000 | 16, 24, 32, 40, 48, 56
11025 | 16, 24, 32, 40, 48, 56, 64, 80
16000 | 16, 24, 32, 40, 48, 56, 64, 80, 96, 112
22050 | 32, 40, 48, 56, 64, 80, 96, 112, 128, 160
24000 | 48, 56, 64, 80, 96, 112, 128, 160
32000 | 48, 56, 64, 80, 96, 112, 128, 160, 192, 224
44100 | 64, 80, 96, 112, 128, 160, 192, 224, 256, 320
48000 | 64, 80, 96, 112, 128, 160, 192, 224, 256, 320

The JavaScript interface

The JavaScript interface allows to create controls by JavaScript and HTML possibilities. The most example in the conaito VoiceMail SDK package based on it. JavaScript interface allows to customize applet controls correspondingly with web site scenario and style. The list of recording applet methods which can be accessible from JavaScript are in the Table 1.

The Java applet interface

The idea of Java applet interface is following: exist 2 applets - Mp3 recording applet and interface (front-end) applet. Recording applet has methods which are accessible outside of applet (table 1). Interface applet creates control panel with controls and accesses the recording applet methods (table 1) to control the recording applet. Also, recording applet sends messages to interface applet. Mp3 recording applet SDK package contains open source code of interface applet, so, user can re-design it correspondingly with web site scenario and style. Source code of interface applet is in the conaito VoiceMail SDK package in the Examples/Java/InterfaceApplet folder.

Note! Interface applet works under Java plug-in 1.4-1.6. Under Microsoft JVM Interface applet does not work. So, if you want to use recording applet under Microsoft JVM and Java plug-in 1.4-1.6, you have to use the JavaScript interface.


How to customize the input level indicator

You can customize the horizontal size ( "indicatorWidth" ) and colors ( "backgroudColor", "indicatorLevel1", " indicatorLevel2", "indicatorLevel13") of input level indicator accordingly to your web page style.

Fig. 1

The size and colors can be set as applet parameters. For example:

<PARAM NAME = "backgroudColor" value = "c0c0c0">

<PARAM NAME = "indicatorLevel1" value = "4664f0">

<PARAM NAME = "indicatorLevel2" value = "28c814">

<PARAM NAME = "indicatorLevel3" value = "f03250">

<PARAM NAME = "indicatorWidth" value = "330">

If these applet parameters are absent, applet uses default parameters. The are the same as in example.

Note! The width of applet window WIDTH must be the same as "indicatorWidth" parameter. The height of applet windows must be HEIGHT=24 always.


Translate applet messages

How to translate applet messages to the national languages

1. Translation in the case of JavaScript interface using

Applet passes to setStatus_RP(s,num) and confirmRecord(s,num) JavaScript functions messages and their numbers.

So, you can process the number and take message from table of messages in other languages. See messages in table 5a, 5b and 5c.

Table 5a: Status messages

Number of message | Description
1 | Loading audio module
2 | Recording voice message
3 | Paused. Press again for continue
4 | Stopped
5 | Playing voice message
6 | Uploading voice message
7 | Uploaded
8 | Connection to server
9 | Buffering
10 | Playing voice message from server
100 | blank

Table 5b: Information messages

Number of message | Description
11 | You must record the voice message before playing
12 | You must record the voice message before send it
13 | Please, enter the file name
14 | A file name must not contain any of the following characters: \\n \\ / . , : * ? \" < > | ! @ # $ % ^ & +<
15 | Please, select the voice file
16 | You are about to overwrite the voice message that you have recorded. Are you sure?

Table 5c: Error messages

Number of message | Description
-1 | Unknown Error
-2 | No sound card detect
-3 | Audio module could not be loaded
-4 | Voice message could not be uploaded
-5 | Incorrect IP address
-6 | Please check ServerScript parameter
-7 | Please check VoiceUrlContext parameter
-8 | Please check key file on the server
-9 | License is expired

2. Translation in the case of Java applet interface using

Recording applet passes to Interface applet methods ( ) the messages and their numbers. So, you can process the number and take message from table of messages in other languages. See messages in table 5a, 5b and 5c. Source code of Intarface applet is available. It is in the conaito VoiceMail SDK package in the Examples/Java/InterfaceApplet folder.


Technical support

In case you would like to download latest version of conaito VoiceMail SDK , find out relative information, or licence this SDK, please visit our website http://www.conaito.com

Our technical support staff will provide timely service on your problems encountered during using our product.

Please provide the following information when you submit your questions:

  • The installed version of conaito VoiceMail SDK
  • The installed type and version of your operation system
  • The details of the problem you encounter. And if it is possible, please inform us how to reproduce this problem
  • Please provide your license informations in case you have a licensed SDK

and our technical support staff will deal with your problem with priority.

At the meanwhile, it's our pleasure and honor to receive any comments and suggestions from you.


Our Service

Our Service for your Solutions

There is no doubt that "Voice over IP" telephony applications are increasing in importance. The strong demand is reflected in the steep upward trends in take-up. Significant costs can be saved and profits increased through VoIP. We offer a professional support for your projects and solutions to help you realize these benefits. Our experienced development team can assist you modify one of our SDKs or help with advice on how to design your own solutions within other applications.

There are many advantages to be gained for your business, or your own customers, through a range of possible solutions including:

  • Direct voice access

The convenience of free and instantaneous direct voice contact with individuals

  • Voice messenging

Leaving messages to be listened to at the receiver’s convenience.

  • Virtual workgroups

Creating focused group work involving individuals who are in different locations. This is the best way to keep everyone up to date on developments and involving substantial cost

savings in travel.

  • Virtual workplaces

Virtual workgroups operate in virtual workplaces and this results in significant savings in real estate rental or upkeep.

  • Meeting & conferences

Convenient group reviews and discussions, rapid resolution of group issues, can involve corporate or mixed customer-company groups, significant levels of saving of costs such as travel and accommodation.

  • Education, schools and eLearning

Particularly useful in supporting home-based learning and economising on student travel and accommodation costs and even books! This can help increase the numbers wishing to use such a basis for education. Teachers can serve a larger number of students without involving buildings, classrooms and associated maintenance and can themselves save costs of travel.

  • eCommuting

Major savings can be gained with staff working from home but using “free” data and voice communications. Such eCommuting reduces the real estate burden on companies; particularly important in service industries.

  • Online support

A large range of online support issues are better resolved using voice communications. In many conventional arrangements customers have to pay for line time when using telephonic support and VoIP eliminates this cost.

There are many other potential applications and benefits. Try imaging how VoIP might improve some aspect of your business operations or competitive position as well as help your customers. Let this potential for innovation inspire you to create better ideas! Why not contact us to review your requirements or explore possibilities by benefiting from our extended experience.

The conaito Team

www.conaito.com