Welcome

conaito PPT2Flash SDK – create. convert. share.

conaito PPT2Flash SDK – create. convert. share.

Powerful and rapid PowerPoint to Flash converting solution for your applications and Websites

With a high performance presentation you are well on the way to make a success of your product. Microsoft PowerPoint® is a famous tool for creating presentations. More than 90 per cent of total presentations all over the world were created by using of Microsoft PowerPoint®. But these presenting world-wide by efficient and fast way requires the well suited Internet format of Macromedia Flash®.

The conaito PPT2Flash SDK (Software Developing Kit) combines both fortes and makes also opportunities to integrate these in existing applications by an easy, fast and economical way for developers of Authoring Applications, Learning Management Systems (LMS) and Web applications, or makes opportunities to offer new applications, Web applications or Web services.

Our PowerPoint-to-Flash SDK provides you a smart and effective solution for converting PowerPoint presentations into an easy-to-use Online-Flash-presentation and professional Flash content authoring like Trade shows, Conferences, E-learning, Researching, Studies, E-cards, Fun content and many more!

The converted Flash presentation works and looks like your PowerPoint presentation PLUS all the advantages of a Flash file (already available in 98% of all Web browsers):

  • Easy online-distribution or CD
  • Greater Accessibility
  • Extensive Compatibility
  • Low file size
  • Resolution friendly
  • A safety and tamper proof format
  • Streaming technology
  • Viewing with or without Player

Potential applications of conaito PPT2Flash SDK:

  • Online Collaboration. Applications for online sharing of PowerPoint presentations.
  • Web-based Authoring Tool which nearly works like Macromedia Breeze®.
  • Learning Management Systems (LMS)
  • Web Seminar. Application for presentation of PowerPoint slide shows (converted to Flash).
  • Desktop applications, say authoring tools.
  • Web server, say presentation server platforms.
  • And much more!

Key features

The new Version 3.7 comes now with:

  • NEW in 3.7: MS Arial Unicode Font support
  • NEW in 3.7: PPTX-to-PPT converting
  • NEW in 3.7: Custom Video Converting arguments
  • NEW in 3.7: Set SWF Slide background as transparent
  • NEW in 3.7: Improved MS Powerpoint® 2007 support
  • NEW in 3.7: Improved Chinese and Japanese support
  • PLUS many reported bugs and problems are solved

  • Convert Microsoft PowerPoint® XP/2003/2007 to Adobe Flash®
  • Convert PPT files to single SWF files for each slide
  • Convert a PPT file in a single self running Flash presentation without need a additional player
  • Converts slides from-to single slides specified by slide Numbers
  • Converts single slides specified by slide Numbers
  • Convert different sizes (not longer only the default PowerPoint® size)
  • Adobe Flash® / Action Script 3.0 support (experimental)
  • Navigation Panel with extended position functions
  • TTC (True Type Collection) Fonts supported
  • 44 new motion effects supported (see Feature Chart for more details)
  • 12 additional effects supported (see Feature Chart for more details)
  • PowerPoint® Slide Transitions support (50+ see Feature Chart for more details)
  • Animated GIF support with Adobe Flash® Video (FLV) generation
  • Expanded Hyperlink support (Text, Shapes, Images etc.)
  • Video support (AVI, MPEG, MOV, M2V, WMV) with Adobe Flash® Video (FLV) generation
  • Audio support (WAV, MP3 - linked and embeded, recorded Audio in PPT)
  • Selectable Adobe Flash® Video target to save it on different space and custom Video Converting arguments
  • Improved Image quality is improved
  • Resize output per width/ height and scale factor
  • Html tag appearance support
  • Save Text optional from each Slide to XML
  • LoopAutoSlideChange property (Now AutoSlideChange, LoopAutoSlideChange and WaitBeforeSlideChange properties give you full control of playing flash if you dont set it in Microsoft PowerPoint® (In this case, Loop and AdvanceTime should be used)
  • Converting different possible Image export formats (PNG, BMP, JPG, GIF)
  • Convert Images RelativeToSlide, ClipRelativeToSlide, ScaleToFit, ScaleXY
  • Flash API for controlling of the converted presentation with JavaScript
  • Navigation support for single SWF output (embedded into swf – prev/next slide/stop/play buttons) with resume playback support
  • Thumbnail Generation of Slides (GIF, JPG, BMP) with size support
  • Command line edition without additional fee
  • Cross-Platform and Browser Playback
  • Slide Thumbnails
  • FULL FTP solution included - Easy uploading converted presentations to server
  • Keep Animated and Static Effects of Slides
  • Presenter Notes
  • Customize presentation player view (source code included)
  • All informations in XML
  • Support for multiple languages
  • Optimization for Hebrew, Japanese, East Asian and Arabian languages
  • Small and lightweight (output files are smaller and lighter in size)
  • Error handling (custom exceptions provides detailed info about problems during conversion)
  • Events are available for notification of conversion engine state change and conversion errors
  • Conversion can be aborted at any time
  • Gradient colors support
  • Paragraph bullets
  • Slide background
  • Paragraph alignment: left, center, right, justify
  • Underling, italic, bold fonts
  • Fully commented sample applications for various programming languages
  • Sample source code for VB.NET, C#, ASP.NET, .NET Webservice, ASP, PHP, JavaScript, C++, VB 6.0 and Delphi 7.0
  • .NET framework as well as COM support

... and much more!

For further information on these features click here .

Please, don't hesitate trying our PowerPoint-to-Flash SDK at once and get yourself, as well as your customers, the exciting experience of easy, fast and high quality standard applications which can convert PowerPoint into Flash.

Conaito PPT2Flash SDK is written in Microsoft .NET and provides the documentation, samples and related libraries you need to integrate with other applications or systems. The applications you develop with this edition of the SDK can run on Windows 2000, Windows XP, Windows 2003 and Windows Vista.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


What´s new?

conaito PPT2Flash SDK – create. convert. share.

PPT2Flash SDK v3.7 released - 07/2009

The new Version 3.7 comes now with:

  • NEW in 3.7: MS Arial Unicode Font support
  • NEW in 3.7: PPTX-to-PPT converting
  • NEW in 3.7: Custom Video Converting arguments
  • NEW in 3.7: Set SWF Slide background as transparent
  • NEW in 3.7: Improved MS Powerpoint® 2007 support
  • NEW in 3.7: Improved Chinese and Japanese support
  • PLUS reported bugs and problems are solved

PPT2Flash SDK v3.6 released - 10/2008

New features in Version 3.6:

  • NEW in 3.6: Improved Symbols and Table support
  • NEW in 3.6: Superscript and Subscript support
  • NEW in 3.6: Template support
  • NEW in 3.6: Selectable Adobe Flash® Video target to save it on different space

PPT2Flash SDK v3.5 released - 06/2008

New features in Version 3.5:

  • NEW in 3.5: Get size from orginal PPT
  • NEW in 3.5: Resize output per width/ height (not longer only per scale factor)
  • NEW in 3.5: Convert different size of ppt (not longer only default ppt size)
  • NEW in 3.5: New License Engine, more secure - not longer a external license file required
  • NEW in 3.5: .Net Webservice sample included
  • NEW in 3.5: FULL FTP solution included - Easy uploading converted presentations to server
  • PLUS rewritten code and many other reported bugs solved

Fixes:

  • fixed: many reported bugs

PPT2Flash SDK v3.0 released - 03/2008

The new Version 3.0 comes now with Adobe Flash® 9/ Action Script 3.0 support.

New features:

  • NEW in v3.0! Adobe Flash® 9/ Action Script 3.0 support
  • NEW in v3.0! New Design of Navigation Panel with extended position functions

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.7 released - 02/2008

The new Version 2.7 comes now with FTP Upload supported - now you can easy upload your converted presentations to your server.

New features:

  • NEW in v2.7! FTP Upload supported - now you can easy upload your converted presentations to your server

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.6 released - 01/2008

The new Version 2.6 provides now TTC (True Type Collection) Font support.

New features:

  • NEW in v2.6! TTC (True Type Collection) Fonts supported

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.5 released - 12/2007

The new Version 2.5 provides now 44 new supported motion effects and additional 12 new supported effects. Also include the new version a new VB.NET and ASP.NET sample.

New features:

  • NEW in v2.5! 44 new motion effects supported (see Feature Chart for more details)
  • NEW in v2.5! 12 additional effects supported (see Feature Chart for more details)
  • NEW in v2.5! New samples included (VB.NET and ASP.NET)

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.4.1 released - 12/2007

New features:

  • NEW in v2.4.1! New VB6 and VC8.0 sample included

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.4 released - 11/2007

New features:

  • NEW in v2.4! PowerPoint® Slide Transitions support (50+)
  • NEW in v2.4! Updated Delphi and VB6 sample

Fixes:

  • fixed: some reported bugs

PPT2Flash SDK v2.3 released - 11/2007

New features:

  • NEW in v2.3! Animated GIF support with Adobe Flash® Video (FLV) generation
  • NEW in v2.3! Expanded Hyperlink support (Text, Shapes, Images etc.)
  • NEW in v2.3! Additional Effects included (AnimEffectThread, AnimEffectSplit, AnimEffectBlink and AnimEffectFloat)

Fixes:

  • fixed: some Effects fixed
  • fixed: Video support on relative paths
  • fixed: some reported bugs

PPT2Flash SDK v2.2 released - 10/2007

New features:

  • NEW in v2.2! Video support (AVI, MPEG, MOV, M2V, WMV) with Adobe Flash® Video (FLV) generation (including synchronization with sound and speed)
  • NEW in v2.2! Audio support (WAV, MP3 - linked and embeded, recorded Audio in PPT)
  • NEW in v2.2! Japanese language support
  • NEW in v2.2! Custom Path effect supported
  • Image quality is improved (now original quality)
  • Html tag appearance support
  • Save Text optional from each Slide to XML
  • LoopAutoSlideChange property (Now AutoSlideChange, LoopAutoSlideChange and WaitBeforeSlideChange properties give you full control of playing flash if you dont set it in Microsoft PowerPoint® (In this case, Loop and AdvanceTime should be used)

Fixes:

  • fixed: Bullets problem fixed
  • fixed: Effects on slide master problem
  • fixed: Separated slides problem
  • fixed: Sound on effect problem
  • fixed: some reported bugs

PPT2Flash SDK v2.1 released - 09/2007

New features:

  • NEW in v2.1! Macromedia Flash® Video (FLV) generation (including synchronization with sound and speed)
  • NEW in v2.1! Image quality is improved (now original quality)
  • NEW in v2.1! Html tag appearance support
  • NEW in v2.1! Save Text optional from each Slide to XML
  • NEW in v2.1! LoopAutoSlideChange property (Now AutoSlideChange, LoopAutoSlideChange and WaitBeforeSlideChange properties give you full control of playing flash if you dont set it in Microsoft PowerPoint® (In this case, Loop and AdvanceTime should be used)

Fixes:

  • fixed: Bullets appearance fixed (coordinates of bullets)
  • fixed: Video appearance fixed and improved (synchronization with sound and speed)
  • fixed: Convert slides to separated swfs fixed - background
  • fixed: some reported bugs

PPT2Flash SDK v2.0 released - 07/2007

  • added: Macromedia Flash® Video (FLV) generation
  • added: Converting different possible Image export formats (PNG, BMP, JPG, GIF)
  • added: Convert Images RelativeToSlide, ClipRelativeToSlide, ScaleToFit, ScaleXY
  • added: WMV Video Format support
  • added: New Option for extraction of text in slides into a xml file
  • added: PHP and JavaScript/HTA sample
  • updated: Faster Video (MPEG, AVI) support
  • fixed: some reported bugs

PPT2Flash SDK v1.7.1 released - 07/2007

  • added: new Property 'SlidesCount' - allows to get slides count before actual converting
  • added: ConvertPPT2SWF(inputPptFile, outputSwfFolwer, firstSlideToConvert, lastSlideToConvert) method - allows to convert specified slides in mode "Convert each slide into separate swf file"
  • updated: C# sample GUI for better usability

PPT2Flash SDK v1.7 released - 07/2007

  • added: Flash API for controlling of the converted presentation with JavaScript
  • added: new Property 'WaitBeforeSlideChange' - allows to set amount of seconds to wait before to go to next slide in AutoSlideChange=true mode
  • fixed: some reported bugs

PPT2Flash SDK v1.6 released - 06/2007

  • added: Linked Audio (WAV) support for single SWF output
  • added: Update in v1.6! command line edition v1.6 without additional fee
  • added: Update in v1.6! ASP.NET sample
  • fixed: some reported bugs

PPT2Flash SDK v1.5 released - 05/2007

  • added: Video (MPEG) support
  • added: Video (AVI - partly) support
  • added: Navigation support for single SWF output (embedded into swf – prev/next slide/stop/play buttons) with resume playback support
  • added: new Property 'ConvertVideo'
  • fixed: some reported bugs

PPT2Flash SDK v1.4 released - 05/2007

  • added: Embedded Audio (MP3) support for single SWF output
  • added: Navigation support for single SWF output (embedded into swf – prev/next slide/stop/play buttons)
  • added: Image Generation of Slides (GIF, JPG, BMP) with size support
  • added: create Standalone Master SWF File
  • fixed: Microsoft Office 2007 support
  • fixed: Windows Vista support
  • fixed: some reported bugs

PPT2Flash SDK v1.3 released - 04/2007

  • added: Linked Audio (MP3) support for single SWF output
  • added: Converts single slides specified by slide Numbers
  • added: Converts slides from-to single slides specified by slide Numbers
  • fixed: some reported bugs

PPT2Flash SDK v1.2 released - 03/2007

  • added: Command Line Edition of the conaito PPT2Flash SDK without additional fee
  • added: Delphi 7 sample
  • added: ASP sample
  • fixed: single output effect bug solved
  • fixed: License file Issue
  • fixed: Bug single SWF and Advance Time

PPT2Flash SDK v1.1 released - 02/2007

  • added: new method ConvertPPT2SWFFile(PPTfilename, SWFfilename, advanceTime)
    to convert a ppt to a single swf (time for switch between slides can set in PowerPoint otherwise can set as parameter 'advanceTime')
  • added: COM support with VB 6.0 sample
  • added: new rewritten ASP.NET sample
  • added: new Property 'ScaleFactor' to set a scale of the swf (currently only single output supported)
  • fixed: Hyperlink color
  • added: Shadow
  • added: Crawl line and support of animation effect type "Motion Paths". Now new effects supported:
    4 Point Star, 5 Point Star, 6 Point Star, 8 Point Star, Diamond, Equal Triangle, Hexagon, Octagon, Parallelogram, Pentagon, Right Triangle, Square, Trapezoid, Diagonal Down Right, Diagonal Up Right, Down, Left, Right, Up, Zigzag, Custom Line
    with supporting "Edit/add points", Reverse Path Derection, Repeat count
  • added: Emboss text
  • fixed: Memory problem solved
  • fixed: Half-transparent colored text

added and changes - PPT2Flash SDK Update - 02/2007

  • fixed: Optimization for Arabian languages
  • fixed: Design template applying (multiple masters slide)

added and changes - PPT2Flash SDK Update - 01/2007

  • added: Optimization for East Asian languages
  • added: Support most of diagram types: Organization chart, Radial, Pyramid, Venn and Target diagram
  • Background update:
    added: fill effect - "Pattern" (completely)
    added: fill effect - "Texture" (completely)
    added: fill effect - "Gratient" Colors present: Early Sunset, Daybreak, Ocean, Moss and Parchment
    with supported Shading styles: Diagonal Down, Diagonal Up, Horizontal and Vertical.
  • Effects update:
    Zoom - Same as Orginal
    Credits - Same as Original
    Dissolve - alternative effect Fade
    Rise Up - alternative effect Fade
  • fixed: Font size problem
  • corrected bullet position

PPT2Flash SDK v1.0 released - 12/2006

For further information on these features click here .

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Full featured multi-format Help generator


PowerPoint vs. Flash

Why should you converting PowerPoint into Flash or SWF format?

Why should authors converting their PowerPoint presentations into Flash or SWF format?

The following advantages of Adobe Flash® formats will show the reason why this is the best choice for presentation sharing for training and business networks:

Greater Accessibility

Flash files are accessible: Most of the Internet browsers included a Flash PlugIn which enables access to Flash files for displaying converted PowerPoint presentations without any additional software.

Extensive Compatibility

The Flash format with extensive compatibility: SWF or Flash files are compatible with most of the operating systems (plat-forms), as well as of most of PDAs (handheld devices).

Content Security

Flash files are very safety: PowerPoint presentations can be easily edited, while Flash files are more safety. SWF files also do not pose any security threat, therefore, these are not sifted at firewalls. This ensures seamless delivery.

Streaming

Flash files by use of streaming technology enables online viewing of the presentation without download of any file.

Reduced Files Size

Flash files are high compressed and therefore they were the preferred medium for Internet streaming or file sharing. A Flash version of your PowerPoint presentation could be a mere 10% of its original size.

Resolution friendly

SWF is resolution friendly: Flash files are friendly with any size or display resolution. This makes them easy to handle across various device display sizes.

Transfer

Flash files requires only low capacity: Converted Flash files can be easily distributed and they are also well suited for file sharing. Contrary to CD-ROMs or DVDs these files don't require high memory capacity, therefore distributing these files is most comfortable. A file converted into Flash has only a split part of capacity than a PowerPoint file.

Our conaito PPT2Flash SDK enables you to create meaningful presentations in PowerPoint and converting to Flash format for easy sharing in e-learning and business.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Features and Animation effects

Features Overview/ Animation effects

Feature Overview

We describe below an overview of the features of conaito PPT2Flash SDK.

Key features

The new Version 3.7 comes now with:

  • NEW in 3.7: MS Arial Unicode Font support
  • NEW in 3.7: PPTX-to-PPT converting
  • NEW in 3.7: Custom Video Converting arguments
  • NEW in 3.7: Set SWF Slide background as transparent
  • NEW in 3.7: Improved MS Powerpoint® 2007 support
  • NEW in 3.7: Improved Chinese and Japanese support
  • PLUS reported bugs and problems are solved

  • Convert Microsoft PowerPoint® XP/2003/2007 to Adobe Flash®
  • Convert PPT files to single SWF files for each slide
  • Convert a PPT file in a single self running Flash presentation without need a additional player
  • Converts slides from-to single slides specified by slide Numbers
  • Converts single slides specified by slide Numbers
  • Convert different sizes (not longer only the default PowerPoint® size)
  • Adobe Flash® / Action Script 3.0 support (experimental)
  • Navigation Panel with extended position functions
  • TTC (True Type Collection) Fonts supported
  • 44 new motion effects supported (see Feature Chart for more details)
  • 12 additional effects supported (see Feature Chart for more details)
  • PowerPoint® Slide Transitions support (50+ see Feature Chart for more details)
  • Animated GIF support with Adobe Flash® Video (FLV) generation
  • Expanded Hyperlink support (Text, Shapes, Images etc.)
  • Video support (AVI, MPEG, MOV, M2V, WMV) with Adobe Flash® Video (FLV) generation
  • Audio support (WAV, MP3 - linked and embeded, recorded Audio in PPT)
  • Selectable Adobe Flash® Video target to save it on different space and custom Video Converting arguments
  • Improved Image quality is improved
  • Resize output per width/ height and scale factor
  • Html tag appearance support
  • Save Text optional from each Slide to XML
  • LoopAutoSlideChange property (Now AutoSlideChange, LoopAutoSlideChange and WaitBeforeSlideChange properties give you full control of playing flash if you dont set it in Microsoft PowerPoint® (In this case, Loop and AdvanceTime should be used)
  • Converting different possible Image export formats (PNG, BMP, JPG, GIF)
  • Convert Images RelativeToSlide, ClipRelativeToSlide, ScaleToFit, ScaleXY
  • Flash API for controlling of the converted presentation with JavaScript
  • Navigation support for single SWF output (embedded into swf – prev/next slide/stop/play buttons) with resume playback support
  • Thumbnail Generation of Slides (GIF, JPG, BMP) with size support
  • Command line edition without additional fee
  • Cross-Platform and Browser Playback
  • Slide Thumbnails
  • FULL FTP solution included - Easy uploading converted presentations to server
  • Keep Animated and Static Effects of Slides
  • Presenter Notes
  • Customize presentation player view (source code included)
  • All informations in XML
  • Support for multiple languages
  • Optimization for Hebrew, Japanese, East Asian and Arabian languages
  • Small and lightweight (output files are smaller and lighter in size)
  • Error handling (custom exceptions provides detailed info about problems during conversion)
  • Events are available for notification of conversion engine state change and conversion errors
  • Conversion can be aborted at any time
  • Gradient colors support
  • Paragraph bullets
  • Slide background
  • Paragraph alignment: left, center, right, justify
  • Underling, italic, bold fonts
  • Fully commented sample applications for various programming languages
  • Sample source code for VB.NET, C#, ASP.NET, .NET Webservice, ASP, PHP, JavaScript, C++, VB 6.0 and Delphi 7.0
  • .NET framework as well as COM support

... and much more!

Mapping Animation effects

We describe below an overview of the animation effects which currently supported with the conaito PPT2Flash SDK.

Id. | Name of Effect (Variations) | PPT2Flash SDK
1. | Appear /Disappear | Same as Original
2. | Fly In (Left, Eight, Bottom, Top, Left bottom, right bottom, left top, right top) — In(entry)-Out(Exit) | Same as Original
3. | Crawl (left, right, top, bottom) — In(entrj)-Out(Exit)- | Same as Original
4. | Blinds (Vertical, horizontal) — appear and disappear | Same as Original
5. | Box (In, out) — appear and disappear | Same as Original
6. | Checkerboard (Across and down) | Same as Original
7. | Dissolve (In-appears, Out-disappears) | Alternative effect Fade
8. | Flash once-Appear/ Disappear | Same as Original
9. | Peek (Left, right, top, bottom) — (In-appears, Out-disappears) | Alternative effect Fade
10. | Random bars (Vertical., Horizontal) — (Appear, disappear) | Same as Original
11. | Split (Horizontal, Vertical)— (Appear, disappear) | Same as Original
12. | Stretch (across, top, bottom, right, left)-(appear, disappear-works only across) | Same as Original
13. | Stripes (Left down, Left up, right down, right up) — (appear, disappears) | Same as Original
14. | Spiral (In-appear, out-disappear) | Same as Original
15. | Swivel (Horizontal, Vertical) | Same as Original
16. | Wipe (Left, top, right, bottom) | Same as Original
17. | Zoom In, In from screen center, In slightly, Out, Out from screen bottom, Out slightlj)--(appear, disappear) | Same as Original
18. | Circle (In, Out) | Same as Original
19. | Diamond (In, Out) | Same as Original
20. | Wedge | Same as Original
21. | Plus (In, out) | Same as Original
22. | Wheels (number of spokes-1 , 2, 3, 4, and 8) | Same as Original
23. | Expand | Same as Original
24. | Faded Swivel | Same as Original
25. | Fade | Same as Original
26. | Faded Zoom | Same as Original
27. | Ascend | Same as Original
28. | Color typewriter (First Color, Second color) | Alternative effect Fade
29. | Descend | Same as Original
30. | Grow and turn | Same as Original
31. | Spinner | Same as Original
32. | Unfold | Same as Original
33. | Center Revolve | Same as Original
34. | Compress | Same as Original
35. | Ease in | Same as Original
36. | Rise up | Same as Original
37. | Boomerang | Same as Original
38. | Credits | Same as Original
39. | Flip | Alternative effect Fade
40. | Fold | Same as Original
41. | Light speed | Alternative effect Fade
42. | Pinwheel | Same as Original
43. | Whip | Alternative effect Fade
44. | Bounce | Alternative effect Fade
45. | Curve up | Same as Original
46. | Float | Same as Original
47. | Glide | Same as Original
48. | Magnify | Same as Original
49. | Sling | Same as Original
50. | Thread (Can rewind it after animation is played) | Same as Original
51. | Change Fill color (Fill Color, Style-Gradient) | Alternative effect Fade
52. | Change font (Font names) | Alternative effect Fade
53. | Change font color (Color) | Alternative effect Fade
54. | Change font style (Bold, Italic, Underline) | Alternative effect Fade
55. | Change font size (Tiny, Smaller, Larger, huge, Custom percentage value for change in size) | Alternative effect Fade
56. | Grow Shrink (Horizontal, Vertical, both) --- (Tiny, Smaller, Larger, huge, Custom percentage value for change in size) | Same as Original
57. | Transparency (25, 50, 75, 100 or Custom percentage value for the transparency) | Same as Original
58. | Change line color (Color) | Alternative effect Fade
59. | Spin (Clockwise, Counter Clockwise)—(Quarter, Half, Full, Two spins, custom value for the spinning angle) | Same as Original
60. | Bold Flash | Alternative effect Fade
61. | Brush on underline | Alternative effect Fade
62. | Color Wave (Color) | Alternative effect Fade
63. | Complementary color 2 | Alternative effect Fade
64. | Darken | Alternative effect Fade
65. | Flash bulb | Same as Original
66. | Vertical highlight (Color) | Alternative effect Fade
67. | Brush on color (Color) | Alternative effect Fade
68. | Color blend (Color) | Alternative effect Fade
69. | Complementary color | Alternative effect Fade
70. | Contrasting color | Alternative effect Fade
71. | De-saturate | Alternative effect Fade
72. | Lighten | Alternative effect Fade
73. | Flicker (Color) | Alternative effect Fade
74. | Shimmer | Alternative effect Fade
75. | Grow with color (Color) | Alternative effect Fade
76. | Teeter (Color) | Alternative effect Fade
77. | Blast (Color) | Alternative effect Fade
78. | Bold reveal | Alternative effect Fade
79. | Wave | Alternative effect Fade
80. | Blink | Same as Original
81. | Style emphasis (Color) | Alternative effect Fade

Mapping Motion Path Effects

Id. | Name of Effect (Variations) | PPT2Flash SDK
82. | 4 Point Star | Same as Original
83. | 5 Point Star | Same as Original
84. | 6 Point Star | Same as Original
85. | 8 Point Star | Same as Original
86. | Diamond | Same as Original
87. | Equal Triangle | Same as Original
88. | Hexagon | Same as Original
89. | Octagon | Same as Original
90. | Parallelogram | Same as Original
91. | Pentagon | Same as Original
92. | Right Triangle | Same as Original
93. | Square | Same as Original
94. | Trapezoid | Same as Original
95. | Diagonal Down Right | Same as Original
96. | Diagonal Up Right | Same as Original
97. | Down | Same as Original
98. | Left | Same as Original
99. | Right | Same as Original
100. | Up | Same as Original
101. | Zigzag | Same as Original
102. | Custom Line with supporting "Edit/add points" | Same as Original
103. | Reverse Path Derection | Same as Original
104. | Repeat count | Same as Original
105. | Circle | Same as Original
106. | Crescent Moon | Same as Original
107. | Football | Same as Original
108. | Heart | Same as Original
109. | Teardrop | Same as Original
110. | Arc Down | Same as Original
111. | Arc Left | Same as Original
112. | Arc Right | Same as Original
113. | Arc Up | Same as Original
114. | Bounce Left | Same as Original
115. | Bounce Right | Same as Original
116. | Curvy Left | Same as Original
117. | Curvy Right | Same as Original
118. | Decaying Wave | Same as Original
119. | Funnel | Same as Original
120. | Heartbeat | Same as Original
121. | S Curve 1 | Same as Original
122. | S Curve 2 | Same as Original
123. | Sine Wave | Same as Original
124. | Spiral Left | Same as Original
125. | Spiral Right | Same as Original
126. | Spring | Same as Original
127. | Stairs Down | Same as Original
128. | Turn Down | Same as Original
129. | Turn Down Right | Same as Original
130. | Turn Up | Same as Original
131. | Turn Up Right | Same as Original
132. | Wave | Same as Original
133. | Bean | Same as Original
134. | Buzz Saw | Same as Original
135. | Curved Square | Same as Original
136. | Curved X | Same as Original
137. | Curvy Star | Same as Original
138. | Figure 8 Four | Same as Original
139. | Horizontal Figure 8 | Same as Original
140. | Inverted Square | Same as Original
141. | Inverted Triange | Same as Original
142. | Loop de Loop | Same as Original
143. | Neutron | Same as Original
144. | Peanut | Same as Original
145. | Plus | Same as Original
146. | Pointy Star | Same as Original
147. | Swoosh | Same as Original
148. | Vertigal Figure 8 | Same as Original

Animation effects legende:

Same as Original Same as Original

Alternative effect Fade Alternative effect Fade

Doesn't work completely Doesn't work completely

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


System Requirements

Development Environments/ System Requirements

The conaito PPT2Flash SDK runs on Windows and also includes a .NET interface that can be used in any .NET programming language like C# or VB.NET. You can use it with your web applications developed in ASP.NET as well. Conaito PPT2Flash SDK also includes a COM interface that can be used from any programming language that supports COM automation, like C++, Visual Basic, Delphi, ASP, PHP, JavaScript, VBScript, etc.

The contents of conaito PPT2Flash SDK and the supported development environments include all of the necessary software components for building systems based on conaito PPT2Flash SDK including documented operational software applications, player and examples (with source code), explanations as well as necessary service programs, libraries and components.

The supported development environments include:

• Visual Basic .NET

• Visual C++ .NET

• Visual C# .NET

• ASP.NET

• ASP, JSP, PHP (COM)

• JavaScript/HTML (COM)

• Visual Basic (COM)

• Visual C++ (COM)

• Borland Delphi (COM)

• and all development environments with COM and .NET framework support

End user system requirements:

In order to run the conaito PPT2Flash SDK, you must ensure that your computer meets the following minimum software and hardware requirements.

Requirement |
Operating System | Win2000 or higher
.NET Framework | .NET Framework 2.0
required Software | Microsoft PowerPoint® XP/2003/2007 A web browser and the Flash player.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Product Activation

Product Trial Activation (without conaito Banner)

Using our SDK trial version without conaito Banner requires a trial license. You can download the trial license when downloading the trial version or you can get it via e-mail.

Using of the received trial license:

  1. Add the path to this license file in your project and validate it

// Create instance of SDK

PPApplication ppTestApp = new PPApplication();

// Set path to license file

ppTestApp.SetLicense("conaito","xxx");

// checking for your license . . .

if (ppTestApp.isLicenseValid)

{

// checking licence information for validation

Console.WriteLine("License Information: Valid");

}

// ending session

ppTestApp.EndSession();

Further information can be found in our Getting started/ Using the PPT2FLASH SDK in VS.NET / VS.NET 2005 section.

Product Activation (licensed full version)

Please try our products before you buy. Our trial version have all the features found in the full version. The duration of trial periods are limited.

When you are ready please visit our website http://www.conaito.com to buy a license.

After purchasing the conaito PPT2Flash SDK you will get your license data.

Using of the received license data:

  1. Add the path to this license file in your project and validate it

// Create instance of SDK

PPApplication ppTestApp = new PPApplication();

// Set path to license file

ppTestApp.SetLicense("conaito","xxx");

// checking for your license . . .

if (ppTestApp.isLicenseValid)

{

// checking licence information for validation

Console.WriteLine("License Information: Valid");

}

// ending session

ppTestApp.EndSession();

Further information can be found in our Getting started/ Using the PPT2FLASH SDK in VS.NET / VS.NET 2005 section.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Licensing

• Single Product/ per Server or Service based Licensing

• Support and Maintenance

• Unlimited Redistribution/Royalty Free License

Our support team welcomes the opportunity to answer any questions you may have.

Educators and educational institutions can purchase the conaito PPT2Flash SDK at discounted prices.
Please contact us for more informations.

Single Product/ Server or Service based Licensing

We provide a 'Single License' to 'Single Product/ Server or Service'. You are limited to use the Single License under your product, server or service. So, if you have two different products, then you would have to buy two license keys.

But you are free to use a single license for as many copies of the product/ server or service for which you have purchased the License Key.

The exclusive selling of the conaito PPT2Flash SDK without it being integrated into product/ server or service or server is not permitted.

Here you can find more Information about our reseller program .

Support and Maintenance

The Support and Maintenance subscription provides you with eMail support for all of our products. In addition your subscription provides all new product releases and updates while your subscription is active.

The conaito PPT2Flash SDK can be purchased with either a without, 30 days, 6 months, 1 year, 2 years or Lifetime of support and maintenance subscription. If your support and maintenance agreement has expired it can be renewed by purchasing a "Subscription Renewal" within 30 days after expiration.

Unlimited Redistribution/ Royalty Free License and other Fees

You are free to redistribute, as many conaito PPT2Flash SDK (per Desktop application/ Royalty Free License) incorporated copies of your product.

Conaito Technologies provides royalty free licensing (per Desktop application/ Royalty Free License), you don't have to pay any fee or royalty to redistribute your products which incorporate conaito PPT2Flash Components. We do not charge any yearly or monthly fee.

Further information can be found in our license agreement section.

Third-party licenses

FFmpeg: The PPT2Flash SDK video and audio encoding is done with ffmpeg - a very fast and powerful tool © 2008 - Fabrice Bellard (originator of the FFmpeg project), et al.). FFmpeg is licensed under the GNU Lesser General Public License (LGPL). See the file 'COPYING.LGPL' for terms and conditions (documentation/licenses folder). Also see the file 'FFmpeg' for information specific to FFmpeg, copyrights and the LGPL (documentation/licenses folder). Used are the *unofficial* FFmpeg Win32 builds made by Ramiro Polla. These files were originally hosted at: http://arrozcru.no-ip.org/ffmpeg_builds/ The source code they were built with can also be found on the page above.

pthreads: Pthreads-win32 is free software, distributed under the GNU Lesser General Public License (LGPL). See the file 'COPYING.LGPL' for terms and conditions (documentation/licenses folder). Also see the file 'pthreads-win32' for information specific to pthreads-win32, copyrights and the LGPL (documentation/licenses folder).

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create PDF Help documents


License Agreement

This License Agreement defines the terms and conditions under which you (the Licensee) are permitted by conaito.com (conaito Technologies - the Licensor) to use the conaito PPT2Flash SDK.

1. Definitions

1.1 "Software Development Kit" shall mean and include the software programs and files needed to integrate the conaito Technologies software components with a software application, including documentation, examples, include files, declarations, source code, utility programs and conaito PPT2Flash SDK components.

1.2 "Application Program" shall mean and include one or more software programs created by the Licensee which use the conaito Technologies Software components.

2. License grant

2.1 Licensor hereby grants to the Licensee, and Licensee hereby accepts, subject to the terms and conditions set forth in this Agreement, a non-exclusive license to use Software Development Kit subject to the terms of this Agreement. The term "license" as used in this Agreement shall mean and include:

2.1.1 The right to use Software Development Kit under single:

• Product (per Desktop application/ Royalty Free License)

• Server

• Service

2.1.2 The right to redistribute one copy (per Desktop application/ Royalty Free License)

of the Redistributable Software with each copy of the Licensee's Application Program.

3. Restrictions

3.1 In accepting the license granted by Licensor, Licensee agrees that it shall not

3.1.1 Include the Redistributable Software with a product which is itself a software development kit, software component, or software library;

3.1.2 Permit its end-users to redistribute the Redistributable Software;

3.1.3 Loan or rent Software Development Kit to a third party;

3.1.4 Attempt to disassemble or reverse-engineer software included with the Software Development Kit.

3.1.5 Pass the license key, which you have received from conaito Technologies, to any user.

4. Term of Agreement

4.1 The term of this Agreement shall commence at the time Licensee receives Software Development Kit and shall continue in effect indefinitely unless terminated as specified in Termination of Agreement, below.

5. Termination of Agreement

5.1 The Licensee may terminate this Agreement at any time by destroying all copies of Software Development Kit. In the event of a material default by the Licensee or the Licensee's agent or representative, of any provision of this Agreement, the Licensor may terminate this Agreement upon thirty (30) days written notice, and the Licensee also has thirty (30) days of notice for termination. Upon termination of the Agreement, the Licensee shall either destroy all licensed copies of Software Development Kit, and all backups, or return them to Licensor. This obligation shall survive the termination of this Agreement.

6. Copyright and proprietary information

6.1 Licensee acknowledges that Software Development Kit and all supporting documentation constitute valuable property of Licensor and that all title and ownership rights in Software Development Kit and related materials remain exclusively with Licensor.

6.2 Licensor reserves all rights with respect to Software Development Kit under all applicable laws for the protection of proprietary information, including, but not limited to, trade secrets, copyrights, trademarks, and patents.

6.3 Except as otherwise provided in this Agreement, Licensee shall not cause or permit unauthorized copying, reproduction, or disclosure of any portion of the Software Development Kit or supporting documentation, or the delivery or distribution of any part thereof to any third person or entity, for any purpose whatsoever, without the prior written permission of Licensor. This restriction shall continue to bind Licensee and its agents and representatives beyond the termination of this Agreement.

Indemnification

7.1 Licensee shall indemnify and defend against any and all claims, including claims by third parties or employees of Licensee, which arise directly or indirectly out of Licensee's use or operation of the Software Development Kit or Redistributable Software.

7.2 The Licensor shall indemnify and hold the Licensee harmless from loss, damage, or liability for direct infringement of any United States, Canadian, or European Union member state patent or copyright with respect to the Software Development Kit or Redistributable Software, provided that the Software Development Kit or Redistributable Software have not been modified and provided the Licensor is promptly notified by the Licensee in writing of any infringement and is permitted to defend, compromise or settle such suit or claim, and provided the Licensee gives to the Licensor such available information, assistance and authority as the Licensor deems necessary to the defense of such suit or claim. Should the use of the Software Development Kit or Redistributable Software be enjoined, or in the event that the Licensor desires to minimize its liabilities hereunder, the Licensor shall have the right, at its sole option and expense to:

7.2.1 Procure for the Licensee the right to continue the use of the Software Development Kit or Redistributable Software; or,

7.2.2 Replace the Software Development Kit or Redistributable Software with a non-infringing product; or,

7.2.3 Modify the Software Development Kit or Redistributable Software so that it becomes non-infringing; or,

7.2.4 Refund to the Licensee the purchase price paid, if any, by the Licensee for the Software Development Kit.

Third-party licenses

FFmpeg: The PPT2Flash SDK video and audio encoding is done with ffmpeg - a very fast and powerful tool © 2008 - Fabrice Bellard (originator of the FFmpeg project), et al.). FFmpeg is licensed under the GNU Lesser General Public License (LGPL). See the file 'COPYING.LGPL' for terms and conditions (documentation/licenses folder). Also see the file 'FFmpeg' for information specific to FFmpeg, copyrights and the LGPL (documentation/licenses folder). Used are the *unofficial* FFmpeg Win32 builds made by Ramiro Polla. These files were originally hosted at: http://arrozcru.no-ip.org/ffmpeg_builds/ The source code they were built with can also be found on the page above.

pthreads: Pthreads-win32 is free software, distributed under the GNU Lesser General Public License (LGPL). See the file 'COPYING.LGPL' for terms and conditions (documentation/licenses folder). Also see the file 'pthreads-win32' for information specific to pthreads-win32, copyrights and the LGPL (documentation/licenses folder).

DISCLAIMER OF WARRANTY

THIS SOFTWARE DEVELOPMENT KIT IS SOLD "AS IS" AND WITHOUT WARRANTIES

AS TO PERFORMANCE OR MERCHANTABILITY.

THIS SOFTWARE DEVELOPMENT KIT IS SOLD WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES WHATSOEVER. BECAUSE OF THE DIVERSITY OF CONDITIONS AND HARDWARE UNDER WHICH THIS SOFTWARE DEVELOPMENT KIT MAY BE USED, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS OFFERED. THE USER IS ADVISED TO TEST THE SOFTWARE DEVELOPMENT KIT AND APPLICATIONS MAKING USE OF IT THOROUGHLY BEFORE RELYING ON IT. THE USER MUST ASSUME THE ENTIRE RISK OF USING THE SOFTWARE DEVELOPMENT KIT.

ANY LIABILITY OF SELLER OR MANUFACTURER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF THE PURCHASE PRICE.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Installation and uninstallation

conaito PPT2Flash SDK

Important! If you've got the conaito PPT2Flash SDK not from our web page, but from the other source (magazine CD or some software library), please visit our home page www.conaito.com - you'll probably find the later version.

Installation

Extract the downloaded zip file (conaitoPPT2FlashSDK.zip) to the directory you prefer.

Uninstallation

Delete the complete directory of the conaito PPT2Flash SDK and the related documents.

Further information can be found in our Getting started/ Using the PPT2FLASH SDK in VS.NET / VS.NET 2005 section.

Development Environments/ System Requirements

The conaito PPT2Flash SDK runs on Windows and also includes a .NET interface that can be used in any .NET programming language like C# or VB.NET. You can use it with your web applications developed in ASP.NET as well. Conaito PPT2Flash SDK also includes a COM interface that can be used from any programming language that supports COM automation, like C++, Visual Basic, Delphi, ASP, JSP, PHP, JavaScript, VBScript, etc.

The contents of conaito PPT2Flash SDK and the supported development environments include all of the necessary software components for building systems based on conaito PPT2Flash SDK including documented operational software applications, player and examples (with source code), explanations as well as necessary service programs, libraries and components.

The supported development environments include:

• Visual Basic .NET

• Visual C++ .NET

• Visual C# .NET

• ASP.NET

• ASP, JSP, PHP (COM)

• JavaScript/HTML (COM)

• Visual Basic (COM)

• Visual C++ (COM)

• Borland Delphi (COM)

• Sample source code for VB.NET, C#, ASP.NET, ASP, PHP, JavaScript, VB 6.0 and Delphi 7.0

End user system requirements:

Operating system: Win2000 or higher

.NET Framework 2.0

Microsoft PowerPoint® XP/2003/2007

A web browser and the Flash player.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Installation on Server

Installation on Server (for ASP.NET)

Configure DCOM

Among other things the conaito PPT2Flash SDK provides the sample ASP.NET demo. A successful conversion of your PowerPoint presentation on a Server requires also the following Server settings:

  • Go to the Start-Run menu item.
  • Type in "DCOMCNFG" and hit enter.
  • This should load the "Component Services" MMC (you can also load from Administrative Tools - Component Services"
  • Expand "Component Services"
  • Expand "Computers"
  • Expand "My Computer"
  • Select the "DCOM Config" item
  • Select the "Microsoft PowerPoint" item.
  • Right click and select Properties
  • Select the Security Tab and you should see the following:

  • Under "Launch and Activation Permissions" select the "Customize" option.
  • Click the "Edit" button

  • Click the "Add" button to add a new account to the list.
  • On the dialog that is displayed click the Locations button

    (this is because by default your domain will be selected and we need a local account)

    In this dialog scroll the list to the top (sometimes the first item is not visible) but scroll to the top and select the first item which is your computer name. In the list below "CCROWE" is the name of my computer.

  • Click the OK button
  • On the dialog that is displayed enter "ASPNET" as the account name.

  • Click the OK button

Note: A quicker way is to just enter the computer name and the account so in my case that would be:

ccrowe\ASPNET

  • Now make sure you select the following options for the "ASP.NET Machine Account"
    • Local Launch : Allow
    • Remote Launch : [blank]
    • Local Activation : Allow
    • Remote Activation : [blank]

These settings can be seen below:

Click the OK button and test your web application and it should work fine.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Full featured Documentation generator


Using the SDK in VS.NET

Using the PPT2FLASH SDK in VS.NET / VS.NET 2005

Getting start with us . . .

1. Create simple test of the PPT2Flash SDK

2. Checking your license

3. Convert PPT to SWF
4. Copy player data to folder

Events
1. Event ShapeProcessed

2. Event ShapeRender

3. Event SlideProcessed

4. Event SlideRender

Create Simple Test of the PPT2Flash SDK

It’s easier than getting cup of tea, it’s healthier that smoking marijuana, stay with us . . .

// Create instance of SDK

PPApplication ppTestApp = new PPApplication();

// input power point file

string curPath = ”input.ppt”;

// Set if render Powerpoint Effects

ppTestApp.RenderEffects = true;

// set truth values of hight quality

ppTestApp.HightQuality = true;

// set convertibility of filename and dataname

ppTestApp.ConvertPPT2SWF(filename, dataname);

// set coping to folder, taking folder name

ppTestApp.CopyPlayerDataToFolder(foldername);

// ending session

ppTestApp.EndSession();

// it's easy to understand, just try-)

First of all we are checking your program version

// Set path to license file

ppTestApp.SetLicense("conaito","xxx");

// checking for your license . . .

if (ppTestApp.isLicenseValid)

{

// checking licence information for validation

Console.WriteLine("License Information: Valid");

}

// ending session

ppTestApp.EndSession();

// checking for your license . . .

// if something is wrong you can contact with our developers

// ... if everything is clear ... and you can use it with brain

Convertibility PPT to SWF

// set loading data from power point file tacking file name

LoadFromFile(filename);

// set render getting path to PPT file

RenderToFolder(foldername);

Copying player data to folder

// checking for errors

try

{

// set of cur path which getting value in this way

string curPath = ”input.ppt”;

// checking for folder name

if (foldername != curPath)

{

// checking for truth exists and simultaneous deleting

if (File.Exists(foldername + @"index.exe")) File.Delete(foldername + @"index.exe");

}

// checking for truth exists and simultaneous copying

if (File.Exists(curPath) && !File.Exists(foldername)) File.Copy(curPath, foldername);

}

// if false then do this way ...

catch(Exception e) { throw new PptException(" Cannot copy player files "); }

Event ShapeProcessed

// checking for shape procession

if (ShapeProcessed != null)

{

// going to use, event shape process

ShapeProcessed(currentShape, totalShapes);

}

It’s used by Default, currentShape gives you the shape being currently processed, totalShapes gives you the total number of shape present in the PowerPoint slide.

Event ShapeRender

// checking for shape render

if (ShapeRender != null)

{

// going to use, event shape render

ShapeRender(currentShape, totalShapes);

}

SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint, currentSlide gives you the slide being currently processed, totalSlides gives you the total number of slides present in the PowerPoint file.

Event SlideProcessed

// checking for slide process

if (SlideProcessed != null)

{

// going to use, event slide process

SlideProcessed(currentSlide, totalSlides);

}

It’s used by Default, currentSlide gives you the slide being currently processed, totalSlides gives you the total number of slides present in the PowerPoint

Event SlideRender

// checking for slide render

if (SlideRender != null)

{

// going to use, event slide render

SlideRender(currentSlide, totalSlides);

}

SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint, currentSlide gives you the slide being currently processed, totalSlides gives you the total number of slides present in the PowerPoint file.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create HTML Help documents


Using the Comand line Edition

Please run "PPT2Flash.exe" in command line without parameters and then you will see all parameters list.

Converting with command line

Examples

PPT2Flash.exe /in:test.ppt

PPT2Flash.exe /in:test.ppt /single /out:test.swf /preview

Player Options

/copyplayer 'Specifies whether to copy player after converting.

/psource 'Specifies full path of directory with player files to be copied.

/pdestination 'Specifies full path of directory for the new player files.

Examples

PPT2Flash.exe /in:test.ppt /copyplayer

PPT2Flash.exe /in:test.ppt /psource:D:\Conaito\Conaito Command Line Edition\ /pdestination:D:\Conaito\Conaito Command Line Edition\output\"

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Free Web Help generator


Files included within the SDK

VS.NET, VS.NET 2005 and Files to be shipped for your application

Following files are required for application installation and for running of conversion module:

The conaito PPT2Flash DLL:

PPLibrary.dll - conaito PowerPoint to Flash/ SWF Library
PPLibrary.tlb - main conversion dll for COM implementation

Optional one of the included player or the player of your own development:

index.html/ index.swf or/and index.exe – depending from player version

Microsoft Office DLL (version depending):

Microsoft.Office.Interop.PowerPoint.dll - office DLL

office.dll - office DLL

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Converted Files

Following files will be generated during conversion procedure for output into file directory by your choice.

Multiple SWF Output (SWF file for each slide, XML file with speaker nodes and optional player)

The Master files

Depending from PowerPoint template up to 2 Master files will be generated. The first one is Slide Master SWF (master_SlideMaster.swf) which is the slide header part used by each slide swf file. The next one is the Title Master SWF (master_TitleMaster.swf). This is the title header part which is used once in first slide

SWF

The generated slide files (Slide1.. Slide10.swf) included the converted PowerPoint slides.

Thumbnails

The generated Thumbnail image files are well suited for preview.

XML

The XML file inclusive all required information of converted presentation (swfs.xml).

Get more information here > „Output presentation XML file“

Player

The player which is required for displaying of converted presentation by your choice.

Get more information here > „Using the Players (exe, html/swf)“

Single Output (single SWF file inlcude all slides)

SWF

The generated SWF file include the converted PowerPoint slides.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Full featured Help generator


Output presentation XML file

During conversion an additional XML file will be generated which includes all required information about presentation (swfs.xml). This included also all information of each slide, all speaker notes and further information.

<?xml version="1.0" encoding="utf-8"?>

<swfs>

<SwfWidth>720</SwfWidth>

<SwfHeight>720</SwfHeight>

<Slides>

<Slide id="1">

<FileName>Slide1.swf</FileName>

<Master>master_SlideMaster.swf</Master>

<Title>Background</Title>

<Notes> </Notes>

</Slide>

</Slides>

</swfs>

Very simple, also we can add some additional information like:

<?xml version="1.0" encoding="utf-8"?>

<swfs>

<SwfWidth>720</SwfWidth>

<SwfHeight>720</SwfHeight>

<Information>

Here you can add your XML data

</Information>

<Slides>

<Slide id="1">

<FileName>Slide1.swf</FileName>

<Master>master_SlideMaster.swf</Master>

<Title>Background</Title>

<Notes> </Notes>

<Information>

Here you can add your XML data for I slide

</Information>

</Slide>

</Slides>

</swfs>

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Free help authoring environment


Using the Players

The conaito PPT2Flash SDK bundles with itself three sample players for viewing the output flash files. You can use either of the three depending upon your requirements or develop your own custom player (source code available).

The Players:

    1. HTML/SWF (index.html, index.swf) based player which you can use for your web based applications.
    2. HTML/ JavaScript/ SWF based based player which you can use for your web based applications.This player demonstrate how you can use JavaScript to control the converted presentation.
    3. The compiled Flash Player (index.exe) that you can use as stand alone.

Getting the HTML Player to function properly

The HTML player is automatically copied to the output location on successful conversion of the PowerPoint files. You just need to run the Index.html file to view the output.

While executing the output through the HTML player, you may receive a Java Script based error “Access is Denied”. This error occurs only if you are executing the HTML file directly from your local drive. This error will not appear in case you are viewing it through IIS. (http://localhost/Test/Index.html).

To resolve this you need to go to Tools à Internet Options

Go to Security tab

Go to Security à Custom Level and enable the option ‘Initialize and script ActiveX controls not marked as safe’.

Enable the option ‘Initialize and script ActiveX controls not marked as safe’

Press OK on both the screens and refresh the page. Now it should work perfectly.

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Registering the Dll for COM

Registering the Dll for COM use

You can register the conaito PPLibrary.dll for use within your COM application by the help of Regasm.exe which is available with the .NET Framework.

Using Regasm.exe from .NET Framework

It’s easier than getting cup of tea, it’s healthier that smoking marijuana, stay with us . . .

The command to do it is:

// command line at the DOS prompt

Regasm Dll\PPLibrary.dll /unregister
Regasm Dll\PPLibrary.dll /tlb:PPLibrary.tlb /codebase

Regasm.exe reads the metadata within an assembly and adds the necessary entries to the registry, which allows COM clients to create .NET Framework classes transparently.

Note: Regasm.exe can be found in "%windir%\Microsoft.NET\Framework\v1.1.xxxx" where xxxx is the build number of the .NET Framework you are using.

Now you are ready to use the wrapped .NET class in your VB6 program.

Note: Executing COM Project in debug mode might give an error. Create an exe and then test it.

Using VisualBasic 6.0 sample - conaito PPT2Flash SDK

To run VB6 Sample follow next steps:

1. Run Register.bat.

2. Run PPTLibraryTestsVB6.exe or open PPTLibraryTestsVB6.vbp using VisualBasic 6.0

More information: How to consume a managed type from COM

http://msdn2.microsoft.com/en-us/library/zsfww439.aspx

* Adobe Flash®. and Macromedia Breeze® are registered trademarks of Adobe.

* Microsoft PowerPoint® is a registered trademark of Microsoft.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create CHM Help documents


Reference

conaito PPT2Flash SDK

Important! If you've got the conaito PPT2Flash SDK not from our web page, but from the other source (magazine CD or some software library), please visit our home page www.conaito.com - you'll probably find the later version.

Reference information can be found in documentation folder of the SDK (conaito.PPT2FlashSDK.Reference.chm).

or

conaito Live Doc´s ( online ) of the PPT2Flash SDK
( http://www.conaito.com/docus/ppt2flash/Reference/index.html ).

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easily create Web Help sites


Technical support

In case you would like to download latest version of conaito PPT2Flash SDK , find out relative information, or licence this SDK, please visit our website http://www.conaito.com

Our technical support staff will provide timely service on your problems encountered during using our product.

Please provide the following information when you submit your questions:

  • The installed version of conaito PPT2Flash SDK
  • The installed type and version of your operation system
  • The details of the problem you encounter. And if it is possible, please inform us how to reproduce this problem
  • Please provide your license informations in case you have a licensed SDK

and our technical support staff will deal with your problem with priority.

At the meanwhile, it's our pleasure and honor to receive any comments and suggestions from you.

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Our Service

Our Service for your Solutions

There is no doubt that "Voice over IP" telephony applications are increasing in importance. The strong demand is reflected in the steep upward trends in take-up. Significant costs can be saved and profits increased through VoIP. We offer a professional support for your projects and solutions to help you realize these benefits. Our experienced development team can assist you modify one of our SDKs or help with advice on how to design your own solutions within other applications.

There are many advantages to be gained for your business, or your own customers, through a range of possible solutions including:

  • Direct voice access

The convenience of free and instantaneous direct voice contact with individuals

  • Voice messenging

Leaving messages to be listened to at the receiver’s convenience.

  • Virtual workgroups

Creating focused group work involving individuals who are in different locations. This is the best way to keep everyone up to date on developments and involving substantial cost

savings in travel.

  • Virtual workplaces

Virtual workgroups operate in virtual workplaces and this results in significant savings in real estate rental or upkeep.

  • Meeting & conferences

Convenient group reviews and discussions, rapid resolution of group issues, can involve corporate or mixed customer-company groups, significant levels of saving of costs such as travel and accommodation.

  • Education, schools and eLearning

Particularly useful in supporting home-based learning and economising on student travel and accommodation costs and even books! This can help increase the numbers wishing to use such a basis for education. Teachers can serve a larger number of students without involving buildings, classrooms and associated maintenance and can themselves save costs of travel.

  • eCommuting

Major savings can be gained with staff working from home but using “free” data and voice communications. Such eCommuting reduces the real estate burden on companies; particularly important in service industries.

  • Online support

A large range of online support issues are better resolved using voice communications. In many conventional arrangements customers have to pay for line time when using telephonic support and VoIP eliminates this cost.

There are many other potential applications and benefits. Try imaging how VoIP might improve some aspect of your business operations or competitive position as well as help your customers. Let this potential for innovation inspire you to create better ideas! Why not contact us to review your requirements or explore possibilities by benefiting from our extended experience.

The conaito Team

www.conaito.com

Any Questions?

Our Support Forum or Knowledgebase/ Helpdesk is the best way for your questions. By this way can we help many user to find a answer on their questions.

Please feel free to contact the conaito Support Team incase of any question.

Copyright © 2009, conaito Technologies - www.conaito.com. All rights reserved.

Created with the Freeware Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation