Conaito.PPLibrary

conaito PPT2Flash SDK 3.7

Conaito.PPLibrary Namespace

Namespace Hierarchy

Classes

Class | Description
AnimationEffectException | The exception that is thrown when power point animation effect cannot be applied.
BasePPTException | Represents base power point exception class for inheritance
BaseSwfException | Represents base flash exception class for inheritance
FtpClient |
FtpClient.FtpException |
PowerPointNotInstalledException |
PPApplication | Powerpoint to SWF Application
PPTEventException |
PptException | The exception that is thrown when power point data cannot be loaded.
RegistryException | The exception that is thrown when registry load/save cannot be performed.
TtfException | The exception that is thrown when true type font cannot be loaded correctly.
ZipException | The exception that is thrown when flash cannot be compressed by zlip compression method.

Interfaces

Interface | Description
IPPApplication | Default interface of PPApplication class for COM interop

Delegates

Delegate | Description
PPApplication.PPTErrorHandler |
PPApplication.ShapeProcessedHandler | ShapeProcessed is fired when SDK is reading the shape information from the slides within the PowerPoint.
PPApplication.ShapeRenderHandler | ShapeRender is fired when SDK is compleate render the shape information from the slides within the PowerPoint.
PPApplication.SlideProcessedHandler | SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint.
PPApplication.SlideRenderHandler | SlideRender is fired when SDK is compleate render the information from the slides within the PowerPoint.
PPApplication.ThumbsRenderHandler |

Enumerations

Enumeration | Description
ExportImageFormat | Specifies image type of exported image from power point
ExportImageMode | Specified image mode of exported image from power point
NavigationPanelAlignment |
PPApplication.OfficeComponent |
ThumbsFormats |

Send comments on this topic.

© conaito Technologies 2009


AnimationEffectException Class

The exception that is thrown when power point animation effect cannot be applied.

For a list of all members of this type, see AnimationEffectException Members .

System.Object
Exception
ApplicationException
BasePPTException
AnimationEffectException

[Visual Basic]
Public Class AnimationEffectException
Inherits BasePPTException
[C#]
public class AnimationEffectException : BasePPTException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

AnimationEffectException Members | Conaito.PPLibrary Namespace


AnimationEffectException Members

AnimationEffectException overview

Public Instance Constructors

AnimationEffectException Constructor Initializes a new instance of the AnimationEffectException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

AnimationEffectException Class | Conaito.PPLibrary Namespace


AnimationEffectException Constructor

Initializes a new instance of the AnimationEffectException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
AnimationEffectException(
string message
);

Parameters

message
The message.

See Also

AnimationEffectException Class | Conaito.PPLibrary Namespace


BasePPTException Class

Represents base power point exception class for inheritance

For a list of all members of this type, see BasePPTException Members .

System.Object
Exception
ApplicationException
BasePPTException
AnimationEffectException
PptException
RegistryException
TtfException
ZipException

[Visual Basic]
Public MustInherit Class BasePPTException
Inherits ApplicationException
[C#]
public abstract class BasePPTException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

BasePPTException Members | Conaito.PPLibrary Namespace


BasePPTException Members

BasePPTException overview

Public Instance Constructors

BasePPTException Constructor Initializes a new instance of the BasePPTException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

BasePPTException Class | Conaito.PPLibrary Namespace


BasePPTException Constructor

Initializes a new instance of the BasePPTException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
BasePPTException(
string message
);

Parameters

message
The message.

See Also

BasePPTException Class | Conaito.PPLibrary Namespace


BaseSwfException Class

Represents base flash exception class for inheritance

For a list of all members of this type, see BaseSwfException Members .

System.Object
Exception
ApplicationException
BaseSwfException

[Visual Basic]
Public MustInherit Class BaseSwfException
Inherits ApplicationException
[C#]
public abstract class BaseSwfException : ApplicationException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

BaseSwfException Members | Conaito.PPLibrary Namespace


BaseSwfException Members

BaseSwfException overview

Public Instance Constructors

BaseSwfException Constructor Initializes a new instance of the BaseSwfException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

BaseSwfException Class | Conaito.PPLibrary Namespace


BaseSwfException Constructor

Initializes a new instance of the BaseSwfException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
BaseSwfException(
string message
);

Parameters

message
The message.

See Also

BaseSwfException Class | Conaito.PPLibrary Namespace


ExportImageFormat Enumeration

Specifies image type of exported image from power point

[Visual Basic]
Public Enum ExportImageFormat
[C#]
public enum ExportImageFormat

Members

Member Name | Description
GIF |
JPG |
PNG |
BMP |

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


ExportImageMode Enumeration

Specified image mode of exported image from power point

[Visual Basic]
Public Enum ExportImageMode
[C#]
public enum ExportImageMode

Members

Member Name | Description
RelativeToSlide |
ClipRelativeToSlide |
ScaleToFit |
ScaleXY |

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


FtpClient Class

For a list of all members of this type, see FtpClient Members .

System.Object
FtpClient

[Visual Basic]
Public Class FtpClient
[C#]
public class FtpClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

FtpClient Members | Conaito.PPLibrary Namespace


FtpClient Members

FtpClient overview

Public Instance Constructors

FtpClient Overloaded. Initializes a new instance of the FtpClient class.

Public Instance Properties

BinaryMode | If the value of mode is true, set binary mode for downloads, else, Ascii mode.
Password | Gets and Set the password.
Port | Remote server port. Typically TCP 21
RemotePath | GetS and Sets the remote directory.
RemotePort | Gets and Sets the port number.
Server | Gets and Sets the name of the FTP server.
Timeout | Timeout waiting for a response from server, in seconds.
Username | Gets and Sets the username.
VerboseDebugging | Display all communications to the debug log

Public Instance Methods

BeginChangeDir |
BeginClose |
BeginDeleteFile |
BeginDownload | Overloaded.
BeginGetFileList | Overloaded.
BeginGetFileSize |
BeginLogin |
BeginMakeDir |
BeginRemoveDir |
BeginRenameFile |
BeginUpload | Overloaded.
BeginUploadDirectory | Overloaded.
ChangeDir | Change the current working directory on the remote FTP server.
Close | Close the FTP connection.
DeleteFile | Delete a file from the remote FTP server.
Download | Overloaded. Download a file to the Assembly's local directory, keeping the same file name.
Equals (inherited from Object) |
GetFileList | Overloaded. Return a string array containing the remote directory's file list.
GetFileSize | Return the size of a file.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Login | Login to the remote server.
MakeDir | Create a directory on the remote FTP server.
RemoveDir | Delete a directory on the remote FTP server.
RenameFile | Rename a file on the remote FTP server.
ToString (inherited from Object) |
Upload | Overloaded. Upload a file.
UploadDirectory | Overloaded. Upload a directory and its file contents

Protected Instance Methods

Finalize | Destuctor
MemberwiseClone (inherited from Object) |

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient Constructor

Default contructor

Overload List

Default contructor

public FtpClient()

public FtpClient(string,string,string)

public FtpClient(string,string,string,int,int)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient Constructor

Default contructor

[Visual Basic]
Public Overloads Sub New()
[C#]
FtpClient();

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient Constructor Overload List


FtpClient Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal server As String, _
ByVal username As String, _
ByVal password As String _
)
[C#]
FtpClient(
string server,
string username,
string password
);

Parameters

server
username
password

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient Constructor Overload List


FtpClient Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal server As String, _
ByVal username As String, _
ByVal password As String, _
ByVal timeoutSeconds As Integer, _
ByVal port As Integer _
)
[C#]
FtpClient(
string server,
string username,
string password,
int timeoutSeconds,
int port
);

Parameters

server
username
password
timeoutSeconds
port

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient Constructor Overload List


FtpClient Properties

The properties of the FtpClient class are listed below. For a complete list of FtpClient class members, see the FtpClient Members topic.

Public Instance Properties

BinaryMode | If the value of mode is true, set binary mode for downloads, else, Ascii mode.
Password | Gets and Set the password.
Port | Remote server port. Typically TCP 21
RemotePath | GetS and Sets the remote directory.
RemotePort | Gets and Sets the port number.
Server | Gets and Sets the name of the FTP server.
Timeout | Timeout waiting for a response from server, in seconds.
Username | Gets and Sets the username.
VerboseDebugging | Display all communications to the debug log

See Also

FtpClient Class | Conaito.PPLibrary Namespace


BinaryMode Property

conaito PPT2Flash SDK 3.7

FtpClient.BinaryMode Property

If the value of mode is true, set binary mode for downloads, else, Ascii mode.

[Visual Basic]
Public Property BinaryMode() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool BinaryMode { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Password Property

conaito PPT2Flash SDK 3.7

FtpClient.Password Property

Gets and Set the password.

[Visual Basic]
Public Property Password() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Password { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Port Property

conaito PPT2Flash SDK 3.7

FtpClient.Port Property

Remote server port. Typically TCP 21

[Visual Basic]
Public Property Port() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int Port { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


RemotePath Property

conaito PPT2Flash SDK 3.7

FtpClient.RemotePath Property

GetS and Sets the remote directory.

[Visual Basic]
Public Property RemotePath() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string RemotePath { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


RemotePort Property

conaito PPT2Flash SDK 3.7

FtpClient.RemotePort Property

Gets and Sets the port number.

[Visual Basic]
Public Property RemotePort() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int RemotePort { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Server Property

conaito PPT2Flash SDK 3.7

FtpClient.Server Property

Gets and Sets the name of the FTP server.

[Visual Basic]
Public Property Server() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Server { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Timeout Property

conaito PPT2Flash SDK 3.7

FtpClient.Timeout Property

Timeout waiting for a response from server, in seconds.

[Visual Basic]
Public Property Timeout() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int Timeout { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Username Property

conaito PPT2Flash SDK 3.7

FtpClient.Username Property

Gets and Sets the username.

[Visual Basic]
Public Property Username() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string Username { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


VerboseDebugging Property

conaito PPT2Flash SDK 3.7

FtpClient.VerboseDebugging Property

Display all communications to the debug log

[Visual Basic]
Public Property VerboseDebugging() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool VerboseDebugging { public get; public set; }

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient Methods

The methods of the FtpClient class are listed below. For a complete list of FtpClient class members, see the FtpClient Members topic.

Public Instance Methods

BeginChangeDir |
BeginClose |
BeginDeleteFile |
BeginDownload | Overloaded.
BeginGetFileList | Overloaded.
BeginGetFileSize |
BeginLogin |
BeginMakeDir |
BeginRemoveDir |
BeginRenameFile |
BeginUpload | Overloaded.
BeginUploadDirectory | Overloaded.
ChangeDir | Change the current working directory on the remote FTP server.
Close | Close the FTP connection.
DeleteFile | Delete a file from the remote FTP server.
Download | Overloaded. Download a file to the Assembly's local directory, keeping the same file name.
Equals (inherited from Object) |
GetFileList | Overloaded. Return a string array containing the remote directory's file list.
GetFileSize | Return the size of a file.
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
Login | Login to the remote server.
MakeDir | Create a directory on the remote FTP server.
RemoveDir | Delete a directory on the remote FTP server.
RenameFile | Rename a file on the remote FTP server.
ToString (inherited from Object) |
Upload | Overloaded. Upload a file.
UploadDirectory | Overloaded. Upload a directory and its file contents

Protected Instance Methods

Finalize | Destuctor
MemberwiseClone (inherited from Object) |

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginChangeDir Method

[Visual Basic]
Public Sub BeginChangeDir( _
ByVal dirName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginChangeDir(
string dirName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginClose Method

[Visual Basic]
Public Sub BeginClose( _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginClose(
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginDeleteFile Method

[Visual Basic]
Public Sub BeginDeleteFile( _
ByVal fileName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginDeleteFile(
string fileName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


BeginDownload Method

conaito PPT2Flash SDK 3.7

FtpClient.BeginDownload Method

Overload List

public IAsyncResult BeginDownload(string,AsyncCallback)

public IAsyncResult BeginDownload(string,bool,AsyncCallback)

public IAsyncResult BeginDownload(string,string,AsyncCallback)

public IAsyncResult BeginDownload(string,string,bool,AsyncCallback)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginDownload(String, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginDownload( _
ByVal remFileName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginDownload(
string remFileName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginDownload Overload List


FtpClient.BeginDownload(String, Boolean, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginDownload( _
ByVal remFileName As String, _
ByVal resume As Boolean, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginDownload(
string remFileName,
bool resume,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginDownload Overload List


FtpClient.BeginDownload(String, String, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginDownload( _
ByVal remFileName As String, _
ByVal locFileName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginDownload(
string remFileName,
string locFileName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginDownload Overload List


FtpClient.BeginDownload(String, String, Boolean, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginDownload( _
ByVal remFileName As String, _
ByVal locFileName As String, _
ByVal resume As Boolean, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginDownload(
string remFileName,
string locFileName,
bool resume,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginDownload Overload List


BeginGetFileList Method

conaito PPT2Flash SDK 3.7

FtpClient.BeginGetFileList Method

Overload List

public IAsyncResult BeginGetFileList(AsyncCallback)

public IAsyncResult BeginGetFileList(string,AsyncCallback)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginGetFileList(AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginGetFileList( _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginGetFileList(
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginGetFileList Overload List


FtpClient.BeginGetFileList(String, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginGetFileList( _
ByVal mask As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginGetFileList(
string mask,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginGetFileList Overload List


FtpClient.BeginGetFileSize Method

[Visual Basic]
Public Sub BeginGetFileSize( _
ByVal fileName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginGetFileSize(
string fileName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginLogin Method

[Visual Basic]
Public Sub BeginLogin( _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginLogin(
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginMakeDir Method

[Visual Basic]
Public Sub BeginMakeDir( _
ByVal dirName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginMakeDir(
string dirName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginRemoveDir Method

[Visual Basic]
Public Sub BeginRemoveDir( _
ByVal dirName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginRemoveDir(
string dirName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginRenameFile Method

[Visual Basic]
Public Sub BeginRenameFile( _
ByVal oldFileName As String, _
ByVal newFileName As String, _
ByVal overwrite As Boolean, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginRenameFile(
string oldFileName,
string newFileName,
bool overwrite,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace


BeginUpload Method

conaito PPT2Flash SDK 3.7

FtpClient.BeginUpload Method

Overload List

public IAsyncResult BeginUpload(string,AsyncCallback)

public IAsyncResult BeginUpload(string,bool,AsyncCallback)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginUpload(String, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginUpload( _
ByVal fileName As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginUpload(
string fileName,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginUpload Overload List


FtpClient.BeginUpload(String, Boolean, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginUpload( _
ByVal fileName As String, _
ByVal resume As Boolean, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginUpload(
string fileName,
bool resume,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginUpload Overload List


BeginUploadDirectory Method

conaito PPT2Flash SDK 3.7

FtpClient.BeginUploadDirectory Method

Overload List

public IAsyncResult BeginUploadDirectory(string,bool,AsyncCallback)

public IAsyncResult BeginUploadDirectory(string,bool,string,AsyncCallback)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.BeginUploadDirectory(String, Boolean, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginUploadDirectory( _
ByVal path As String, _
ByVal recurse As Boolean, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginUploadDirectory(
string path,
bool recurse,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginUploadDirectory Overload List


FtpClient.BeginUploadDirectory(String, Boolean, String, AsyncCallback) Method

[Visual Basic]
Public Overloads Sub BeginUploadDirectory( _
ByVal path As String, _
ByVal recurse As Boolean, _
ByVal mask As String, _
ByVal callback As AsyncCallback _
)
[C#]
public IAsyncResult BeginUploadDirectory(
string path,
bool recurse,
string mask,
AsyncCallback callback
);

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.BeginUploadDirectory Overload List


FtpClient.ChangeDir Method

Change the current working directory on the remote FTP server.

[Visual Basic]
Public Sub ChangeDir( _
ByVal dirName As String _
)
[C#]
public void ChangeDir(
string dirName
);

Parameters

dirName

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.Close Method

Close the FTP connection.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.DeleteFile Method

Delete a file from the remote FTP server.

[Visual Basic]
Public Sub DeleteFile( _
ByVal fileName As String _
)
[C#]
public void DeleteFile(
string fileName
);

Parameters

fileName

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Download Method

conaito PPT2Flash SDK 3.7

FtpClient.Download Method

Download a file to the Assembly's local directory, keeping the same file name.

Overload List

Download a file to the Assembly's local directory, keeping the same file name.

public void Download(string)

Download a remote file to the Assembly's local directory, keeping the same file name, and set the resume flag.

public void Download(string,bool)

Download a remote file to a local file name which can include a path. The local file name will be created or overwritten, but the path must exist.

public void Download(string,string)

Download a remote file to a local file name which can include a path, and set the resume flag. The local file name will be created or overwritten, but the path must exist.

public void Download(string,string,bool)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.Download(String) Method

Download a file to the Assembly's local directory, keeping the same file name.

[Visual Basic]
Public Overloads Sub Download( _
ByVal remFileName As String _
)
[C#]
public void Download(
string remFileName
);

Parameters

remFileName

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Download Overload List


FtpClient.Download(String, Boolean) Method

Download a remote file to the Assembly's local directory, keeping the same file name, and set the resume flag.

[Visual Basic]
Public Overloads Sub Download( _
ByVal remFileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Download(
string remFileName,
bool resume
);

Parameters

remFileName
resume

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Download Overload List


FtpClient.Download(String, String) Method

Download a remote file to a local file name which can include a path. The local file name will be created or overwritten, but the path must exist.

[Visual Basic]
Public Overloads Sub Download( _
ByVal remFileName As String, _
ByVal locFileName As String _
)
[C#]
public void Download(
string remFileName,
string locFileName
);

Parameters

remFileName
locFileName

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Download Overload List


FtpClient.Download(String, String, Boolean) Method

Download a remote file to a local file name which can include a path, and set the resume flag. The local file name will be created or overwritten, but the path must exist.

[Visual Basic]
Public Overloads Sub Download( _
ByVal remFileName As String, _
ByVal locFileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Download(
string remFileName,
string locFileName,
bool resume
);

Parameters

remFileName
locFileName
resume

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Download Overload List


FtpClient.Finalize Method

Destuctor

[Visual Basic]
Protected Overrides Sub Finalize()
[C#]
protected override void Finalize();

See Also

FtpClient Class | Conaito.PPLibrary Namespace


GetFileList Method

conaito PPT2Flash SDK 3.7

FtpClient.GetFileList Method

Return a string array containing the remote directory's file list.

Overload List

Return a string array containing the remote directory's file list.

public string[] GetFileList()

Return a string array containing the remote directory's file list.

public string[] GetFileList(string)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.GetFileList() Method

Return a string array containing the remote directory's file list.

[Visual Basic]
Public Overloads Sub GetFileList()
[C#]
public string[] GetFileList();

Return Value

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.GetFileList Overload List


FtpClient.GetFileList(String) Method

Return a string array containing the remote directory's file list.

[Visual Basic]
Public Overloads Sub GetFileList( _
ByVal mask As String _
)
[C#]
public string[] GetFileList(
string mask
);

Parameters

mask

Return Value

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.GetFileList Overload List


FtpClient.GetFileSize Method

Return the size of a file.

[Visual Basic]
Public Sub GetFileSize( _
ByVal fileName As String _
)
[C#]
public long GetFileSize(
string fileName
);

Parameters

fileName

Return Value

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.Login Method

Login to the remote server.

[Visual Basic]
Public Sub Login()
[C#]
public void Login();

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.MakeDir Method

Create a directory on the remote FTP server.

[Visual Basic]
Public Sub MakeDir( _
ByVal dirName As String _
)
[C#]
public void MakeDir(
string dirName
);

Parameters

dirName

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.RemoveDir Method

Delete a directory on the remote FTP server.

[Visual Basic]
Public Sub RemoveDir( _
ByVal dirName As String _
)
[C#]
public void RemoveDir(
string dirName
);

Parameters

dirName

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.RenameFile Method

Rename a file on the remote FTP server.

[Visual Basic]
Public Sub RenameFile( _
ByVal oldFileName As String, _
ByVal newFileName As String, _
ByVal overwrite As Boolean _
)
[C#]
public void RenameFile(
string oldFileName,
string newFileName,
bool overwrite
);

Parameters

oldFileName
newFileName
overwrite
setting to false will throw exception if it exists

See Also

FtpClient Class | Conaito.PPLibrary Namespace


Upload Method

conaito PPT2Flash SDK 3.7

FtpClient.Upload Method

Upload a file.

Overload List

Upload a file.

public void Upload(string)

Upload a file and set the resume flag.

public void Upload(string,bool)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.Upload(String) Method

Upload a file.

[Visual Basic]
Public Overloads Sub Upload( _
ByVal fileName As String _
)
[C#]
public void Upload(
string fileName
);

Parameters

fileName

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Upload Overload List


FtpClient.Upload(String, Boolean) Method

Upload a file and set the resume flag.

[Visual Basic]
Public Overloads Sub Upload( _
ByVal fileName As String, _
ByVal resume As Boolean _
)
[C#]
public void Upload(
string fileName,
bool resume
);

Parameters

fileName
resume

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.Upload Overload List


UploadDirectory Method

conaito PPT2Flash SDK 3.7

FtpClient.UploadDirectory Method

Upload a directory and its file contents

Overload List

Upload a directory and its file contents

public void UploadDirectory(string,bool)

Upload a directory and its file contents

public void UploadDirectory(string,bool,string)

See Also

FtpClient Class | Conaito.PPLibrary Namespace


FtpClient.UploadDirectory(String, Boolean) Method

Upload a directory and its file contents

[Visual Basic]
Public Overloads Sub UploadDirectory( _
ByVal path As String, _
ByVal recurse As Boolean _
)
[C#]
public void UploadDirectory(
string path,
bool recurse
);

Parameters

path
recurse
Whether to recurse sub directories

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.UploadDirectory Overload List


FtpClient.UploadDirectory(String, Boolean, String) Method

Upload a directory and its file contents

[Visual Basic]
Public Overloads Sub UploadDirectory( _
ByVal path As String, _
ByVal recurse As Boolean, _
ByVal mask As String _
)
[C#]
public void UploadDirectory(
string path,
bool recurse,
string mask
);

Parameters

path
recurse
Whether to recurse sub directories
mask
Only upload files of the given mask - everything is '*.*'

See Also

FtpClient Class | Conaito.PPLibrary Namespace | FtpClient.UploadDirectory Overload List


FtpClient.FtpException Class

For a list of all members of this type, see FtpClient.FtpException Members .

System.Object
Exception
FtpClient.FtpException

[Visual Basic]
Public Class FtpException
Inherits Exception
[C#]
public class FtpException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

FtpClient.FtpException Members | Conaito.PPLibrary Namespace


FtpClient.FtpException Members

FtpClient.FtpException overview

Public Instance Constructors

FtpClient.FtpException Overloaded. Initializes a new instance of the FtpClient.FtpException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FtpException Class | Conaito.PPLibrary Namespace


FtpClient.FtpException Constructor

Overload List

public FtpClient.FtpException(string)

public FtpClient.FtpException(string,Exception)

See Also

FtpException Class | Conaito.PPLibrary Namespace


FtpClient.FtpException Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String _
)
[C#]
FtpException(
string message
);

See Also

FtpException Class | Conaito.PPLibrary Namespace | FtpException Constructor Overload List


FtpClient.FtpException Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String, _
ByVal innerException As Exception _
)
[C#]
FtpException(
string message,
Exception innerException
);

See Also

FtpException Class | Conaito.PPLibrary Namespace | FtpException Constructor Overload List


IPPApplication Interface

Default interface of PPApplication class for COM interop

For a list of all members of this type, see IPPApplication Members .

[Visual Basic]
<Guid(Value:="8A9590DB-46B3-4aed-ACCE-C004A7CDEB43")> _
Public Interface IPPApplication
[C#]
[Guid(Value="8A9590DB-46B3-4aed-ACCE-C004A7CDEB43")]
public interface IPPApplication

Types that implement IPPApplication

Type | Description
PPApplication | Powerpoint to SWF Application

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

IPPApplication Members | Conaito.PPLibrary Namespace


IPPApplication Members

IPPApplication overview

Public Instance Properties

_ppPres
_ppPresSet
AdvanceTime
AutoSlideChange
ConvertAudio
ConvertVideo
CustomVideoConvArgs
ExportImageFormat
ExportImageMode
FrameRate
FullLicenseDate
GenerateHthmlWithAdvancedFlashAPI
HightQuality
IsLicenseValide
IsStartOnClick
LicenseMode
Loop
LoopAutoSlideChange
NavigationPanel
RenderEffects
SaveText
ScaleX
ScaleY
SlidesCount
SmoothImage
ThumbsHeight
ThumbsWidth
WaitBeforeAutoSlideChange
XmlData

Public Instance Methods

ConvertPPT2SWF | Overloaded.
ConvertPPT2SWFFile | Overloaded.
ConvertPPT2SWFSeparately |
ConvertPPT2SWFWithoutStandaloneMasterSwf |
ConvertSWF2Exe |
CopyPlayerDataToFolder |
CopyPlayerFromToFolder |
EndSession |
Load |
LoadFromFile |
PublishToFTP |
RenderThumbsToFolder | Overloaded.
RenderToFile |
RenderToFolder |
SetLicense |
StopRender |

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication Properties

The properties of the IPPApplication interface are listed below. For a complete list of IPPApplication interface members, see the IPPApplication Members topic.

Public Instance Properties

_ppPres
_ppPresSet
AdvanceTime
AutoSlideChange
ConvertAudio
ConvertVideo
CustomVideoConvArgs
ExportImageFormat
ExportImageMode
FrameRate
FullLicenseDate
GenerateHthmlWithAdvancedFlashAPI
HightQuality
IsLicenseValide
IsStartOnClick
LicenseMode
Loop
LoopAutoSlideChange
NavigationPanel
RenderEffects
SaveText
ScaleX
ScaleY
SlidesCount
SmoothImage
ThumbsHeight
ThumbsWidth
WaitBeforeAutoSlideChange
XmlData

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


_ppPres Property

conaito PPT2Flash SDK 3.7

IPPApplication._ppPres Property

[Visual Basic]
Public MustOverride Property _ppPres() As Presentation
Public Get
End Get
Public Set
End Set
End Property
[C#]
public Presentation _ppPres { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


_ppPresSet Property

conaito PPT2Flash SDK 3.7

IPPApplication._ppPresSet Property

[Visual Basic]
Public MustOverride Property _ppPresSet() As Presentations
Public Get
End Get
Public Set
End Set
End Property
[C#]
public Presentations _ppPresSet { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


AdvanceTime Property

conaito PPT2Flash SDK 3.7

IPPApplication.AdvanceTime Property

[Visual Basic]
Public MustOverride Property AdvanceTime() As Double
Public Get
End Get
Public Set
End Set
End Property
[C#]
public double AdvanceTime { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


AutoSlideChange Property

conaito PPT2Flash SDK 3.7

IPPApplication.AutoSlideChange Property

[Visual Basic]
Public MustOverride Property AutoSlideChange() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool AutoSlideChange { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ConvertAudio Property

conaito PPT2Flash SDK 3.7

IPPApplication.ConvertAudio Property

[Visual Basic]
Public MustOverride Property ConvertAudio() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ConvertAudio { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ConvertVideo Property

conaito PPT2Flash SDK 3.7

IPPApplication.ConvertVideo Property

[Visual Basic]
Public MustOverride Property ConvertVideo() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ConvertVideo { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


CustomVideoConvArgs Property

conaito PPT2Flash SDK 3.7

IPPApplication.CustomVideoConvArgs Property

[Visual Basic]
Public MustOverride Property CustomVideoConvArgs() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string CustomVideoConvArgs { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ExportImageFormat Property

conaito PPT2Flash SDK 3.7

IPPApplication.ExportImageFormat Property

[Visual Basic]
Public MustOverride Property ExportImageFormat() As ExportImageFormat
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ExportImageFormat ExportImageFormat { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ExportImageMode Property

conaito PPT2Flash SDK 3.7

IPPApplication.ExportImageMode Property

[Visual Basic]
Public MustOverride Property ExportImageMode() As ExportImageMode
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ExportImageMode ExportImageMode { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


FrameRate Property

conaito PPT2Flash SDK 3.7

IPPApplication.FrameRate Property

[Visual Basic]
Public MustOverride Property FrameRate() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int FrameRate { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


FullLicenseDate Property

conaito PPT2Flash SDK 3.7

IPPApplication.FullLicenseDate Property

[Visual Basic]
Public MustOverride ReadOnly Property FullLicenseDate() As String
Public Get
End Get
End Property
[C#]
public string FullLicenseDate { public get; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


GenerateHthmlWithAdvancedFlashAPI Property

conaito PPT2Flash SDK 3.7

IPPApplication.GenerateHthmlWithAdvancedFlashAPI Property

[Visual Basic]
Public MustOverride Property GenerateHthmlWithAdvancedFlashAPI() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool GenerateHthmlWithAdvancedFlashAPI { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


HightQuality Property

conaito PPT2Flash SDK 3.7

IPPApplication.HightQuality Property

[Visual Basic]
Public MustOverride Property HightQuality() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool HightQuality { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IsLicenseValide Property

conaito PPT2Flash SDK 3.7

IPPApplication.IsLicenseValide Property

[Visual Basic]
Public MustOverride ReadOnly Property IsLicenseValide() As Boolean
Public Get
End Get
End Property
[C#]
public bool IsLicenseValide { public get; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IsStartOnClick Property

conaito PPT2Flash SDK 3.7

IPPApplication.IsStartOnClick Property

[Visual Basic]
Public MustOverride Property IsStartOnClick() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool IsStartOnClick { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


LicenseMode Property

conaito PPT2Flash SDK 3.7

IPPApplication.LicenseMode Property

[Visual Basic]
Public MustOverride ReadOnly Property LicenseMode() As LicenseMode
Public Get
End Get
End Property
[C#]
public LicenseMode LicenseMode { public get; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


Loop Property

conaito PPT2Flash SDK 3.7

IPPApplication.Loop Property

[Visual Basic]
Public MustOverride Property Loop() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Loop { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


LoopAutoSlideChange Property

conaito PPT2Flash SDK 3.7

IPPApplication.LoopAutoSlideChange Property

[Visual Basic]
Public MustOverride Property LoopAutoSlideChange() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool LoopAutoSlideChange { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


NavigationPanel Property

conaito PPT2Flash SDK 3.7

IPPApplication.NavigationPanel Property

[Visual Basic]
Public MustOverride Property NavigationPanel() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool NavigationPanel { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


RenderEffects Property

conaito PPT2Flash SDK 3.7

IPPApplication.RenderEffects Property

[Visual Basic]
Public MustOverride Property RenderEffects() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool RenderEffects { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


SaveText Property

conaito PPT2Flash SDK 3.7

IPPApplication.SaveText Property

[Visual Basic]
Public MustOverride Property SaveText() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool SaveText { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ScaleX Property

conaito PPT2Flash SDK 3.7

IPPApplication.ScaleX Property

[Visual Basic]
Public MustOverride Property ScaleX() As Single
Public Get
End Get
Public Set
End Set
End Property
[C#]
public float ScaleX { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ScaleY Property

conaito PPT2Flash SDK 3.7

IPPApplication.ScaleY Property

[Visual Basic]
Public MustOverride Property ScaleY() As Single
Public Get
End Get
Public Set
End Set
End Property
[C#]
public float ScaleY { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


SlidesCount Property

conaito PPT2Flash SDK 3.7

IPPApplication.SlidesCount Property

[Visual Basic]
Public MustOverride ReadOnly Property SlidesCount() As Integer
Public Get
End Get
End Property
[C#]
public int SlidesCount { public get; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


SmoothImage Property

conaito PPT2Flash SDK 3.7

IPPApplication.SmoothImage Property

[Visual Basic]
Public MustOverride Property SmoothImage() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool SmoothImage { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ThumbsHeight Property

conaito PPT2Flash SDK 3.7

IPPApplication.ThumbsHeight Property

[Visual Basic]
Public MustOverride Property ThumbsHeight() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int ThumbsHeight { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ThumbsWidth Property

conaito PPT2Flash SDK 3.7

IPPApplication.ThumbsWidth Property

[Visual Basic]
Public MustOverride Property ThumbsWidth() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int ThumbsWidth { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


WaitBeforeAutoSlideChange Property

conaito PPT2Flash SDK 3.7

IPPApplication.WaitBeforeAutoSlideChange Property

[Visual Basic]
Public MustOverride Property WaitBeforeAutoSlideChange() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int WaitBeforeAutoSlideChange { public get; public set; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


XmlData Property

conaito PPT2Flash SDK 3.7

IPPApplication.XmlData Property

[Visual Basic]
Public MustOverride ReadOnly Property XmlData() As String
Public Get
End Get
End Property
[C#]
public string XmlData { public get; }

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication Methods

The methods of the IPPApplication interface are listed below. For a complete list of IPPApplication interface members, see the IPPApplication Members topic.

Public Instance Methods

ConvertPPT2SWF | Overloaded.
ConvertPPT2SWFFile | Overloaded.
ConvertPPT2SWFSeparately |
ConvertPPT2SWFWithoutStandaloneMasterSwf |
ConvertSWF2Exe |
CopyPlayerDataToFolder |
CopyPlayerFromToFolder |
EndSession |
Load |
LoadFromFile |
PublishToFTP |
RenderThumbsToFolder | Overloaded.
RenderToFile |
RenderToFolder |
SetLicense |
StopRender |

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


ConvertPPT2SWF Method

conaito PPT2Flash SDK 3.7

IPPApplication.ConvertPPT2SWF Method

Overload List

void ConvertPPT2SWF(string,string)

void ConvertPPT2SWF(string,string,int,int)

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.ConvertPPT2SWF(String, String) Method

[Visual Basic]
Public Sub ConvertPPT2SWF( _
ByVal filename As String, _
ByVal foldername As String _
)
[C#]
void ConvertPPT2SWF(
string filename,
string foldername
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWF Overload List


IPPApplication.ConvertPPT2SWF(String, String, Int32, Int32) Method

[Visual Basic]
Public Sub ConvertPPT2SWF( _
ByVal filename As String, _
ByVal foldername As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
)
[C#]
void ConvertPPT2SWF(
string filename,
string foldername,
int fromSlide,
int toSlide
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWF Overload List


ConvertPPT2SWFFile Method

conaito PPT2Flash SDK 3.7

IPPApplication.ConvertPPT2SWFFile Method

Overload List

void ConvertPPT2SWFFile(string,string)

void ConvertPPT2SWFFile(string,string,double)

void ConvertPPT2SWFFile(string,string,int,int)

void ConvertPPT2SWFFile(string,string,int[])

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.ConvertPPT2SWFFile(String, String) Method

[Visual Basic]
Public Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String _
)
[C#]
void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWFFile Overload List


IPPApplication.ConvertPPT2SWFFile(String, String, Double) Method

[Visual Basic]
Public Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal advanceTime As Double _
)
[C#]
void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
double advanceTime
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWFFile Overload List


IPPApplication.ConvertPPT2SWFFile(String, String, Int32, Int32) Method

[Visual Basic]
Public Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
)
[C#]
void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
int fromSlide,
int toSlide
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWFFile Overload List


IPPApplication.ConvertPPT2SWFFile(String, String, Int32) Method

[Visual Basic]
Public Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal slidesNumbers As Integer _
)
[C#]
void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
int[] slidesNumbers
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.ConvertPPT2SWFFile Overload List


IPPApplication.ConvertPPT2SWFSeparately Method

[Visual Basic]
Public Sub ConvertPPT2SWFSeparately( _
ByVal filename As String, _
ByVal foldername As String _
)
[C#]
void ConvertPPT2SWFSeparately(
string filename,
string foldername
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.ConvertPPT2SWFWithoutStandaloneMasterSwf Method

[Visual Basic]
Public Sub ConvertPPT2SWFWithoutStandaloneMasterSwf( _
ByVal filename As String, _
ByVal foldername As String _
)
[C#]
void ConvertPPT2SWFWithoutStandaloneMasterSwf(
string filename,
string foldername
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.ConvertSWF2Exe Method

[Visual Basic]
Public Sub ConvertSWF2Exe( _
ByVal swfFile As String, _
ByVal exeFile As String _
)
[C#]
void ConvertSWF2Exe(
string swfFile,
string exeFile
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.CopyPlayerDataToFolder Method

[Visual Basic]
Public Sub CopyPlayerDataToFolder( _
ByVal foldername As String _
)
[C#]
void CopyPlayerDataToFolder(
string foldername
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.CopyPlayerFromToFolder Method

[Visual Basic]
Public Sub CopyPlayerFromToFolder( _
ByVal fromfolder As String, _
ByVal tofolder As String _
)
[C#]
void CopyPlayerFromToFolder(
string fromfolder,
string tofolder
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.EndSession Method

[Visual Basic]
Public Sub EndSession()
[C#]
void EndSession();

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.Load Method

[Visual Basic]
Public Sub Load( _
ByVal powerPointFile As String _
)
[C#]
void Load(
string powerPointFile
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.LoadFromFile Method

[Visual Basic]
Public Sub LoadFromFile( _
ByVal filename As String _
)
[C#]
void LoadFromFile(
string filename
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.PublishToFTP Method

[Visual Basic]
Public Sub PublishToFTP( _
ByVal SwfFilepath As String, _
ByVal FtpUrlAdress As String, _
ByVal FtpServerAdress As String, _
ByVal FtpPort As Integer, _
ByVal FtpLogin As String, _
ByVal FtpPassword As String _
)
[C#]
void PublishToFTP(
string SwfFilepath,
string FtpUrlAdress,
string FtpServerAdress,
int FtpPort,
string FtpLogin,
string FtpPassword
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


RenderThumbsToFolder Method

conaito PPT2Flash SDK 3.7

IPPApplication.RenderThumbsToFolder Method

Overload List

void RenderThumbsToFolder(string,string,ThumbsFormats,int,int)

void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,bool)

void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,int,int)

void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,int,int,bool)

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32) Method

[Visual Basic]
Public Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer _
)
[C#]
void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.RenderThumbsToFolder Overload List


IPPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Boolean) Method

[Visual Basic]
Public Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal genThumbsXml As Boolean _
)
[C#]
void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
bool genThumbsXml
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.RenderThumbsToFolder Overload List


IPPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Int32, Int32) Method

[Visual Basic]
Public Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
)
[C#]
void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
int fromSlide,
int toSlide
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.RenderThumbsToFolder Overload List


IPPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Int32, Int32, Boolean) Method

[Visual Basic]
Public Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer, _
ByVal genThumbsXml As Boolean _
)
[C#]
void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
int fromSlide,
int toSlide,
bool genThumbsXml
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace | IPPApplication.RenderThumbsToFolder Overload List


IPPApplication.RenderToFile Method

[Visual Basic]
Public Sub RenderToFile( _
ByVal filename As String _
)
[C#]
void RenderToFile(
string filename
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.RenderToFolder Method

[Visual Basic]
Public Sub RenderToFolder( _
ByVal foldername As String _
)
[C#]
void RenderToFolder(
string foldername
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.SetLicense Method

[Visual Basic]
Public Sub SetLicense( _
ByVal user As String, _
ByVal key As String _
)
[C#]
void SetLicense(
string user,
string key
);

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


IPPApplication.StopRender Method

[Visual Basic]
Public Sub StopRender()
[C#]
void StopRender();

See Also

IPPApplication Interface | Conaito.PPLibrary Namespace


NavigationPanelAlignment Enumeration

[Visual Basic]
Public Enum NavigationPanelAlignment
[C#]
public enum NavigationPanelAlignment

Members

Member Name | Description
Left |
Center |
Right |

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PowerPointNotInstalledException Class

For a list of all members of this type, see PowerPointNotInstalledException Members .

System.Object
Exception
PowerPointNotInstalledException

[Visual Basic]
<Serializable> _
Public Class PowerPointNotInstalledException
Inherits Exception
[C#]
[Serializable]
public class PowerPointNotInstalledException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

PowerPointNotInstalledException Members | Conaito.PPLibrary Namespace


PowerPointNotInstalledException Members

PowerPointNotInstalledException overview

Public Instance Constructors

PowerPointNotInstalledException Constructor Initializes a new instance of the PowerPointNotInstalledException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PowerPointNotInstalledException Class | Conaito.PPLibrary Namespace


PowerPointNotInstalledException Constructor

Initializes a new instance of the PowerPointNotInstalledException class.

[Visual Basic]
Public Sub New()
[C#]
PowerPointNotInstalledException();

See Also

PowerPointNotInstalledException Class | Conaito.PPLibrary Namespace


PPApplication Class

Powerpoint to SWF Application

For a list of all members of this type, see PPApplication Members .

System.Object
PPApplication

[Visual Basic]
<Guid(Value:="33F2E7A9-36AC-4467-A40D-29DBA6146781")> _
<ClassInterface(Value:=ClassInterfaceType.None)> _
Public Class PPApplication
Implements IPPApplication
[C#]
[Guid(Value="33F2E7A9-36AC-4467-A40D-29DBA6146781")]
[ClassInterface(Value=ClassInterfaceType.None)]
public class PPApplication : IPPApplication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

PPApplication Members | Conaito.PPLibrary Namespace


PPApplication Members

PPApplication overview

Public Static (Shared) Fields

SWFVersion

Public Instance Constructors

PPApplication Constructor Initializes a new instance of the PPApplication class.

Public Instance Fields

_extractedFilesDirectory

Public Instance Properties

_ppPres | By Majid Get or set Presentation
_ppPresSet |
AdvanceTime | Advance time
AS3 | Experimental!!! Generate SWF as AS3(VM2)
AS3stop | Experimental!!! Use AS3 Stop with VM2
AutoSlideChange | Gets or sets a value indicating whether need auto slide change if no auto advance time in powerpoint.
BackgroundTransparent | Gets or sets a value indicating whether convert Background Transparent included in ppt file.
ConvertAudio | Gets or sets a value indicating whether convert audio included in ppt file.
ConvertSlideTransitions | Convert slide transitions
ConvertVideo | Gets or sets a value indicating whether convert video included in ppt file.
CustomVideoConvArgs | Custom arguments for Video.exe. Example: -acodec mp3 -i [inputFile] -ar 44100 -ab 128 -f flv -s [width]x[height] [outputFile] [inputFile], [width], [height], [outputFile] - system values, not to edit (SDK puts the real values)
EnableDebugger | Enable Debugger to SWF file
ExportImageFormat | Gets or sets the export image format from ppt file.
ExportImageMode | Gets or sets the export image mode from ppt file.
FLVOutput |
FLVURL |
FrameRate | Gets or sets the frame rate.
FullLicenseDate | Date of license finish
GenerateHthmlWithAdvancedFlashAPI | Gets or sets a value indicating whether to generate html with advanced flash api ( gotoSlide, gotoAnimation, etc. )
HightQuality | Gets or sets a value indicating export Image quality.
IsLicenseValide | Gets a value indicating whether this license is valid.
IsStartOnClick | Gets or sets a value indicating if need stop before Clicked effects.
LicenseMode | License Mode
Loop | Enables or disables loop play for single swf output
LoopAutoSlideChange | Gets or sets a value indicating whether loop show if auto slide change is true.
NavigationPanel | Gets or sets navigation panel visibility
NavigationPanelAlignment | Navigation panel alignment
NavigationPanelOffset | Navigation panel offset
RenderEffects | Gets or sets a value indicating whether if need render effects.
ReviewCheck | Gets or sets a value indicating whether save all text from ppt file into xml file.
SaveText | Gets or sets a value indicating whether save all text from ppt file into xml file.
ScaleX | Scale X
ScaleY | Scale Y
SlideHeight | Height of slide
SlideonProssess | Current Slide on Prossess
SlidesCount | Gets the slides count.
SlideWidth | Width of slide
SmoothImage | Gets or sets a value indicating whether smooth image exported from powerpoint.
TempDirectory |
ThumbsFormat | Gets or sets the thumbs picture format.
ThumbsHeight | Gets or sets the height of the thumbs.
ThumbsWidth | Gets or sets the width of the thumbs.
WaitBeforeAutoSlideChange | Gets or sets the time to wait before auto slide change (if there is some animation then max(DurationOfAnimation, WaitBeforeAutoSlideChange) is used).
XmlData | Gets the XML data string.

Public Instance Methods

ConvertPPT2SWF | Overloaded. Convert PPT to SWF. Each power point slide is converted to separate swf file.
ConvertPPT2SWFFile | Overloaded. Convert PPT to SWF File
ConvertPPT2SWFSeparately | Overloaded.
ConvertPPT2SWFWithoutStandaloneMasterSwf | Convert PPT to SWF Format. No standalone swf file is generated.
ConvertPPTX2PPT |
ConvertSWF2Exe | Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory
CopyPlayerDataToFolder | Copies the player data to folder. From Executing folder.
CopyPlayerFromToFolder | Copies the player data to folder. From other folder.
EndSession | Close Powerpoint Session
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsLicenseValid | Is license valid (LicenseMode == FULL or TRIAL)
Load | Loads power point file into memory. It allows to get power point info before actul converting.
LoadFromFile | Load data from Powerpoint file.
PublishToFTP | Piblish SWF File to FTP
RenderThumbsToFolder | Overloaded. Renders the thumbnails to folder.
RenderToFile | Render slides to SWF file
RenderToFolder | Render all Scenes to Folder.
RenderToFolderSeparately | Render some slides to folder
SetLicense | Set license name and key
StopRender | Stop render process
ToString (inherited from Object) |

Public Instance Events

Exception |
ShapeProcessed | ShapeProcessed is fired when SDK is reading the shape information from the slides within the PowerPoint.
ShapeRender | ShapeRender is fired when SDK is compleate render the shape information from the slides within the PowerPoint.
SlideProcessed | SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint.
SlideRender | SlideRender is fired when SDK is compleate render the information from the slides within the PowerPoint.
ThumbsRender | ThumbsRender is fired when SDK is compleate render the thumb

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnError

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication Constructor

Initializes a new instance of the PPApplication class.

[Visual Basic]
Public Sub New()
[C#]
PPApplication();

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication Fields

The fields of the PPApplication class are listed below. For a complete list of PPApplication class members, see the PPApplication Members topic.

Public Static (Shared) Fields

SWFVersion

Public Instance Fields

_extractedFilesDirectory

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication._extractedFilesDirectory Field

[Visual Basic]
Public _extractedFilesDirectory As String
[C#]
public string _extractedFilesDirectory;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.SWFVersion Field

[Visual Basic]
Public Shared SWFVersion As Integer
[C#]
public static int SWFVersion;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication Properties

The properties of the PPApplication class are listed below. For a complete list of PPApplication class members, see the PPApplication Members topic.

Public Instance Properties

_ppPres | By Majid Get or set Presentation
_ppPresSet |
AdvanceTime | Advance time
AS3 | Experimental!!! Generate SWF as AS3(VM2)
AS3stop | Experimental!!! Use AS3 Stop with VM2
AutoSlideChange | Gets or sets a value indicating whether need auto slide change if no auto advance time in powerpoint.
BackgroundTransparent | Gets or sets a value indicating whether convert Background Transparent included in ppt file.
ConvertAudio | Gets or sets a value indicating whether convert audio included in ppt file.
ConvertSlideTransitions | Convert slide transitions
ConvertVideo | Gets or sets a value indicating whether convert video included in ppt file.
CustomVideoConvArgs | Custom arguments for Video.exe. Example: -acodec mp3 -i [inputFile] -ar 44100 -ab 128 -f flv -s [width]x[height] [outputFile] [inputFile], [width], [height], [outputFile] - system values, not to edit (SDK puts the real values)
EnableDebugger | Enable Debugger to SWF file
ExportImageFormat | Gets or sets the export image format from ppt file.
ExportImageMode | Gets or sets the export image mode from ppt file.
FLVOutput |
FLVURL |
FrameRate | Gets or sets the frame rate.
FullLicenseDate | Date of license finish
GenerateHthmlWithAdvancedFlashAPI | Gets or sets a value indicating whether to generate html with advanced flash api ( gotoSlide, gotoAnimation, etc. )
HightQuality | Gets or sets a value indicating export Image quality.
IsLicenseValide | Gets a value indicating whether this license is valid.
IsStartOnClick | Gets or sets a value indicating if need stop before Clicked effects.
LicenseMode | License Mode
Loop | Enables or disables loop play for single swf output
LoopAutoSlideChange | Gets or sets a value indicating whether loop show if auto slide change is true.
NavigationPanel | Gets or sets navigation panel visibility
NavigationPanelAlignment | Navigation panel alignment
NavigationPanelOffset | Navigation panel offset
RenderEffects | Gets or sets a value indicating whether if need render effects.
ReviewCheck | Gets or sets a value indicating whether save all text from ppt file into xml file.
SaveText | Gets or sets a value indicating whether save all text from ppt file into xml file.
ScaleX | Scale X
ScaleY | Scale Y
SlideHeight | Height of slide
SlideonProssess | Current Slide on Prossess
SlidesCount | Gets the slides count.
SlideWidth | Width of slide
SmoothImage | Gets or sets a value indicating whether smooth image exported from powerpoint.
TempDirectory |
ThumbsFormat | Gets or sets the thumbs picture format.
ThumbsHeight | Gets or sets the height of the thumbs.
ThumbsWidth | Gets or sets the width of the thumbs.
WaitBeforeAutoSlideChange | Gets or sets the time to wait before auto slide change (if there is some animation then max(DurationOfAnimation, WaitBeforeAutoSlideChange) is used).
XmlData | Gets the XML data string.

See Also

PPApplication Class | Conaito.PPLibrary Namespace


_ppPres Property

conaito PPT2Flash SDK 3.7

PPApplication._ppPres Property

By Majid Get or set Presentation

[Visual Basic]
Public NotOverridable Property _ppPres() As Presentation _
Implements IPPApplication._ppPres

Public Get
End Get
Public Set
End Set
End Property
[C#]
public Presentation _ppPres { public get; public set; }

Implements

IPPApplication._ppPres

See Also

PPApplication Class | Conaito.PPLibrary Namespace


_ppPresSet Property

conaito PPT2Flash SDK 3.7

PPApplication._ppPresSet Property

[Visual Basic]
Public NotOverridable Property _ppPresSet() As Presentations _
Implements IPPApplication._ppPresSet

Public Get
End Get
Public Set
End Set
End Property
[C#]
public Presentations _ppPresSet { public get; public set; }

Implements

IPPApplication._ppPresSet

See Also

PPApplication Class | Conaito.PPLibrary Namespace


AdvanceTime Property

conaito PPT2Flash SDK 3.7

PPApplication.AdvanceTime Property

Advance time

[Visual Basic]
Public NotOverridable Property AdvanceTime() As Double _
Implements IPPApplication.AdvanceTime

Public Get
End Get
Public Set
End Set
End Property
[C#]
public double AdvanceTime { public get; public set; }

Implements

IPPApplication.AdvanceTime

See Also

PPApplication Class | Conaito.PPLibrary Namespace


AS3 Property

conaito PPT2Flash SDK 3.7

PPApplication.AS3 Property

Experimental!!! Generate SWF as AS3(VM2)

[Visual Basic]
Public Property AS3() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool AS3 { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


AS3stop Property

conaito PPT2Flash SDK 3.7

PPApplication.AS3stop Property

Experimental!!! Use AS3 Stop with VM2

[Visual Basic]
Public Property AS3stop() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool AS3stop { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


AutoSlideChange Property

conaito PPT2Flash SDK 3.7

PPApplication.AutoSlideChange Property

Gets or sets a value indicating whether need auto slide change if no auto advance time in powerpoint.

[Visual Basic]
Public NotOverridable Property AutoSlideChange() As Boolean _
Implements IPPApplication.AutoSlideChange

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool AutoSlideChange { public get; public set; }

Property Value

true if do auto slide change; otherwise, false.

Implements

IPPApplication.AutoSlideChange

See Also

PPApplication Class | Conaito.PPLibrary Namespace


BackgroundTransparent Property

conaito PPT2Flash SDK 3.7

PPApplication.BackgroundTransparent Property

Gets or sets a value indicating whether convert Background Transparent included in ppt file.

[Visual Basic]
Public Property BackgroundTransparent() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool BackgroundTransparent { public get; public set; }

Property Value

true if need convert audio; otherwise, false.

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ConvertAudio Property

conaito PPT2Flash SDK 3.7

PPApplication.ConvertAudio Property

Gets or sets a value indicating whether convert audio included in ppt file.

[Visual Basic]
Public NotOverridable Property ConvertAudio() As Boolean _
Implements IPPApplication.ConvertAudio

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ConvertAudio { public get; public set; }

Property Value

true if need convert audio; otherwise, false.

Implements

IPPApplication.ConvertAudio

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ConvertSlideTransitions Property

conaito PPT2Flash SDK 3.7

PPApplication.ConvertSlideTransitions Property

Convert slide transitions

[Visual Basic]
Public Property ConvertSlideTransitions() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ConvertSlideTransitions { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ConvertVideo Property

conaito PPT2Flash SDK 3.7

PPApplication.ConvertVideo Property

Gets or sets a value indicating whether convert video included in ppt file.

[Visual Basic]
Public NotOverridable Property ConvertVideo() As Boolean _
Implements IPPApplication.ConvertVideo

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ConvertVideo { public get; public set; }

Property Value

true if need convert video; otherwise, false.

Implements

IPPApplication.ConvertVideo

See Also

PPApplication Class | Conaito.PPLibrary Namespace


CustomVideoConvArgs Property

conaito PPT2Flash SDK 3.7

PPApplication.CustomVideoConvArgs Property

Custom arguments for Video.exe. Example: -acodec mp3 -i [inputFile] -ar 44100 -ab 128 -f flv -s [width]x[height] [outputFile] [inputFile], [width], [height], [outputFile] - system values, not to edit (SDK puts the real values)

[Visual Basic]
Public NotOverridable Property CustomVideoConvArgs() As String _
Implements IPPApplication.CustomVideoConvArgs

Public Get
End Get
Public Set
End Set
End Property
[C#]
public string CustomVideoConvArgs { public get; public set; }

Implements

IPPApplication.CustomVideoConvArgs

See Also

PPApplication Class | Conaito.PPLibrary Namespace


EnableDebugger Property

conaito PPT2Flash SDK 3.7

PPApplication.EnableDebugger Property

Enable Debugger to SWF file

[Visual Basic]
Public Property EnableDebugger() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool EnableDebugger { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ExportImageFormat Property

conaito PPT2Flash SDK 3.7

PPApplication.ExportImageFormat Property

Gets or sets the export image format from ppt file.

[Visual Basic]
Public NotOverridable Property ExportImageFormat() As ExportImageFormat _
Implements IPPApplication.ExportImageFormat

Public Get
End Get
Public Set
End Set
End Property
[C#]
public ExportImageFormat ExportImageFormat { public get; public set; }

Property Value

The export image format.

Implements

IPPApplication.ExportImageFormat

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ExportImageMode Property

conaito PPT2Flash SDK 3.7

PPApplication.ExportImageMode Property

Gets or sets the export image mode from ppt file.

[Visual Basic]
Public NotOverridable Property ExportImageMode() As ExportImageMode _
Implements IPPApplication.ExportImageMode

Public Get
End Get
Public Set
End Set
End Property
[C#]
public ExportImageMode ExportImageMode { public get; public set; }

Property Value

The export image mode.

Implements

IPPApplication.ExportImageMode

See Also

PPApplication Class | Conaito.PPLibrary Namespace


FLVOutput Property

conaito PPT2Flash SDK 3.7

PPApplication.FLVOutput Property

[Visual Basic]
Public Property FLVOutput() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string FLVOutput { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


FLVURL Property

conaito PPT2Flash SDK 3.7

PPApplication.FLVURL Property

[Visual Basic]
Public Property FLVURL() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string FLVURL { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


FrameRate Property

conaito PPT2Flash SDK 3.7

PPApplication.FrameRate Property

Gets or sets the frame rate.

[Visual Basic]
Public NotOverridable Property FrameRate() As Integer _
Implements IPPApplication.FrameRate

Public Get
End Get
Public Set
End Set
End Property
[C#]
public int FrameRate { public get; public set; }

Property Value

The frame rate.

Implements

IPPApplication.FrameRate

See Also

PPApplication Class | Conaito.PPLibrary Namespace


FullLicenseDate Property

conaito PPT2Flash SDK 3.7

PPApplication.FullLicenseDate Property

Date of license finish

[Visual Basic]
Public NotOverridable Property FullLicenseDate() As String _
Implements IPPApplication.FullLicenseDate

Public Get
End Get
Public Set
End Set
End Property
[C#]
public string FullLicenseDate { public get; public set; }

Implements

IPPApplication.FullLicenseDate

See Also

PPApplication Class | Conaito.PPLibrary Namespace


GenerateHthmlWithAdvancedFlashAPI Property

conaito PPT2Flash SDK 3.7

PPApplication.GenerateHthmlWithAdvancedFlashAPI Property

Gets or sets a value indicating whether to generate html with advanced flash api ( gotoSlide, gotoAnimation, etc. )

[Visual Basic]
Public NotOverridable Property GenerateHthmlWithAdvancedFlashAPI() As Boolean _
Implements IPPApplication.GenerateHthmlWithAdvancedFlashAPI

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool GenerateHthmlWithAdvancedFlashAPI { public get; public set; }

Implements

IPPApplication.GenerateHthmlWithAdvancedFlashAPI

See Also

PPApplication Class | Conaito.PPLibrary Namespace


HightQuality Property

conaito PPT2Flash SDK 3.7

PPApplication.HightQuality Property

Gets or sets a value indicating export Image quality.

[Visual Basic]
Public NotOverridable Property HightQuality() As Boolean _
Implements IPPApplication.HightQuality

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool HightQuality { public get; public set; }

Property Value

true if need Save all image to PNG; otherwise, false.

Implements

IPPApplication.HightQuality

See Also

PPApplication Class | Conaito.PPLibrary Namespace


IsLicenseValide Property

conaito PPT2Flash SDK 3.7

PPApplication.IsLicenseValide Property

Gets a value indicating whether this license is valid.

[Visual Basic]
Public NotOverridable ReadOnly Property IsLicenseValide() As Boolean _
Implements IPPApplication.IsLicenseValide

Public Get
End Get
End Property
[C#]
public bool IsLicenseValide { public get; }

Property Value

true if this license valide; otherwise, false.

Implements

IPPApplication.IsLicenseValide

See Also

PPApplication Class | Conaito.PPLibrary Namespace


IsStartOnClick Property

conaito PPT2Flash SDK 3.7

PPApplication.IsStartOnClick Property

Gets or sets a value indicating if need stop before Clicked effects.

[Visual Basic]
Public NotOverridable Property IsStartOnClick() As Boolean _
Implements IPPApplication.IsStartOnClick

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool IsStartOnClick { public get; public set; }

Property Value

true stop before Click Effect.

Implements

IPPApplication.IsStartOnClick

See Also

PPApplication Class | Conaito.PPLibrary Namespace


LicenseMode Property

conaito PPT2Flash SDK 3.7

PPApplication.LicenseMode Property

License Mode

[Visual Basic]
Public NotOverridable ReadOnly Property LicenseMode() As LicenseMode _
Implements IPPApplication.LicenseMode

Public Get
End Get
End Property
[C#]
public LicenseMode LicenseMode { public get; }

Implements

IPPApplication.LicenseMode

See Also

PPApplication Class | Conaito.PPLibrary Namespace


Loop Property

conaito PPT2Flash SDK 3.7

PPApplication.Loop Property

Enables or disables loop play for single swf output

[Visual Basic]
Public NotOverridable Property Loop() As Boolean _
Implements IPPApplication.Loop

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool Loop { public get; public set; }

Implements

IPPApplication.Loop

See Also

PPApplication Class | Conaito.PPLibrary Namespace


LoopAutoSlideChange Property

conaito PPT2Flash SDK 3.7

PPApplication.LoopAutoSlideChange Property

Gets or sets a value indicating whether loop show if auto slide change is true.

[Visual Basic]
Public NotOverridable Property LoopAutoSlideChange() As Boolean _
Implements IPPApplication.LoopAutoSlideChange

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool LoopAutoSlideChange { public get; public set; }

Property Value

true if loop auto slide change show; otherwise, false.

Implements

IPPApplication.LoopAutoSlideChange

See Also

PPApplication Class | Conaito.PPLibrary Namespace


NavigationPanel Property

conaito PPT2Flash SDK 3.7

PPApplication.NavigationPanel Property

Gets or sets navigation panel visibility

[Visual Basic]
Public NotOverridable Property NavigationPanel() As Boolean _
Implements IPPApplication.NavigationPanel

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool NavigationPanel { public get; public set; }

Implements

IPPApplication.NavigationPanel

Remarks

For single output only

See Also

PPApplication Class | Conaito.PPLibrary Namespace


NavigationPanelAlignment Property

conaito PPT2Flash SDK 3.7

PPApplication.NavigationPanelAlignment Property

Navigation panel alignment

[Visual Basic]
Public Property NavigationPanelAlignment() As NavigationPanelAlignment
Public Get
End Get
Public Set
End Set
End Property
[C#]
public NavigationPanelAlignment NavigationPanelAlignment { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


NavigationPanelOffset Property

conaito PPT2Flash SDK 3.7

PPApplication.NavigationPanelOffset Property

Navigation panel offset

[Visual Basic]
Public Property NavigationPanelOffset() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int NavigationPanelOffset { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


RenderEffects Property

conaito PPT2Flash SDK 3.7

PPApplication.RenderEffects Property

Gets or sets a value indicating whether if need render effects.

[Visual Basic]
Public NotOverridable Property RenderEffects() As Boolean _
Implements IPPApplication.RenderEffects

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool RenderEffects { public get; public set; }

Property Value

true if need render effects; otherwise, false.

Implements

IPPApplication.RenderEffects

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ReviewCheck Property

conaito PPT2Flash SDK 3.7

PPApplication.ReviewCheck Property

Gets or sets a value indicating whether save all text from ppt file into xml file.

[Visual Basic]
Public Property ReviewCheck() As Boolean
Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool ReviewCheck { public get; public set; }

Property Value

true if need saving text; otherwise, false.

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SaveText Property

conaito PPT2Flash SDK 3.7

PPApplication.SaveText Property

Gets or sets a value indicating whether save all text from ppt file into xml file.

[Visual Basic]
Public NotOverridable Property SaveText() As Boolean _
Implements IPPApplication.SaveText

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool SaveText { public get; public set; }

Property Value

true if need saving text; otherwise, false.

Implements

IPPApplication.SaveText

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ScaleX Property

conaito PPT2Flash SDK 3.7

PPApplication.ScaleX Property

Scale X

[Visual Basic]
Public NotOverridable Property ScaleX() As Single _
Implements IPPApplication.ScaleX

Public Get
End Get
Public Set
End Set
End Property
[C#]
public float ScaleX { public get; public set; }

Implements

IPPApplication.ScaleX

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ScaleY Property

conaito PPT2Flash SDK 3.7

PPApplication.ScaleY Property

Scale Y

[Visual Basic]
Public NotOverridable Property ScaleY() As Single _
Implements IPPApplication.ScaleY

Public Get
End Get
Public Set
End Set
End Property
[C#]
public float ScaleY { public get; public set; }

Implements

IPPApplication.ScaleY

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SlideHeight Property

conaito PPT2Flash SDK 3.7

PPApplication.SlideHeight Property

Height of slide

[Visual Basic]
Public Property SlideHeight() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int SlideHeight { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SlideonProssess Property

conaito PPT2Flash SDK 3.7

PPApplication.SlideonProssess Property

Current Slide on Prossess

[Visual Basic]
Public Property SlideonProssess() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int SlideonProssess { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SlidesCount Property

conaito PPT2Flash SDK 3.7

PPApplication.SlidesCount Property

Gets the slides count.

[Visual Basic]
Public NotOverridable ReadOnly Property SlidesCount() As Integer _
Implements IPPApplication.SlidesCount

Public Get
End Get
End Property
[C#]
public int SlidesCount { public get; }

Property Value

The slides count.

Implements

IPPApplication.SlidesCount

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SlideWidth Property

conaito PPT2Flash SDK 3.7

PPApplication.SlideWidth Property

Width of slide

[Visual Basic]
Public Property SlideWidth() As Integer
Public Get
End Get
Public Set
End Set
End Property
[C#]
public int SlideWidth { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


SmoothImage Property

conaito PPT2Flash SDK 3.7

PPApplication.SmoothImage Property

Gets or sets a value indicating whether smooth image exported from powerpoint.

[Visual Basic]
Public NotOverridable Property SmoothImage() As Boolean _
Implements IPPApplication.SmoothImage

Public Get
End Get
Public Set
End Set
End Property
[C#]
public bool SmoothImage { public get; public set; }

Property Value

true if smooth image; otherwise, false.

Implements

IPPApplication.SmoothImage

See Also

PPApplication Class | Conaito.PPLibrary Namespace


TempDirectory Property

conaito PPT2Flash SDK 3.7

PPApplication.TempDirectory Property

[Visual Basic]
Public Property TempDirectory() As String
Public Get
End Get
Public Set
End Set
End Property
[C#]
public string TempDirectory { public get; public set; }

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ThumbsFormat Property

conaito PPT2Flash SDK 3.7

PPApplication.ThumbsFormat Property

Gets or sets the thumbs picture format.

[Visual Basic]
Public Property ThumbsFormat() As ThumbsFormats
Public Get
End Get
Public Set
End Set
End Property
[C#]
public ThumbsFormats ThumbsFormat { public get; public set; }

Property Value

The thumbs format.

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ThumbsHeight Property

conaito PPT2Flash SDK 3.7

PPApplication.ThumbsHeight Property

Gets or sets the height of the thumbs.

[Visual Basic]
Public NotOverridable Property ThumbsHeight() As Integer _
Implements IPPApplication.ThumbsHeight

Public Get
End Get
Public Set
End Set
End Property
[C#]
public int ThumbsHeight { public get; public set; }

Property Value

The height of the thumbs.

Implements

IPPApplication.ThumbsHeight

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ThumbsWidth Property

conaito PPT2Flash SDK 3.7

PPApplication.ThumbsWidth Property

Gets or sets the width of the thumbs.

[Visual Basic]
Public NotOverridable Property ThumbsWidth() As Integer _
Implements IPPApplication.ThumbsWidth

Public Get
End Get
Public Set
End Set
End Property
[C#]
public int ThumbsWidth { public get; public set; }

Property Value

The width of the thumbs.

Implements

IPPApplication.ThumbsWidth

See Also

PPApplication Class | Conaito.PPLibrary Namespace


WaitBeforeAutoSlideChange Property

conaito PPT2Flash SDK 3.7

PPApplication.WaitBeforeAutoSlideChange Property

Gets or sets the time to wait before auto slide change (if there is some animation then max(DurationOfAnimation, WaitBeforeAutoSlideChange) is used).

[Visual Basic]
Public NotOverridable Property WaitBeforeAutoSlideChange() As Integer _
Implements IPPApplication.WaitBeforeAutoSlideChange

Public Get
End Get
Public Set
End Set
End Property
[C#]
public int WaitBeforeAutoSlideChange { public get; public set; }

Property Value

The time in sec to wait before auto slide change.

Implements

IPPApplication.WaitBeforeAutoSlideChange

See Also

PPApplication Class | Conaito.PPLibrary Namespace


XmlData Property

conaito PPT2Flash SDK 3.7

PPApplication.XmlData Property

Gets the XML data string.

[Visual Basic]
Public NotOverridable ReadOnly Property XmlData() As String _
Implements IPPApplication.XmlData

Public Get
End Get
End Property
[C#]
public string XmlData { public get; }

Property Value

The XML data.

Implements

IPPApplication.XmlData

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication Methods

The methods of the PPApplication class are listed below. For a complete list of PPApplication class members, see the PPApplication Members topic.

Public Instance Methods

ConvertPPT2SWF | Overloaded. Convert PPT to SWF. Each power point slide is converted to separate swf file.
ConvertPPT2SWFFile | Overloaded. Convert PPT to SWF File
ConvertPPT2SWFSeparately | Overloaded.
ConvertPPT2SWFWithoutStandaloneMasterSwf | Convert PPT to SWF Format. No standalone swf file is generated.
ConvertPPTX2PPT |
ConvertSWF2Exe | Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory
CopyPlayerDataToFolder | Copies the player data to folder. From Executing folder.
CopyPlayerFromToFolder | Copies the player data to folder. From other folder.
EndSession | Close Powerpoint Session
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsLicenseValid | Is license valid (LicenseMode == FULL or TRIAL)
Load | Loads power point file into memory. It allows to get power point info before actul converting.
LoadFromFile | Load data from Powerpoint file.
PublishToFTP | Piblish SWF File to FTP
RenderThumbsToFolder | Overloaded. Renders the thumbnails to folder.
RenderToFile | Render slides to SWF file
RenderToFolder | Render all Scenes to Folder.
RenderToFolderSeparately | Render some slides to folder
SetLicense | Set license name and key
StopRender | Stop render process
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
OnError

See Also

PPApplication Class | Conaito.PPLibrary Namespace


ConvertPPT2SWF Method

conaito PPT2Flash SDK 3.7

PPApplication.ConvertPPT2SWF Method

Convert PPT to SWF. Each power point slide is converted to separate swf file.

Overload List

Convert PPT to SWF. Each power point slide is converted to separate swf file.

public void ConvertPPT2SWF(string,string)

Convert PPT to SWF. Each power point slide is converted to separate swf file.

public void ConvertPPT2SWF(string,string,int,int)

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ConvertPPT2SWF(String, String) Method

Convert PPT to SWF. Each power point slide is converted to separate swf file.

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWF( _
ByVal filename As String, _
ByVal foldername As String _
) _
Implements IPPApplication.ConvertPPT2SWF
[C#]
public void ConvertPPT2SWF(
string filename,
string foldername
);

Parameters

filename
Target PPT File
foldername
Output Directory

Implements

IPPApplication.ConvertPPT2SWF

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWF Overload List


PPApplication.ConvertPPT2SWF(String, String, Int32, Int32) Method

Convert PPT to SWF. Each power point slide is converted to separate swf file.

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWF( _
ByVal filename As String, _
ByVal foldername As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
) _
Implements IPPApplication.ConvertPPT2SWF
[C#]
public void ConvertPPT2SWF(
string filename,
string foldername,
int fromSlide,
int toSlide
);

Parameters

filename
Target PPT File
foldername
Output Directory
fromSlide
First slide to be converted
toSlide
Last slide to be converted

Implements

IPPApplication.ConvertPPT2SWF

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWF Overload List


ConvertPPT2SWFFile Method

conaito PPT2Flash SDK 3.7

PPApplication.ConvertPPT2SWFFile Method

Convert PPT to SWF File

Overload List

Convert PPT to SWF File

public void ConvertPPT2SWFFile(string,string)

Convert PPT to SWF File

public void ConvertPPT2SWFFile(string,string,double)

Convert PPT to SWF File

public void ConvertPPT2SWFFile(string,string,int,int)

public void ConvertPPT2SWFFile(string,string,int[])

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ConvertPPT2SWFFile(String, String) Method

Convert PPT to SWF File

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String _
) _
Implements IPPApplication.ConvertPPT2SWFFile
[C#]
public void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename
);

Parameters

PPTfilename
Target PPT file
SWFfilename
Output SWF file

Implements

IPPApplication.ConvertPPT2SWFFile

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFFile Overload List


PPApplication.ConvertPPT2SWFFile(String, String, Double) Method

Convert PPT to SWF File

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal advanceTime As Double _
) _
Implements IPPApplication.ConvertPPT2SWFFile
[C#]
public void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
double advanceTime
);

Parameters

PPTfilename
Target PPT file
SWFfilename
Output SWF file
advanceTime
Advance time in seconds

Implements

IPPApplication.ConvertPPT2SWFFile

Exceptions

Exception Type | Condition
ArgumentException |

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFFile Overload List


PPApplication.ConvertPPT2SWFFile(String, String, Int32, Int32) Method

Convert PPT to SWF File

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
) _
Implements IPPApplication.ConvertPPT2SWFFile
[C#]
public void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
int fromSlide,
int toSlide
);

Parameters

PPTfilename
Target PPT file
SWFfilename
Output SWF file
fromSlide
First slide to be converted
toSlide
Last slide to be converted

Implements

IPPApplication.ConvertPPT2SWFFile

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFFile Overload List


PPApplication.ConvertPPT2SWFFile(String, String, Int32) Method

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWFFile( _
ByVal PPTfilename As String, _
ByVal SWFfilename As String, _
ByVal slidesNumbers As Integer _
) _
Implements IPPApplication.ConvertPPT2SWFFile
[C#]
public void ConvertPPT2SWFFile(
string PPTfilename,
string SWFfilename,
int[] slidesNumbers
);

Parameters

PPTfilename
SWFfilename
slidesNumbers

Implements

IPPApplication.ConvertPPT2SWFFile

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFFile Overload List


ConvertPPT2SWFSeparately Method

conaito PPT2Flash SDK 3.7

PPApplication.ConvertPPT2SWFSeparately Method

Overload List

public void ConvertPPT2SWFSeparately(string,string)

public void ConvertPPT2SWFSeparately(string,string,int,int)

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ConvertPPT2SWFSeparately(String, String) Method

[Visual Basic]
Public NotOverridable Overloads Sub ConvertPPT2SWFSeparately( _
ByVal filename As String, _
ByVal foldername As String _
) _
Implements IPPApplication.ConvertPPT2SWFSeparately
[C#]
public void ConvertPPT2SWFSeparately(
string filename,
string foldername
);

Implements

IPPApplication.ConvertPPT2SWFSeparately

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFSeparately Overload List


PPApplication.ConvertPPT2SWFSeparately(String, String, Int32, Int32) Method

[Visual Basic]
Public Overloads Sub ConvertPPT2SWFSeparately( _
ByVal filename As String, _
ByVal foldername As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
)
[C#]
public void ConvertPPT2SWFSeparately(
string filename,
string foldername,
int fromSlide,
int toSlide
);

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.ConvertPPT2SWFSeparately Overload List


PPApplication.ConvertPPT2SWFWithoutStandaloneMasterSwf Method

Convert PPT to SWF Format. No standalone swf file is generated.

[Visual Basic]
Public NotOverridable Sub ConvertPPT2SWFWithoutStandaloneMasterSwf( _
ByVal filename As String, _
ByVal foldername As String _
) _
Implements IPPApplication.ConvertPPT2SWFWithoutStandaloneMasterSwf
[C#]
public void ConvertPPT2SWFWithoutStandaloneMasterSwf(
string filename,
string foldername
);

Parameters

filename
Target PPT File
foldername
Output DirectoryFLY Output Directory

Implements

IPPApplication.ConvertPPT2SWFWithoutStandaloneMasterSwf

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ConvertPPTX2PPT Method

[Visual Basic]
Public Sub ConvertPPTX2PPT( _
ByVal sourcePptx As String, _
ByVal targetPpt As String _
)
[C#]
public void ConvertPPTX2PPT(
string sourcePptx,
string targetPpt
);

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ConvertSWF2Exe Method

Converting SWF to EXE. FlashPlayer.exe must be contains in assembly directory

[Visual Basic]
Public NotOverridable Sub ConvertSWF2Exe( _
ByVal swfFile As String, _
ByVal exeFile As String _
) _
Implements IPPApplication.ConvertSWF2Exe
[C#]
public void ConvertSWF2Exe(
string swfFile,
string exeFile
);

Parameters

swfFile
exeFile

Implements

IPPApplication.ConvertSWF2Exe

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.CopyPlayerDataToFolder Method

Copies the player data to folder. From Executing folder.

[Visual Basic]
Public NotOverridable Sub CopyPlayerDataToFolder( _
ByVal foldername As String _
) _
Implements IPPApplication.CopyPlayerDataToFolder
[C#]
public void CopyPlayerDataToFolder(
string foldername
);

Parameters

foldername
The foldername.

Implements

IPPApplication.CopyPlayerDataToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.CopyPlayerFromToFolder Method

Copies the player data to folder. From other folder.

[Visual Basic]
Public NotOverridable Sub CopyPlayerFromToFolder( _
ByVal fromfolder As String, _
ByVal tofolder As String _
) _
Implements IPPApplication.CopyPlayerFromToFolder
[C#]
public void CopyPlayerFromToFolder(
string fromfolder,
string tofolder
);

Parameters

fromfolder
The fromfolder.
tofolder
The tofolder.

Implements

IPPApplication.CopyPlayerFromToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.EndSession Method

Close Powerpoint Session

[Visual Basic]
Public NotOverridable Sub EndSession() _
Implements IPPApplication.EndSession
[C#]
public void EndSession();

Implements

IPPApplication.EndSession

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.IsLicenseValid Method

Is license valid (LicenseMode == FULL or TRIAL)

[Visual Basic]
Public Sub IsLicenseValid()
[C#]
public bool IsLicenseValid();

Return Value

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.Load Method

Loads power point file into memory. It allows to get power point info before actul converting.

[Visual Basic]
Public NotOverridable Sub Load( _
ByVal powerPointFile As String _
) _
Implements IPPApplication.Load
[C#]
public void Load(
string powerPointFile
);

Parameters

powerPointFile
input power point file

Implements

IPPApplication.Load

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.LoadFromFile Method

Load data from Powerpoint file.

[Visual Basic]
Public NotOverridable Sub LoadFromFile( _
ByVal filename As String _
) _
Implements IPPApplication.LoadFromFile
[C#]
public void LoadFromFile(
string filename
);

Parameters

filename
path to PPT file.

Implements

IPPApplication.LoadFromFile

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.OnError Method

[Visual Basic]
Protected Sub OnError( _
ByVal errorMsg As String _
)
[C#]
protected void OnError(
string errorMsg
);

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.PublishToFTP Method

Piblish SWF File to FTP

[Visual Basic]
Public NotOverridable Sub PublishToFTP( _
ByVal SwfFilepath As String, _
ByVal FtpUrlAdress As String, _
ByVal FtpServerAdress As String, _
ByVal FtpPort As Integer, _
ByVal FtpLogin As String, _
ByVal FtpPassword As String _
) _
Implements IPPApplication.PublishToFTP
[C#]
public void PublishToFTP(
string SwfFilepath,
string FtpUrlAdress,
string FtpServerAdress,
int FtpPort,
string FtpLogin,
string FtpPassword
);

Implements

IPPApplication.PublishToFTP

See Also

PPApplication Class | Conaito.PPLibrary Namespace


RenderThumbsToFolder Method

conaito PPT2Flash SDK 3.7

PPApplication.RenderThumbsToFolder Method

Renders the thumbnails to folder.

Overload List

Renders the thumbnails to folder.

public void RenderThumbsToFolder(string,string,ThumbsFormats,int,int)

Renders the thumbnails to folder.

public void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,bool)

Renders the thumbnails to folder.

public void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,int,int)

Renders the thumbnails to folder.

public void RenderThumbsToFolder(string,string,ThumbsFormats,int,int,int,int,bool)

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32) Method

Renders the thumbnails to folder.

[Visual Basic]
Public NotOverridable Overloads Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer _
) _
Implements IPPApplication.RenderThumbsToFolder
[C#]
public void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height
);

Parameters

pptfilename
The input ppt file.
thumbspath
The thumbnail path.
thumbsFormat
The thumbnail format.
width
The width.
height
The height.

Implements

IPPApplication.RenderThumbsToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.RenderThumbsToFolder Overload List


PPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Boolean) Method

Renders the thumbnails to folder.

[Visual Basic]
Public NotOverridable Overloads Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal genThumbsXML As Boolean _
) _
Implements IPPApplication.RenderThumbsToFolder
[C#]
public void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
bool genThumbsXML
);

Parameters

pptfilename
The input ppt file.
thumbspath
The thumbnail path.
thumbsFormat
The thumbnail format.
width
The width.
height
The height.
genThumbsXML
Generate a thumbs.xml file.

Implements

IPPApplication.RenderThumbsToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.RenderThumbsToFolder Overload List


PPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Int32, Int32) Method

Renders the thumbnails to folder.

[Visual Basic]
Public NotOverridable Overloads Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
) _
Implements IPPApplication.RenderThumbsToFolder
[C#]
public void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
int fromSlide,
int toSlide
);

Parameters

pptfilename
The input ppt file.
thumbspath
The thumbnail path.
thumbsFormat
The thumbnail format.
width
The width.
height
The height.
fromSlide
From slide number. First slide - 1.
toSlide
To slide number.

Implements

IPPApplication.RenderThumbsToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.RenderThumbsToFolder Overload List


PPApplication.RenderThumbsToFolder(String, String, ThumbsFormats, Int32, Int32, Int32, Int32, Boolean) Method

Renders the thumbnails to folder.

[Visual Basic]
Public NotOverridable Overloads Sub RenderThumbsToFolder( _
ByVal pptfilename As String, _
ByVal thumbspath As String, _
ByVal thumbsFormat As ThumbsFormats, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer, _
ByVal genThumbsXML As Boolean _
) _
Implements IPPApplication.RenderThumbsToFolder
[C#]
public void RenderThumbsToFolder(
string pptfilename,
string thumbspath,
ThumbsFormats thumbsFormat,
int width,
int height,
int fromSlide,
int toSlide,
bool genThumbsXML
);

Parameters

pptfilename
The input ppt file.
thumbspath
The thumbnail path.
thumbsFormat
The thumbnail format.
width
The width.
height
The height.
fromSlide
From slide number. First slide - 1.
toSlide
To slide number.
genThumbsXML
Generate a thumbs.xml file.

Implements

IPPApplication.RenderThumbsToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace | PPApplication.RenderThumbsToFolder Overload List


PPApplication.RenderToFile Method

Render slides to SWF file

[Visual Basic]
Public NotOverridable Sub RenderToFile( _
ByVal filename As String _
) _
Implements IPPApplication.RenderToFile
[C#]
public void RenderToFile(
string filename
);

Parameters

filename
SWF file name

Implements

IPPApplication.RenderToFile

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.RenderToFolder Method

Render all Scenes to Folder.

[Visual Basic]
Public NotOverridable Sub RenderToFolder( _
ByVal foldername As String _
) _
Implements IPPApplication.RenderToFolder
[C#]
public void RenderToFolder(
string foldername
);

Parameters

foldername
path to folder.

Implements

IPPApplication.RenderToFolder

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.RenderToFolderSeparately Method

Render some slides to folder

[Visual Basic]
Public Sub RenderToFolderSeparately( _
ByVal foldername As String, _
ByVal fromSlide As Integer, _
ByVal toSlide As Integer _
)
[C#]
public void RenderToFolderSeparately(
string foldername,
int fromSlide,
int toSlide
);

Parameters

foldername
fromSlide
toSlide

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.SetLicense Method

Set license name and key

[Visual Basic]
Public NotOverridable Sub SetLicense( _
ByVal user As String, _
ByVal key As String _
) _
Implements IPPApplication.SetLicense
[C#]
public void SetLicense(
string user,
string key
);

Parameters

user
key

Implements

IPPApplication.SetLicense

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.StopRender Method

Stop render process

[Visual Basic]
Public NotOverridable Sub StopRender() _
Implements IPPApplication.StopRender
[C#]
public void StopRender();

Implements

IPPApplication.StopRender

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication Events

The events of the PPApplication class are listed below. For a complete list of PPApplication class members, see the PPApplication Members topic.

Public Instance Events

Exception |
ShapeProcessed | ShapeProcessed is fired when SDK is reading the shape information from the slides within the PowerPoint.
ShapeRender | ShapeRender is fired when SDK is compleate render the shape information from the slides within the PowerPoint.
SlideProcessed | SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint.
SlideRender | SlideRender is fired when SDK is compleate render the information from the slides within the PowerPoint.
ThumbsRender | ThumbsRender is fired when SDK is compleate render the thumb

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.Exception Event

[Visual Basic]
Public Event Exception As PPTErrorHandler
[C#]
public event PPTErrorHandler Exception;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ShapeProcessed Event

ShapeProcessed is fired when SDK is reading the shape information from the slides within the PowerPoint.

[Visual Basic]
Public Event ShapeProcessed As ShapeProcessedHandler
[C#]
public event ShapeProcessedHandler ShapeProcessed;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ShapeRender Event

ShapeRender is fired when SDK is compleate render the shape information from the slides within the PowerPoint.

[Visual Basic]
Public Event ShapeRender As ShapeRenderHandler
[C#]
public event ShapeRenderHandler ShapeRender;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.SlideProcessed Event

SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint.

[Visual Basic]
Public Event SlideProcessed As SlideProcessedHandler
[C#]
public event SlideProcessedHandler SlideProcessed;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.SlideRender Event

SlideRender is fired when SDK is compleate render the information from the slides within the PowerPoint.

[Visual Basic]
Public Event SlideRender As SlideRenderHandler
[C#]
public event SlideRenderHandler SlideRender;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.ThumbsRender Event

ThumbsRender is fired when SDK is compleate render the thumb

[Visual Basic]
Public Event ThumbsRender As ThumbsRenderHandler
[C#]
public event ThumbsRenderHandler ThumbsRender;

See Also

PPApplication Class | Conaito.PPLibrary Namespace


PPApplication.OfficeComponent Enumeration

[Visual Basic]
Public Enum OfficeComponent
[C#]
public enum OfficeComponent

Members

Member Name | Description
Word |
Excel |
PowerPoint |
Outlook |

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.PPTErrorHandler Delegate

[Visual Basic]
Public Delegate Function PPTErrorHandler( _
ByVal errorMsg As String _
)
[C#]
public delegate void PPTErrorHandler(
string errorMsg
);

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.ShapeProcessedHandler Delegate

ShapeProcessed is fired when SDK is reading the shape information from the slides within the PowerPoint.

[Visual Basic]
Public Delegate Function ShapeProcessedHandler( _
ByVal currentShape As Integer, _
ByVal totalShapes As Integer _
)
[C#]
public delegate void ShapeProcessedHandler(
int currentShape,
int totalShapes
);

Parameters

currentShape
currentShape gives you the shape being currently processed
totalShapes
totalShapes gives you the total number of shape present in the PowerPoint slide

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.ShapeRenderHandler Delegate

ShapeRender is fired when SDK is compleate render the shape information from the slides within the PowerPoint.

[Visual Basic]
Public Delegate Function ShapeRenderHandler( _
ByVal currentShape As Integer, _
ByVal totalShapes As Integer _
)
[C#]
public delegate void ShapeRenderHandler(
int currentShape,
int totalShapes
);

Parameters

currentShape
currentShape gives you the shape being currently processed
totalShapes
totalShapes gives you the total number of shape present in the PowerPoint slide

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.SlideProcessedHandler Delegate

SlideProcessed is fired when SDK is reading the information from the slides within the PowerPoint.

[Visual Basic]
Public Delegate Function SlideProcessedHandler( _
ByVal currentSlide As Integer, _
ByVal totalSlides As Integer _
)
[C#]
public delegate void SlideProcessedHandler(
int currentSlide,
int totalSlides
);

Parameters

currentSlide
currentSlide gives you the slide being currently processed
totalSlides
totalSlides gives you the total number of slides present in the PowerPoint file

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.SlideRenderHandler Delegate

SlideRender is fired when SDK is compleate render the information from the slides within the PowerPoint.

[Visual Basic]
Public Delegate Function SlideRenderHandler( _
ByVal currentSlide As Integer, _
ByVal totalSlides As Integer _
)
[C#]
public delegate void SlideRenderHandler(
int currentSlide,
int totalSlides
);

Parameters

currentSlide
currentSlide gives you the slide being currently processed
totalSlides
totalSlides gives you the total number of slides present in the PowerPoint file

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPApplication.ThumbsRenderHandler Delegate

[Visual Basic]
Public Delegate Function ThumbsRenderHandler( _
ByVal fromThumb As Integer, _
ByVal toThumb As Integer, _
ByVal currentThumb As Integer, _
ByVal currThumbPath As String _
)
[C#]
public delegate void ThumbsRenderHandler(
int fromThumb,
int toThumb,
int currentThumb,
string currThumbPath
);

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


PPTEventException Class

For a list of all members of this type, see PPTEventException Members .

System.Object
Exception
PPTEventException

[Visual Basic]
<Serializable> _
Public Class PPTEventException
Inherits Exception
[C#]
[Serializable]
public class PPTEventException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

PPTEventException Members | Conaito.PPLibrary Namespace


PPTEventException Members

PPTEventException overview

Public Instance Constructors

PPTEventException Overloaded. Initializes a new instance of the PPTEventException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

PPTEventException Overloaded. Initializes a new instance of the PPTEventException class.

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PPTEventException Class | Conaito.PPLibrary Namespace


PPTEventException Constructor

Initializes a new instance of the PPTEventException class.

Overload List

Initializes a new instance of the PPTEventException class.

public PPTEventException()

protected PPTEventException(SerializationInfo,StreamingContext)

public PPTEventException(string)

public PPTEventException(string,Exception)

See Also

PPTEventException Class | Conaito.PPLibrary Namespace


PPTEventException Constructor

Initializes a new instance of the PPTEventException class.

[Visual Basic]
Public Overloads Sub New()
[C#]
PPTEventException();

See Also

PPTEventException Class | Conaito.PPLibrary Namespace | PPTEventException Constructor Overload List


PPTEventException Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String _
)
[C#]
PPTEventException(
string message
);

See Also

PPTEventException Class | Conaito.PPLibrary Namespace | PPTEventException Constructor Overload List


PPTEventException Constructor

[Visual Basic]
Public Overloads Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
[C#]
PPTEventException(
string message,
Exception inner
);

See Also

PPTEventException Class | Conaito.PPLibrary Namespace | PPTEventException Constructor Overload List


PPTEventException Constructor

[Visual Basic]
Protected Overloads Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
[C#]
PPTEventException(
SerializationInfo info,
StreamingContext context
);

See Also

PPTEventException Class | Conaito.PPLibrary Namespace | PPTEventException Constructor Overload List


PptException Class

The exception that is thrown when power point data cannot be loaded.

For a list of all members of this type, see PptException Members .

System.Object
Exception
ApplicationException
BasePPTException
PptException

[Visual Basic]
Public Class PptException
Inherits BasePPTException
[C#]
public class PptException : BasePPTException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

PptException Members | Conaito.PPLibrary Namespace


PptException Members

PptException overview

Public Instance Constructors

PptException Constructor Initializes a new instance of the PptException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PptException Class | Conaito.PPLibrary Namespace


PptException Constructor

Initializes a new instance of the PptException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
PptException(
string message
);

Parameters

message
The message.

See Also

PptException Class | Conaito.PPLibrary Namespace


RegistryException Class

The exception that is thrown when registry load/save cannot be performed.

For a list of all members of this type, see RegistryException Members .

System.Object
Exception
ApplicationException
BasePPTException
RegistryException

[Visual Basic]
Public Class RegistryException
Inherits BasePPTException
[C#]
public class RegistryException : BasePPTException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

RegistryException Members | Conaito.PPLibrary Namespace


RegistryException Members

RegistryException overview

Public Instance Constructors

RegistryException Constructor Initializes a new instance of the RegistryException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

RegistryException Class | Conaito.PPLibrary Namespace


RegistryException Constructor

Initializes a new instance of the RegistryException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
RegistryException(
string message
);

Parameters

message
The message.

See Also

RegistryException Class | Conaito.PPLibrary Namespace


ThumbsFormats Enumeration

[Visual Basic]
Public Enum ThumbsFormats
[C#]
public enum ThumbsFormats

Members

Member Name | Description
PNG |
JPG |
BMP |
GIF |

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary Namespace


TtfException Class

The exception that is thrown when true type font cannot be loaded correctly.

For a list of all members of this type, see TtfException Members .

System.Object
Exception
ApplicationException
BasePPTException
TtfException

[Visual Basic]
Public Class TtfException
Inherits BasePPTException
[C#]
public class TtfException : BasePPTException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

TtfException Members | Conaito.PPLibrary Namespace


TtfException Members

TtfException overview

Public Instance Constructors

TtfException Constructor Initializes a new instance of the TtfException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TtfException Class | Conaito.PPLibrary Namespace


TtfException Constructor

Initializes a new instance of the TtfException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
TtfException(
string message
);

Parameters

message
The message.

See Also

TtfException Class | Conaito.PPLibrary Namespace


ZipException Class

The exception that is thrown when flash cannot be compressed by zlip compression method.

For a list of all members of this type, see ZipException Members .

System.Object
Exception
ApplicationException
BasePPTException
ZipException

[Visual Basic]
Public Class ZipException
Inherits BasePPTException
[C#]
public class ZipException : BasePPTException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Conaito.PPLibrary

Assembly: PPLibrary (in PPLibrary.dll)

See Also

ZipException Members | Conaito.PPLibrary Namespace


ZipException Members

ZipException overview

Public Instance Constructors

ZipException Constructor Initializes a new instance of the ZipException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ZipException Class | Conaito.PPLibrary Namespace


ZipException Constructor

Initializes a new instance of the ZipException class.

[Visual Basic]
Public Sub New( _
ByVal message As String _
)
[C#]
ZipException(
string message
);

Parameters

message
The message.

See Also

ZipException Class | Conaito.PPLibrary Namespace


Conaito.PPLibrary.License

conaito PPT2Flash SDK 3.7

Conaito.PPLibrary.License Namespace

Namespace Hierarchy

Enumerations

Enumeration | Description
LicenseMode | Represents license mode


LicenseMode Enumeration

Represents license mode

[Visual Basic]
Public Enum LicenseMode
[C#]
public enum LicenseMode

Members

Member Name | Description
Full |
FullDateExpired |
Trial |
TrialDateExpired |

Requirements

Namespace: Conaito.PPLibrary.License

Assembly: PPLibrary (in PPLibrary.dll)

See Also

Conaito.PPLibrary.License Namespace


Conaito.PPLibrary.LicenseHierarchy

conaito PPT2Flash SDK 3.7

Conaito.PPLibrary.License Hierarchy

Object
ValueType
Enum ---- IComparable, IConvertible, IFormattable
LicenseMode

See Also

Conaito.PPLibrary.License Namespace


Conaito.PPLibraryHierarchy

conaito PPT2Flash SDK 3.7

Conaito.PPLibrary Hierarchy

Object
FtpClient
IPPApplication
PPApplication ---- IPPApplication
Delegate ---- ICloneable, ISerializable
MulticastDelegate
PPApplication.PPTErrorHandler
PPApplication.ShapeProcessedHandler
PPApplication.ShapeRenderHandler
PPApplication.SlideProcessedHandler
PPApplication.SlideRenderHandler
PPApplication.ThumbsRenderHandler
Exception ---- ISerializable
FtpClient.FtpException
PowerPointNotInstalledException
PPTEventException
ApplicationException
BasePPTException
AnimationEffectException
PptException
RegistryException
TtfException
ZipException
BaseSwfException
ValueType
Enum ---- IComparable, IConvertible, IFormattable
ExportImageFormat
ExportImageMode
NavigationPanelAlignment
PPApplication.OfficeComponent
ThumbsFormats

See Also

Conaito.PPLibrary Namespace