Conaito.Office2Silverlight Namespace

[image]

conaito Office2Silverlight SDK Documentation
Conaito.Office2Silverlight Namespace
Send Feedback
conaito Office2Silverlight SDK
Conaito Office2Silverlight SDK

Classes

 | Class | Description
Public class | Appearance | Class for silverlight appearance settings
Public class | OfficeConverter | Class for generating the Silverlight XAP from the Office documents(PowerPoint, Word, Excel etc) and XPS
Public class | OfficeDocument | OfficeDocument class
Public class | OutputSettings | Class for output settings
Public class | Utils | Utils class

Enumerations

 | Enumeration | Description
Public enumeration | BackgroundImageStretch | Describes how content is resized to fill its allocated space.
Public enumeration | BackgroundMode | Background mode class
Public enumeration | ExeWindowBorderStyle | Enumeration of windows styles for output exe
Public enumeration | InfoLinkHorizontalPosition |
Public enumeration | InfoLinkVerticalPosition |
Public enumeration | ThumbnailsPosition | Thumbnails class
Public enumeration | ThumbnailsStyle | Enumeration of thumbnails style
Public enumeration | ToolbarHorizontalAlignment | Indicates where an element should be displayed on the horizontal axis relative to the allocated layout slot of the parent element.
Public enumeration | ToolbarPosition | ToolbarPosition class
Public enumeration | ToolbarVerticalAlignment | Describes how a child element is vertically positioned or stretched within a parent's layout slot.
Public enumeration | ViewMode | Enumeration of output view modes
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


Appearance Class

[image]

conaito Office2Silverlight SDK Documentation
Appearance Class
Members See Also Send Feedback
conaito Office2Silverlight SDK
Class for silverlight appearance settings

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Appearance
Visual Basic
Public Class Appearance
Visual C++
public ref class Appearance

Inheritance Hierarchy

System..::..Object
Conaito.Office2Silverlight..::..Appearance

See Also

Appearance Members
Conaito.Office2Silverlight Namespace


Appearance Members

[image] [image]

conaito Office2Silverlight SDK Documentation
Appearance Members
Appearance Class Constructors Methods Properties See Also Send Feedback
conaito Office2Silverlight SDK

The Appearance type exposes the following members.

Constructors

 | Name | Description
Public method | Appearance | Initializes a new instance of the Appearance class.

Methods

 | Name | Description
 | LoadFromString |
 | LoadFromXml | Loads appearance theme from XML.
Public method | SaveToString |
Public method | SaveToXML | Saves appearance theme to XML.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | BackgroundImagePath | Gets or sets the background image path.
Public property | BackgroundImageStretch | Gets or sets the background image stretch.
Public property | BackgroundMode | Gets or sets the background mode.
Public property | ControlsApplyTheme |
Public property | ControlsBackgroundColor | Gets or sets the color of the controls background.
Public property | ControlsBackgroundElementsColor | Gets or sets the color of the controls background elements.
Public property | ControlsBackgroundTextColor | Gets or sets the color of the controls background2.
Public property | ControlsComboboxOverColor | Gets or sets the color of the controls combobox over.
Public property | ControlsForegroundColor | Gets or sets the color of the controls foreground.
Public property | InfoLinkColor | Gets or sets the color of the info link.
Public property | InfoLinkHorizontalPosition | Gets or sets the info link horizontal position.
Public property | InfoLinkHyperlink | Gets or sets the info link hyperlink.
Public property | InfoLinkHyperlinkTarget | Gets or sets the info link hyperlink target.
Public property | InfoLinkText | Gets or sets the info link text.
Public property | InfoLinkVerticalPosition | Gets or sets the info link vertical position.
Public property | ThumbBottomIndent | Gets or sets the thumb bottom indent.
Public property | ThumbLeftIndent | Gets or sets the thumb left indent.
Public property | ThumbPosition | Gets or sets the thumb position.
Public property | ThumbRightIndent | Gets or sets the thumb right indent.
Public property | ThumbTopIndent | Gets or sets the thumb top indent.
Public property | ToolbarAreaHeight | Gets or sets the height of the toolbar area.
Public property | ToolbarBackgroundColor | Gets or sets the color of the toolbar background.
Public property | ToolbarBackgroundImagePath | Gets or sets the toolbar background image path.
Public property | ToolbarBackgroundImageStretch | Gets or sets the toolbar background image stretch.
Public property | ToolbarBackgroundMode | Gets or sets the toolbar background mode.
Public property | ToolbarBordersColor | Gets or sets the color of the toolbar borders.
Public property | ToolbarBordersRadiusX | Gets or sets the toolbar borders radius X.
Public property | ToolbarBordersRadiusY | Gets or sets the toolbar borders radius Y.
Public property | ToolbarBordersShow | Gets or sets a value indicating whether [toolbar borders show].
Public property | ToolbarBordersWidth | Gets or sets the width of the toolbar borders.
Public property | ToolbarBottomIndent | Gets or sets the toolbar bottom indent.
Public property | ToolbarHeight | Gets or sets the height of the toolbar.
Public property | ToolbarHorizontalAlignment | Gets or sets the toolbar horizontal alignment.
Public property | ToolbarLeftIndent | Gets or sets the toolbar left indent.
Public property | ToolbarPosition | Gets or sets the toolbar position.
Public property | ToolbarRightIndent | Gets or sets the toolbar right indent.
Public property | ToolbarShadowColor | Gets or sets the color of the toolbar shadow.
Public property | ToolbarShadowDepth | Gets or sets the toolbar shadow depth.
Public property | ToolbarShadowOpacity | Gets or sets the toolbar shadow opacity.
Public property | ToolbarShadowRadius | Gets or sets the toolbar shadow radius.
Public property | ToolbarShadowShow | Gets or sets a value indicating whether [toolbar shadow show].
Public property | ToolbarTopIndent | Gets or sets the toolbar top indent.
Public property | ToolbarVerticalAlignment | Gets or sets the toolbar vertical alignment.
Public property | ToolbarWidth | Gets or sets the width of the toolbar.
Public property | ViewerBackgroundColor | Gets or sets the color of the viewer background.
Public property | ViewerBackgroundImagePath | Gets or sets the viewer background image path.
Public property | ViewerBackgroundImageStretch | Gets or sets the viewer background image stretch.
Public property | ViewerBackgroundMode | Gets or sets the viewer background mode.
Public property | ViewerBordersColor | Gets or sets the color of the viewer borders.
Public property | ViewerBordersLeftRightIndent | Gets or sets the viewer borders left right indent.
Public property | ViewerBordersRadiusX | Gets or sets the viewer borders radius X.
Public property | ViewerBordersRadiusY | Gets or sets the viewer borders radius Y.
Public property | ViewerBordersShow | Gets or sets a value indicating whether [viewer borders show].
Public property | ViewerBordersTopButtomIndent | Gets or sets the viewer borders top buttom indent.
Public property | ViewerBordersWidth | Gets or sets the width of the viewer borders.
Public property | ViewerShadowColor | Gets or sets the color of the viewer shadow.
Public property | ViewerShadowDepth | Gets or sets the viewer shadow depth.
Public property | ViewerShadowOpacity | Gets or sets the viewer shadow opacity.
Public property | ViewerShadowRadius | Gets or sets the viewer shadow radius.
Public property | ViewerShadowShow | Gets or sets a value indicating whether [viewer shadow show].

See Also

Appearance Class


Appearance Constructor

[image]

conaito Office2Silverlight SDK Documentation
Appearance Constructor
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Initializes a new instance of the Appearance class.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Appearance()
Visual Basic
Public Sub New
Visual C++
public:
Appearance()

See Also


Appearance Methods

[image] [image]

conaito Office2Silverlight SDK Documentation
Appearance Methods
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK

The Appearance type exposes the following members.

Methods

 | Name | Description
 | LoadFromString |
 | LoadFromXml | Loads appearance theme from XML.
Public method | SaveToString |
Public method | SaveToXML | Saves appearance theme to XML.

See Also


LoadFromString Method

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..LoadFromString Method
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Appearance LoadFromString(
    string content
)
Visual Basic
Public Shared Function LoadFromString ( _
    content As String _
) As Appearance
Visual C++
public:
static Appearance^ LoadFromString(
    String^ content
)

Parameters

content
Type: System..::..String

See Also


LoadFromXml Method

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..LoadFromXml Method
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Loads appearance theme from XML.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Appearance LoadFromXml(
    string themeFilePath
)
Visual Basic
Public Shared Function LoadFromXml ( _
    themeFilePath As String _
) As Appearance
Visual C++
public:
static Appearance^ LoadFromXml(
    String^ themeFilePath
)

Parameters

themeFilePath
Type: System..::..String
The theme file path.

Return Value

See Also


SaveToString Method

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..SaveToString Method
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string SaveToString()
Visual Basic
Public Function SaveToString As String
Visual C++
public:
String^ SaveToString()

See Also


SaveToXML Method

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..SaveToXML Method
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Saves appearance theme to XML.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SaveToXML(
    string filePath
)
Visual Basic
Public Sub SaveToXML ( _
    filePath As String _
)
Visual C++
public:
void SaveToXML(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path.

See Also


Appearance Properties

[image] [image]

conaito Office2Silverlight SDK Documentation
Appearance Properties
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK

The Appearance type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | Gets or sets the color of the background.
Public property | BackgroundImagePath | Gets or sets the background image path.
Public property | BackgroundImageStretch | Gets or sets the background image stretch.
Public property | BackgroundMode | Gets or sets the background mode.
Public property | ControlsApplyTheme |
Public property | ControlsBackgroundColor | Gets or sets the color of the controls background.
Public property | ControlsBackgroundElementsColor | Gets or sets the color of the controls background elements.
Public property | ControlsBackgroundTextColor | Gets or sets the color of the controls background2.
Public property | ControlsComboboxOverColor | Gets or sets the color of the controls combobox over.
Public property | ControlsForegroundColor | Gets or sets the color of the controls foreground.
Public property | InfoLinkColor | Gets or sets the color of the info link.
Public property | InfoLinkHorizontalPosition | Gets or sets the info link horizontal position.
Public property | InfoLinkHyperlink | Gets or sets the info link hyperlink.
Public property | InfoLinkHyperlinkTarget | Gets or sets the info link hyperlink target.
Public property | InfoLinkText | Gets or sets the info link text.
Public property | InfoLinkVerticalPosition | Gets or sets the info link vertical position.
Public property | ThumbBottomIndent | Gets or sets the thumb bottom indent.
Public property | ThumbLeftIndent | Gets or sets the thumb left indent.
Public property | ThumbPosition | Gets or sets the thumb position.
Public property | ThumbRightIndent | Gets or sets the thumb right indent.
Public property | ThumbTopIndent | Gets or sets the thumb top indent.
Public property | ToolbarAreaHeight | Gets or sets the height of the toolbar area.
Public property | ToolbarBackgroundColor | Gets or sets the color of the toolbar background.
Public property | ToolbarBackgroundImagePath | Gets or sets the toolbar background image path.
Public property | ToolbarBackgroundImageStretch | Gets or sets the toolbar background image stretch.
Public property | ToolbarBackgroundMode | Gets or sets the toolbar background mode.
Public property | ToolbarBordersColor | Gets or sets the color of the toolbar borders.
Public property | ToolbarBordersRadiusX | Gets or sets the toolbar borders radius X.
Public property | ToolbarBordersRadiusY | Gets or sets the toolbar borders radius Y.
Public property | ToolbarBordersShow | Gets or sets a value indicating whether [toolbar borders show].
Public property | ToolbarBordersWidth | Gets or sets the width of the toolbar borders.
Public property | ToolbarBottomIndent | Gets or sets the toolbar bottom indent.
Public property | ToolbarHeight | Gets or sets the height of the toolbar.
Public property | ToolbarHorizontalAlignment | Gets or sets the toolbar horizontal alignment.
Public property | ToolbarLeftIndent | Gets or sets the toolbar left indent.
Public property | ToolbarPosition | Gets or sets the toolbar position.
Public property | ToolbarRightIndent | Gets or sets the toolbar right indent.
Public property | ToolbarShadowColor | Gets or sets the color of the toolbar shadow.
Public property | ToolbarShadowDepth | Gets or sets the toolbar shadow depth.
Public property | ToolbarShadowOpacity | Gets or sets the toolbar shadow opacity.
Public property | ToolbarShadowRadius | Gets or sets the toolbar shadow radius.
Public property | ToolbarShadowShow | Gets or sets a value indicating whether [toolbar shadow show].
Public property | ToolbarTopIndent | Gets or sets the toolbar top indent.
Public property | ToolbarVerticalAlignment | Gets or sets the toolbar vertical alignment.
Public property | ToolbarWidth | Gets or sets the width of the toolbar.
Public property | ViewerBackgroundColor | Gets or sets the color of the viewer background.
Public property | ViewerBackgroundImagePath | Gets or sets the viewer background image path.
Public property | ViewerBackgroundImageStretch | Gets or sets the viewer background image stretch.
Public property | ViewerBackgroundMode | Gets or sets the viewer background mode.
Public property | ViewerBordersColor | Gets or sets the color of the viewer borders.
Public property | ViewerBordersLeftRightIndent | Gets or sets the viewer borders left right indent.
Public property | ViewerBordersRadiusX | Gets or sets the viewer borders radius X.
Public property | ViewerBordersRadiusY | Gets or sets the viewer borders radius Y.
Public property | ViewerBordersShow | Gets or sets a value indicating whether [viewer borders show].
Public property | ViewerBordersTopButtomIndent | Gets or sets the viewer borders top buttom indent.
Public property | ViewerBordersWidth | Gets or sets the width of the viewer borders.
Public property | ViewerShadowColor | Gets or sets the color of the viewer shadow.
Public property | ViewerShadowDepth | Gets or sets the viewer shadow depth.
Public property | ViewerShadowOpacity | Gets or sets the viewer shadow opacity.
Public property | ViewerShadowRadius | Gets or sets the viewer shadow radius.
Public property | ViewerShadowShow | Gets or sets a value indicating whether [viewer shadow show].

See Also


BackgroundColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..BackgroundColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the background.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As String
    Get
    Set
Visual C++
public:
property String^ BackgroundColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the background.

See Also


BackgroundImagePath Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..BackgroundImagePath Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the background image path.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string BackgroundImagePath { get; set; }
Visual Basic
Public Property BackgroundImagePath As String
    Get
    Set
Visual C++
public:
property String^ BackgroundImagePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The background image path.

See Also


BackgroundImageStretch Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..BackgroundImageStretch Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the background image stretch.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundImageStretch BackgroundImageStretch { get; set; }
Visual Basic
Public Property BackgroundImageStretch As BackgroundImageStretch
    Get
    Set
Visual C++
public:
property BackgroundImageStretch BackgroundImageStretch {
    BackgroundImageStretch get ();
    void set (BackgroundImageStretch value);
}

Field Value

The background image stretch.

See Also


BackgroundMode Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..BackgroundMode Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the background mode.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundMode BackgroundMode { get; set; }
Visual Basic
Public Property BackgroundMode As BackgroundMode
    Get
    Set
Visual C++
public:
property BackgroundMode BackgroundMode {
    BackgroundMode get ();
    void set (BackgroundMode value);
}

Field Value

The background mode.

See Also


ControlsApplyTheme Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsApplyTheme Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ControlsApplyTheme { get; set; }
Visual Basic
Public Property ControlsApplyTheme As Boolean
    Get
    Set
Visual C++
public:
property bool ControlsApplyTheme {
    bool get ();
    void set (bool value);
}

See Also


ControlsBackgroundColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsBackgroundColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the controls background.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ControlsBackgroundColor { get; set; }
Visual Basic
Public Property ControlsBackgroundColor As String
    Get
    Set
Visual C++
public:
property String^ ControlsBackgroundColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the controls background.

See Also


ControlsBackgroundElementsColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsBackgroundElementsColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the controls background elements.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ControlsBackgroundElementsColor { get; set; }
Visual Basic
Public Property ControlsBackgroundElementsColor As String
    Get
    Set
Visual C++
public:
property String^ ControlsBackgroundElementsColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the controls background elements.

See Also


ControlsBackgroundTextColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsBackgroundTextColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the controls background2.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ControlsBackgroundTextColor { get; set; }
Visual Basic
Public Property ControlsBackgroundTextColor As String
    Get
    Set
Visual C++
public:
property String^ ControlsBackgroundTextColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the controls background2.

See Also


ControlsComboboxOverColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsComboboxOverColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the controls combobox over.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ControlsComboboxOverColor { get; set; }
Visual Basic
Public Property ControlsComboboxOverColor As String
    Get
    Set
Visual C++
public:
property String^ ControlsComboboxOverColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the controls combobox over.

See Also


ControlsForegroundColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ControlsForegroundColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the controls foreground.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ControlsForegroundColor { get; set; }
Visual Basic
Public Property ControlsForegroundColor As String
    Get
    Set
Visual C++
public:
property String^ ControlsForegroundColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the controls foreground.

See Also


InfoLinkColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the info link.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string InfoLinkColor { get; set; }
Visual Basic
Public Property InfoLinkColor As String
    Get
    Set
Visual C++
public:
property String^ InfoLinkColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the info link.

See Also


InfoLinkHorizontalPosition Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkHorizontalPosition Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the info link horizontal position.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public InfoLinkHorizontalPosition InfoLinkHorizontalPosition { get; set; }
Visual Basic
Public Property InfoLinkHorizontalPosition As InfoLinkHorizontalPosition
    Get
    Set
Visual C++
public:
property InfoLinkHorizontalPosition InfoLinkHorizontalPosition {
    InfoLinkHorizontalPosition get ();
    void set (InfoLinkHorizontalPosition value);
}

Field Value

The info link horizontal position.

See Also


InfoLinkHyperlink Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkHyperlink Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the info link hyperlink.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string InfoLinkHyperlink { get; set; }
Visual Basic
Public Property InfoLinkHyperlink As String
    Get
    Set
Visual C++
public:
property String^ InfoLinkHyperlink {
    String^ get ();
    void set (String^ value);
}

Field Value

The info link hyperlink.

See Also


InfoLinkHyperlinkTarget Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkHyperlinkTarget Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the info link hyperlink target.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string InfoLinkHyperlinkTarget { get; set; }
Visual Basic
Public Property InfoLinkHyperlinkTarget As String
    Get
    Set
Visual C++
public:
property String^ InfoLinkHyperlinkTarget {
    String^ get ();
    void set (String^ value);
}

Field Value

The info link hyperlink target.

See Also


InfoLinkText Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkText Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the info link text.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string InfoLinkText { get; set; }
Visual Basic
Public Property InfoLinkText As String
    Get
    Set
Visual C++
public:
property String^ InfoLinkText {
    String^ get ();
    void set (String^ value);
}

Field Value

The info link text.

See Also


InfoLinkVerticalPosition Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..InfoLinkVerticalPosition Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the info link vertical position.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public InfoLinkVerticalPosition InfoLinkVerticalPosition { get; set; }
Visual Basic
Public Property InfoLinkVerticalPosition As InfoLinkVerticalPosition
    Get
    Set
Visual C++
public:
property InfoLinkVerticalPosition InfoLinkVerticalPosition {
    InfoLinkVerticalPosition get ();
    void set (InfoLinkVerticalPosition value);
}

Field Value

The info link vertical position.

See Also


ThumbBottomIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ThumbBottomIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumb bottom indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ThumbBottomIndent { get; set; }
Visual Basic
Public Property ThumbBottomIndent As Integer
    Get
    Set
Visual C++
public:
property int ThumbBottomIndent {
    int get ();
    void set (int value);
}

Field Value

The thumb bottom indent.

See Also


ThumbLeftIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ThumbLeftIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumb left indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ThumbLeftIndent { get; set; }
Visual Basic
Public Property ThumbLeftIndent As Integer
    Get
    Set
Visual C++
public:
property int ThumbLeftIndent {
    int get ();
    void set (int value);
}

Field Value

The thumb left indent.

See Also


ThumbPosition Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ThumbPosition Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumb position.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ThumbnailsPosition ThumbPosition { get; set; }
Visual Basic
Public Property ThumbPosition As ThumbnailsPosition
    Get
    Set
Visual C++
public:
property ThumbnailsPosition ThumbPosition {
    ThumbnailsPosition get ();
    void set (ThumbnailsPosition value);
}

Field Value

The thumb position.

See Also


ThumbRightIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ThumbRightIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumb right indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ThumbRightIndent { get; set; }
Visual Basic
Public Property ThumbRightIndent As Integer
    Get
    Set
Visual C++
public:
property int ThumbRightIndent {
    int get ();
    void set (int value);
}

Field Value

The thumb right indent.

See Also


ThumbTopIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ThumbTopIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumb top indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ThumbTopIndent { get; set; }
Visual Basic
Public Property ThumbTopIndent As Integer
    Get
    Set
Visual C++
public:
property int ThumbTopIndent {
    int get ();
    void set (int value);
}

Field Value

The thumb top indent.

See Also


ToolbarAreaHeight Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarAreaHeight Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the height of the toolbar area.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarAreaHeight { get; set; }
Visual Basic
Public Property ToolbarAreaHeight As Integer
    Get
    Set
Visual C++
public:
property int ToolbarAreaHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the toolbar area.

See Also


ToolbarBackgroundColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBackgroundColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the toolbar background.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ToolbarBackgroundColor { get; set; }
Visual Basic
Public Property ToolbarBackgroundColor As String
    Get
    Set
Visual C++
public:
property String^ ToolbarBackgroundColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the toolbar background.

See Also


ToolbarBackgroundImagePath Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBackgroundImagePath Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar background image path.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ToolbarBackgroundImagePath { get; set; }
Visual Basic
Public Property ToolbarBackgroundImagePath As String
    Get
    Set
Visual C++
public:
property String^ ToolbarBackgroundImagePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The toolbar background image path.

See Also


ToolbarBackgroundImageStretch Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBackgroundImageStretch Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar background image stretch.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundImageStretch ToolbarBackgroundImageStretch { get; set; }
Visual Basic
Public Property ToolbarBackgroundImageStretch As BackgroundImageStretch
    Get
    Set
Visual C++
public:
property BackgroundImageStretch ToolbarBackgroundImageStretch {
    BackgroundImageStretch get ();
    void set (BackgroundImageStretch value);
}

Field Value

The toolbar background image stretch.

See Also


ToolbarBackgroundMode Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBackgroundMode Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar background mode.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundMode ToolbarBackgroundMode { get; set; }
Visual Basic
Public Property ToolbarBackgroundMode As BackgroundMode
    Get
    Set
Visual C++
public:
property BackgroundMode ToolbarBackgroundMode {
    BackgroundMode get ();
    void set (BackgroundMode value);
}

Field Value

The toolbar background mode.

See Also


ToolbarBordersColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBordersColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the toolbar borders.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ToolbarBordersColor { get; set; }
Visual Basic
Public Property ToolbarBordersColor As String
    Get
    Set
Visual C++
public:
property String^ ToolbarBordersColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the toolbar borders.

See Also


ToolbarBordersRadiusX Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBordersRadiusX Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar borders radius X.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarBordersRadiusX { get; set; }
Visual Basic
Public Property ToolbarBordersRadiusX As Integer
    Get
    Set
Visual C++
public:
property int ToolbarBordersRadiusX {
    int get ();
    void set (int value);
}

Field Value

The toolbar borders radius X.

See Also


ToolbarBordersRadiusY Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBordersRadiusY Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar borders radius Y.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarBordersRadiusY { get; set; }
Visual Basic
Public Property ToolbarBordersRadiusY As Integer
    Get
    Set
Visual C++
public:
property int ToolbarBordersRadiusY {
    int get ();
    void set (int value);
}

Field Value

The toolbar borders radius Y.

See Also


ToolbarBordersShow Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBordersShow Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [toolbar borders show].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ToolbarBordersShow { get; set; }
Visual Basic
Public Property ToolbarBordersShow As Boolean
    Get
    Set
Visual C++
public:
property bool ToolbarBordersShow {
    bool get ();
    void set (bool value);
}

Field Value

true if [toolbar borders show]; otherwise, false.

See Also


ToolbarBordersWidth Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBordersWidth Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the width of the toolbar borders.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarBordersWidth { get; set; }
Visual Basic
Public Property ToolbarBordersWidth As Integer
    Get
    Set
Visual C++
public:
property int ToolbarBordersWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the toolbar borders.

See Also


ToolbarBottomIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarBottomIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar bottom indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarBottomIndent { get; set; }
Visual Basic
Public Property ToolbarBottomIndent As Integer
    Get
    Set
Visual C++
public:
property int ToolbarBottomIndent {
    int get ();
    void set (int value);
}

Field Value

The toolbar bottom indent.

See Also


ToolbarHeight Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarHeight Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the height of the toolbar.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarHeight { get; set; }
Visual Basic
Public Property ToolbarHeight As Integer
    Get
    Set
Visual C++
public:
property int ToolbarHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the toolbar.

See Also


ToolbarHorizontalAlignment Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarHorizontalAlignment Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar horizontal alignment.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolbarHorizontalAlignment ToolbarHorizontalAlignment { get; set; }
Visual Basic
Public Property ToolbarHorizontalAlignment As ToolbarHorizontalAlignment
    Get
    Set
Visual C++
public:
property ToolbarHorizontalAlignment ToolbarHorizontalAlignment {
    ToolbarHorizontalAlignment get ();
    void set (ToolbarHorizontalAlignment value);
}

Field Value

The toolbar horizontal alignment.

See Also


ToolbarLeftIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarLeftIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar left indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarLeftIndent { get; set; }
Visual Basic
Public Property ToolbarLeftIndent As Integer
    Get
    Set
Visual C++
public:
property int ToolbarLeftIndent {
    int get ();
    void set (int value);
}

Field Value

The toolbar left indent.

See Also


ToolbarPosition Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarPosition Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar position.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolbarPosition ToolbarPosition { get; set; }
Visual Basic
Public Property ToolbarPosition As ToolbarPosition
    Get
    Set
Visual C++
public:
property ToolbarPosition ToolbarPosition {
    ToolbarPosition get ();
    void set (ToolbarPosition value);
}

Field Value

The toolbar position.

See Also


ToolbarRightIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarRightIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar right indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarRightIndent { get; set; }
Visual Basic
Public Property ToolbarRightIndent As Integer
    Get
    Set
Visual C++
public:
property int ToolbarRightIndent {
    int get ();
    void set (int value);
}

Field Value

The toolbar right indent.

See Also


ToolbarShadowColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarShadowColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the toolbar shadow.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ToolbarShadowColor { get; set; }
Visual Basic
Public Property ToolbarShadowColor As String
    Get
    Set
Visual C++
public:
property String^ ToolbarShadowColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the toolbar shadow.

See Also


ToolbarShadowDepth Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarShadowDepth Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar shadow depth.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarShadowDepth { get; set; }
Visual Basic
Public Property ToolbarShadowDepth As Integer
    Get
    Set
Visual C++
public:
property int ToolbarShadowDepth {
    int get ();
    void set (int value);
}

Field Value

The toolbar shadow depth.

See Also


ToolbarShadowOpacity Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarShadowOpacity Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar shadow opacity.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarShadowOpacity { get; set; }
Visual Basic
Public Property ToolbarShadowOpacity As Integer
    Get
    Set
Visual C++
public:
property int ToolbarShadowOpacity {
    int get ();
    void set (int value);
}

Field Value

The toolbar shadow opacity.

See Also


ToolbarShadowRadius Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarShadowRadius Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar shadow radius.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarShadowRadius { get; set; }
Visual Basic
Public Property ToolbarShadowRadius As Integer
    Get
    Set
Visual C++
public:
property int ToolbarShadowRadius {
    int get ();
    void set (int value);
}

Field Value

The toolbar shadow radius.

See Also


ToolbarShadowShow Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarShadowShow Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [toolbar shadow show].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ToolbarShadowShow { get; set; }
Visual Basic
Public Property ToolbarShadowShow As Boolean
    Get
    Set
Visual C++
public:
property bool ToolbarShadowShow {
    bool get ();
    void set (bool value);
}

Field Value

true if [toolbar shadow show]; otherwise, false.

See Also


ToolbarTopIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarTopIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar top indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarTopIndent { get; set; }
Visual Basic
Public Property ToolbarTopIndent As Integer
    Get
    Set
Visual C++
public:
property int ToolbarTopIndent {
    int get ();
    void set (int value);
}

Field Value

The toolbar top indent.

See Also


ToolbarVerticalAlignment Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarVerticalAlignment Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the toolbar vertical alignment.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolbarVerticalAlignment ToolbarVerticalAlignment { get; set; }
Visual Basic
Public Property ToolbarVerticalAlignment As ToolbarVerticalAlignment
    Get
    Set
Visual C++
public:
property ToolbarVerticalAlignment ToolbarVerticalAlignment {
    ToolbarVerticalAlignment get ();
    void set (ToolbarVerticalAlignment value);
}

Field Value

The toolbar vertical alignment.

See Also


ToolbarWidth Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ToolbarWidth Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the width of the toolbar.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ToolbarWidth { get; set; }
Visual Basic
Public Property ToolbarWidth As Integer
    Get
    Set
Visual C++
public:
property int ToolbarWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the toolbar.

See Also


ViewerBackgroundColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBackgroundColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the viewer background.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ViewerBackgroundColor { get; set; }
Visual Basic
Public Property ViewerBackgroundColor As String
    Get
    Set
Visual C++
public:
property String^ ViewerBackgroundColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the viewer background.

See Also


ViewerBackgroundImagePath Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBackgroundImagePath Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer background image path.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ViewerBackgroundImagePath { get; set; }
Visual Basic
Public Property ViewerBackgroundImagePath As String
    Get
    Set
Visual C++
public:
property String^ ViewerBackgroundImagePath {
    String^ get ();
    void set (String^ value);
}

Field Value

The viewer background image path.

See Also


ViewerBackgroundImageStretch Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBackgroundImageStretch Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer background image stretch.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundImageStretch ViewerBackgroundImageStretch { get; set; }
Visual Basic
Public Property ViewerBackgroundImageStretch As BackgroundImageStretch
    Get
    Set
Visual C++
public:
property BackgroundImageStretch ViewerBackgroundImageStretch {
    BackgroundImageStretch get ();
    void set (BackgroundImageStretch value);
}

Field Value

The viewer background image stretch.

See Also


ViewerBackgroundMode Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBackgroundMode Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer background mode.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BackgroundMode ViewerBackgroundMode { get; set; }
Visual Basic
Public Property ViewerBackgroundMode As BackgroundMode
    Get
    Set
Visual C++
public:
property BackgroundMode ViewerBackgroundMode {
    BackgroundMode get ();
    void set (BackgroundMode value);
}

Field Value

The viewer background mode.

See Also


ViewerBordersColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the viewer borders.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ViewerBordersColor { get; set; }
Visual Basic
Public Property ViewerBordersColor As String
    Get
    Set
Visual C++
public:
property String^ ViewerBordersColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the viewer borders.

See Also


ViewerBordersLeftRightIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersLeftRightIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer borders left right indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerBordersLeftRightIndent { get; set; }
Visual Basic
Public Property ViewerBordersLeftRightIndent As Integer
    Get
    Set
Visual C++
public:
property int ViewerBordersLeftRightIndent {
    int get ();
    void set (int value);
}

Field Value

The viewer borders left right indent.

See Also


ViewerBordersRadiusX Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersRadiusX Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer borders radius X.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerBordersRadiusX { get; set; }
Visual Basic
Public Property ViewerBordersRadiusX As Integer
    Get
    Set
Visual C++
public:
property int ViewerBordersRadiusX {
    int get ();
    void set (int value);
}

Field Value

The viewer borders radius X.

See Also


ViewerBordersRadiusY Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersRadiusY Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer borders radius Y.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerBordersRadiusY { get; set; }
Visual Basic
Public Property ViewerBordersRadiusY As Integer
    Get
    Set
Visual C++
public:
property int ViewerBordersRadiusY {
    int get ();
    void set (int value);
}

Field Value

The viewer borders radius Y.

See Also


ViewerBordersShow Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersShow Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [viewer borders show].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ViewerBordersShow { get; set; }
Visual Basic
Public Property ViewerBordersShow As Boolean
    Get
    Set
Visual C++
public:
property bool ViewerBordersShow {
    bool get ();
    void set (bool value);
}

Field Value

true if [viewer borders show]; otherwise, false.

See Also


ViewerBordersTopButtomIndent Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersTopButtomIndent Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer borders top buttom indent.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerBordersTopButtomIndent { get; set; }
Visual Basic
Public Property ViewerBordersTopButtomIndent As Integer
    Get
    Set
Visual C++
public:
property int ViewerBordersTopButtomIndent {
    int get ();
    void set (int value);
}

Field Value

The viewer borders top buttom indent.

See Also


ViewerBordersWidth Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerBordersWidth Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the width of the viewer borders.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerBordersWidth { get; set; }
Visual Basic
Public Property ViewerBordersWidth As Integer
    Get
    Set
Visual C++
public:
property int ViewerBordersWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the viewer borders.

See Also


ViewerShadowColor Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerShadowColor Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the color of the viewer shadow.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ViewerShadowColor { get; set; }
Visual Basic
Public Property ViewerShadowColor As String
    Get
    Set
Visual C++
public:
property String^ ViewerShadowColor {
    String^ get ();
    void set (String^ value);
}

Field Value

The color of the viewer shadow.

See Also


ViewerShadowDepth Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerShadowDepth Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer shadow depth.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerShadowDepth { get; set; }
Visual Basic
Public Property ViewerShadowDepth As Integer
    Get
    Set
Visual C++
public:
property int ViewerShadowDepth {
    int get ();
    void set (int value);
}

Field Value

The viewer shadow depth.

See Also


ViewerShadowOpacity Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerShadowOpacity Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer shadow opacity.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerShadowOpacity { get; set; }
Visual Basic
Public Property ViewerShadowOpacity As Integer
    Get
    Set
Visual C++
public:
property int ViewerShadowOpacity {
    int get ();
    void set (int value);
}

Field Value

The viewer shadow opacity.

See Also


ViewerShadowRadius Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerShadowRadius Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the viewer shadow radius.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ViewerShadowRadius { get; set; }
Visual Basic
Public Property ViewerShadowRadius As Integer
    Get
    Set
Visual C++
public:
property int ViewerShadowRadius {
    int get ();
    void set (int value);
}

Field Value

The viewer shadow radius.

See Also


ViewerShadowShow Property

[image]

conaito Office2Silverlight SDK Documentation
Appearance..::..ViewerShadowShow Property
Appearance Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [viewer shadow show].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ViewerShadowShow { get; set; }
Visual Basic
Public Property ViewerShadowShow As Boolean
    Get
    Set
Visual C++
public:
property bool ViewerShadowShow {
    bool get ();
    void set (bool value);
}

Field Value

true if [viewer shadow show]; otherwise, false.

See Also


BackgroundImageStretch Enumeration

[image]

conaito Office2Silverlight SDK Documentation
BackgroundImageStretch Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Describes how content is resized to fill its allocated space.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum BackgroundImageStretch
Visual Basic
Public Enumeration BackgroundImageStretch
Visual C++
public enum class BackgroundImageStretch

Members

Member name | Description
None |
Fill |
Uniform |
UniformToFill |
Texture |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


BackgroundMode Enumeration

[image]

conaito Office2Silverlight SDK Documentation
BackgroundMode Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Background mode class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum BackgroundMode
Visual Basic
Public Enumeration BackgroundMode
Visual C++
public enum class BackgroundMode

Members

Member name | Description
Default |
Color |
Image |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


ExeWindowBorderStyle Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ExeWindowBorderStyle Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Enumeration of windows styles for output exe

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ExeWindowBorderStyle
Visual Basic
Public Enumeration ExeWindowBorderStyle
Visual C++
public enum class ExeWindowBorderStyle

Members

Member name | Description
Resizable |
Fixed |
None |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


InfoLinkHorizontalPosition Enumeration

[image]

conaito Office2Silverlight SDK Documentation
InfoLinkHorizontalPosition Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum InfoLinkHorizontalPosition
Visual Basic
Public Enumeration InfoLinkHorizontalPosition
Visual C++
public enum class InfoLinkHorizontalPosition

Members

Member name | Description
Left |
Center |
Right |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


InfoLinkVerticalPosition Enumeration

[image]

conaito Office2Silverlight SDK Documentation
InfoLinkVerticalPosition Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum InfoLinkVerticalPosition
Visual Basic
Public Enumeration InfoLinkVerticalPosition
Visual C++
public enum class InfoLinkVerticalPosition

Members

Member name | Description
Top |
Center |
Bottom |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


OfficeConverter Class

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter Class
Members See Also Send Feedback
conaito Office2Silverlight SDK
Class for generating the Silverlight XAP from the Office documents(PowerPoint, Word, Excel etc) and XPS

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class OfficeConverter : MarshalByRefObject
Visual Basic
Public Class OfficeConverter _
    Inherits MarshalByRefObject
Visual C++
public ref class OfficeConverter : public MarshalByRefObject

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Conaito.Office2Silverlight..::..OfficeConverter

See Also

OfficeConverter Members


OfficeConverter Members

[image] [image]

conaito Office2Silverlight SDK Documentation
OfficeConverter Members
OfficeConverter Class Constructors Methods Properties See Also Send Feedback
conaito Office2Silverlight SDK

The OfficeConverter type exposes the following members.

Constructors

 | Name | Description
Public method | OfficeConverter | Initializes a new instance of the OfficeConverter class.

Methods

 | Name | Description
Public method | ConvertToSilverlight | Converts Office document to silverlight.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the library version.
Public method | IsLicenseValid | Determines whether [is license valid].
Public method | OpenDocument | Opens the Office document.
Public method | SetLicenseKey | Sets the license key.

Properties

 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | Document | Gets the XPS document information.
Public property | ErrorMessage | Gets the error message.
Public property | ErrorReturned | Gets a value indicating whether [error returned].
Public property | Settings | Gets the converting settings.

See Also

OfficeConverter Class


OfficeConverter Constructor

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter Constructor
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Initializes a new instance of the OfficeConverter class.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OfficeConverter()
Visual Basic
Public Sub New
Visual C++
public:
OfficeConverter()

See Also

OfficeConverter Class


OfficeConverter Methods

[image] [image]

conaito Office2Silverlight SDK Documentation
OfficeConverter Methods
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK

The OfficeConverter type exposes the following members.

Methods

 | Name | Description
Public method | ConvertToSilverlight | Converts Office document to silverlight.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the library version.
Public method | IsLicenseValid | Determines whether [is license valid].
Public method | OpenDocument | Opens the Office document.
Public method | SetLicenseKey | Sets the license key.

See Also

OfficeConverter Class


ConvertToSilverlight Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..ConvertToSilverlight Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Converts Office document to silverlight.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ConvertToSilverlight(
    string xapDocumentPath
)
Visual Basic
Public Sub ConvertToSilverlight ( _
    xapDocumentPath As String _
)
Visual C++
public:
void ConvertToSilverlight(
    String^ xapDocumentPath
)

Parameters

xapDocumentPath
Type: System..::..String
The xap document path.

See Also

OfficeConverter Class


GetLicenseInfo Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..GetLicenseInfo Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the license info.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string GetLicenseInfo()
Visual Basic
Public Function GetLicenseInfo As String
Visual C++
public:
String^ GetLicenseInfo()

Return Value

See Also

OfficeConverter Class


GetVersion Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..GetVersion Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the library version.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string GetVersion()
Visual Basic
Public Function GetVersion As String
Visual C++
public:
String^ GetVersion()

Return Value

See Also

OfficeConverter Class


IsLicenseValid Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..IsLicenseValid Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Determines whether [is license valid].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsLicenseValid()
Visual Basic
Public Function IsLicenseValid As Boolean
Visual C++
public:
bool IsLicenseValid()

Return Value

true if [is license valid]; otherwise, false.

See Also

OfficeConverter Class


OpenDocument Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..OpenDocument Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Opens the Office document.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void OpenDocument(
    string officeFilePath
)
Visual Basic
Public Sub OpenDocument ( _
    officeFilePath As String _
)
Visual C++
public:
void OpenDocument(
    String^ officeFilePath
)

Parameters

officeFilePath
Type: System..::..String
The Office file path.

See Also

OfficeConverter Class


SetLicenseKey Method

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..SetLicenseKey Method
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Sets the license key.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetLicenseKey(
    string licenseKey
)
Visual Basic
Public Sub SetLicenseKey ( _
    licenseKey As String _
)
Visual C++
public:
void SetLicenseKey(
    String^ licenseKey
)

Parameters

licenseKey
Type: System..::..String
The license key.

See Also

OfficeConverter Class


OfficeConverter Properties

[image] [image]

conaito Office2Silverlight SDK Documentation
OfficeConverter Properties
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK

The OfficeConverter type exposes the following members.

Properties

 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | Document | Gets the XPS document information.
Public property | ErrorMessage | Gets the error message.
Public property | ErrorReturned | Gets a value indicating whether [error returned].
Public property | Settings | Gets the converting settings.

See Also

OfficeConverter Class


CustomLogo Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..CustomLogo Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the custom banner. Works only on FULL license mode.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Bitmap CustomLogo { get; set; }
Visual Basic
Public Property CustomLogo As Bitmap
    Get
    Set
Visual C++
public:
property Bitmap^ CustomLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Field Value

The custom banner.

See Also

OfficeConverter Class


CustomLogoURL Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..CustomLogoURL Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the custom logo URL.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string CustomLogoURL { get; set; }
Visual Basic
Public Property CustomLogoURL As String
    Get
    Set
Visual C++
public:
property String^ CustomLogoURL {
    String^ get ();
    void set (String^ value);
}

Field Value

The custom logo URL.

See Also

OfficeConverter Class


Document Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..Document Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the XPS document information.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OfficeDocument Document { get; private set; }
Visual Basic
Public Property Document As OfficeDocument
    Get
    Private Set
Visual C++
public:
property OfficeDocument^ Document {
    OfficeDocument^ get ();
    private: void set (OfficeDocument^ value);
}

Field Value

The document.

See Also

OfficeConverter Class


ErrorMessage Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..ErrorMessage Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the error message.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ErrorMessage { get; private set; }
Visual Basic
Public Property ErrorMessage As String
    Get
    Private Set
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The error message.

See Also

OfficeConverter Class


ErrorReturned Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..ErrorReturned Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets a value indicating whether [error returned].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ErrorReturned { get; private set; }
Visual Basic
Public Property ErrorReturned As Boolean
    Get
    Private Set
Visual C++
public:
property bool ErrorReturned {
    bool get ();
    private: void set (bool value);
}

Field Value

true if [error returned]; otherwise, false.

See Also

OfficeConverter Class


Settings Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeConverter..::..Settings Property
OfficeConverter Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the converting settings.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OutputSettings Settings { get; set; }
Visual Basic
Public Property Settings As OutputSettings
    Get
    Set
Visual C++
public:
property OutputSettings^ Settings {
    OutputSettings^ get ();
    void set (OutputSettings^ value);
}

Field Value

The settings.

See Also

OfficeConverter Class


OfficeDocument Class

[image]

conaito Office2Silverlight SDK Documentation
OfficeDocument Class
Members See Also Send Feedback
conaito Office2Silverlight SDK
OfficeDocument class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class OfficeDocument
Visual Basic
Public Class OfficeDocument
Visual C++
public ref class OfficeDocument

Inheritance Hierarchy

System..::..Object
Conaito.Office2Silverlight..::..OfficeDocument

See Also

OfficeDocument Members


OfficeDocument Members

[image] [image]

conaito Office2Silverlight SDK Documentation
OfficeDocument Members
OfficeDocument Class Properties See Also Send Feedback
conaito Office2Silverlight SDK

The OfficeDocument type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the Office document name.
Public property | Path | Gets the Office document full path.

See Also

OfficeDocument Class


OfficeDocument Properties

[image] [image]

conaito Office2Silverlight SDK Documentation
OfficeDocument Properties
OfficeDocument Class See Also Send Feedback
conaito Office2Silverlight SDK

The OfficeDocument type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the Office document name.
Public property | Path | Gets the Office document full path.

See Also

OfficeDocument Class


Name Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeDocument..::..Name Property
OfficeDocument Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the Office document name.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set
Visual C++
public:
property String^ Name {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

The name.

See Also

OfficeDocument Class


Path Property

[image]

conaito Office2Silverlight SDK Documentation
OfficeDocument..::..Path Property
OfficeDocument Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the Office document full path.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Path { get; internal set; }
Visual Basic
Public Property Path As String
    Get
    Friend Set
Visual C++
public:
property String^ Path {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

The path.

See Also

OfficeDocument Class


OutputSettings Class

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings Class
Members See Also Send Feedback
conaito Office2Silverlight SDK
Class for output settings

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class OutputSettings
Visual Basic
Public Class OutputSettings
Visual C++
public ref class OutputSettings

Inheritance Hierarchy

System..::..Object
Conaito.Office2Silverlight..::..OutputSettings

See Also

OutputSettings Members


OutputSettings Members

[image] [image]

conaito Office2Silverlight SDK Documentation
OutputSettings Members
OutputSettings Class Constructors Methods Properties See Also Send Feedback
conaito Office2Silverlight SDK

The OutputSettings type exposes the following members.

Constructors

 | Name | Description
Public method | OutputSettings | Initializes a new instance of the OutputSettings class.

Methods

 | Name | Description
Public method | SaveToString |

Properties

 | Name | Description
Public property | AllowOOBMode | Gets or sets a value indicating whether [allow OOB mode].
Public property | Appearance | Gets the output silverlight appearance settings(theme).
Public property | CreateOutputFolderIfNotExists | Gets or sets a value indicating whether [create output folder if not exists].
Public property | ExeWindowBorder | Gets or sets the exe window border style.
Public property | ExeWindowHeight | Gets or sets the height of the exe window.
Public property | ExeWindowTitle | Gets or sets the exe window title.
Public property | ExeWindowWidth | Gets or sets the width of the exe window.
Public property | GenerateEXE | Gets or sets a value indicating whether [generate EXE].
Public property | GenerateHTML | Gets or sets a value indicating whether [generate HTML].
Public property | GenerateThumbnail | Gets or sets a value indicating whether [generate thumbnail].
Public property | OOBName | Gets or sets the name of the OOB.
Public property | ShowFullscreenButton | Gets or sets a value indicating whether [show fullscreen button].
Public property | ShowInfoLink | Gets or sets a value indicating whether [show info link].
Public property | ShowSizeModePicker | Gets or sets a value indicating whether [show size mode picker].
Public property | ShowThumbnailsListOnStart | Gets or sets a value indicating whether [show thumbnails list on start].
Public property | ShowToolbar | Gets or sets a value indicating whether [show toolbar].
Public property | ThumbnailsStyle | Gets or sets the thumbnails style.
Public property | ViewMode | Gets or sets the view mode.

See Also

OutputSettings Class


OutputSettings Constructor

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings Constructor
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Initializes a new instance of the OutputSettings class.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OutputSettings()
Visual Basic
Public Sub New
Visual C++
public:
OutputSettings()

See Also

OutputSettings Class


OutputSettings Methods

[image] [image]

conaito Office2Silverlight SDK Documentation
OutputSettings Methods
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK

The OutputSettings type exposes the following members.

Methods

 | Name | Description
Public method | SaveToString |

See Also

OutputSettings Class


SaveToString Method

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..SaveToString Method
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string SaveToString()
Visual Basic
Public Function SaveToString As String
Visual C++
public:
String^ SaveToString()

See Also

OutputSettings Class


OutputSettings Properties

[image] [image]

conaito Office2Silverlight SDK Documentation
OutputSettings Properties
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK

The OutputSettings type exposes the following members.

Properties

 | Name | Description
Public property | AllowOOBMode | Gets or sets a value indicating whether [allow OOB mode].
Public property | Appearance | Gets the output silverlight appearance settings(theme).
Public property | CreateOutputFolderIfNotExists | Gets or sets a value indicating whether [create output folder if not exists].
Public property | ExeWindowBorder | Gets or sets the exe window border style.
Public property | ExeWindowHeight | Gets or sets the height of the exe window.
Public property | ExeWindowTitle | Gets or sets the exe window title.
Public property | ExeWindowWidth | Gets or sets the width of the exe window.
Public property | GenerateEXE | Gets or sets a value indicating whether [generate EXE].
Public property | GenerateHTML | Gets or sets a value indicating whether [generate HTML].
Public property | GenerateThumbnail | Gets or sets a value indicating whether [generate thumbnail].
Public property | OOBName | Gets or sets the name of the OOB.
Public property | ShowFullscreenButton | Gets or sets a value indicating whether [show fullscreen button].
Public property | ShowInfoLink | Gets or sets a value indicating whether [show info link].
Public property | ShowSizeModePicker | Gets or sets a value indicating whether [show size mode picker].
Public property | ShowThumbnailsListOnStart | Gets or sets a value indicating whether [show thumbnails list on start].
Public property | ShowToolbar | Gets or sets a value indicating whether [show toolbar].
Public property | ThumbnailsStyle | Gets or sets the thumbnails style.
Public property | ViewMode | Gets or sets the view mode.

See Also

OutputSettings Class


AllowOOBMode Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..AllowOOBMode Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [allow OOB mode].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool AllowOOBMode { get; set; }
Visual Basic
Public Property AllowOOBMode As Boolean
    Get
    Set
Visual C++
public:
property bool AllowOOBMode {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow OOB mode]; otherwise, false.

See Also

OutputSettings Class


Appearance Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..Appearance Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets the output silverlight appearance settings(theme).

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Appearance Appearance { get; set; }
Visual Basic
Public Property Appearance As Appearance
    Get
    Set
Visual C++
public:
property Appearance^ Appearance {
    Appearance^ get ();
    void set (Appearance^ value);
}

Field Value

The appearance.

See Also

OutputSettings Class


CreateOutputFolderIfNotExists Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..CreateOutputFolderIfNotExists Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [create output folder if not exists].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool CreateOutputFolderIfNotExists { get; set; }
Visual Basic
Public Property CreateOutputFolderIfNotExists As Boolean
    Get
    Set
Visual C++
public:
property bool CreateOutputFolderIfNotExists {
    bool get ();
    void set (bool value);
}

Field Value

true if [create output folder if not exists]; otherwise, false.

See Also

OutputSettings Class


ExeWindowBorder Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ExeWindowBorder Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the exe window border style.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ExeWindowBorderStyle ExeWindowBorder { get; set; }
Visual Basic
Public Property ExeWindowBorder As ExeWindowBorderStyle
    Get
    Set
Visual C++
public:
property ExeWindowBorderStyle ExeWindowBorder {
    ExeWindowBorderStyle get ();
    void set (ExeWindowBorderStyle value);
}

Field Value

The exe window border.

See Also

OutputSettings Class


ExeWindowHeight Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ExeWindowHeight Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the height of the exe window.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ExeWindowHeight { get; set; }
Visual Basic
Public Property ExeWindowHeight As Integer
    Get
    Set
Visual C++
public:
property int ExeWindowHeight {
    int get ();
    void set (int value);
}

Field Value

The height of the exe window.

See Also

OutputSettings Class


ExeWindowTitle Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ExeWindowTitle Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the exe window title.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string ExeWindowTitle { get; set; }
Visual Basic
Public Property ExeWindowTitle As String
    Get
    Set
Visual C++
public:
property String^ ExeWindowTitle {
    String^ get ();
    void set (String^ value);
}

Field Value

The exe window title.

See Also

OutputSettings Class


ExeWindowWidth Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ExeWindowWidth Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the width of the exe window.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int ExeWindowWidth { get; set; }
Visual Basic
Public Property ExeWindowWidth As Integer
    Get
    Set
Visual C++
public:
property int ExeWindowWidth {
    int get ();
    void set (int value);
}

Field Value

The width of the exe window.

See Also

OutputSettings Class


GenerateEXE Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..GenerateEXE Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [generate EXE].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool GenerateEXE { get; set; }
Visual Basic
Public Property GenerateEXE As Boolean
    Get
    Set
Visual C++
public:
property bool GenerateEXE {
    bool get ();
    void set (bool value);
}

Field Value

true if [generate EXE]; otherwise, false.

See Also

OutputSettings Class


GenerateHTML Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..GenerateHTML Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [generate HTML].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool GenerateHTML { get; set; }
Visual Basic
Public Property GenerateHTML As Boolean
    Get
    Set
Visual C++
public:
property bool GenerateHTML {
    bool get ();
    void set (bool value);
}

Field Value

true if [generate HTML]; otherwise, false.

See Also

OutputSettings Class


GenerateThumbnail Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..GenerateThumbnail Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [generate thumbnail].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool GenerateThumbnail { get; set; }
Visual Basic
Public Property GenerateThumbnail As Boolean
    Get
    Set
Visual C++
public:
property bool GenerateThumbnail {
    bool get ();
    void set (bool value);
}

Field Value

true if [generate thumbnail]; otherwise, false.

See Also

OutputSettings Class


OOBName Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..OOBName Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the name of the OOB.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string OOBName { get; set; }
Visual Basic
Public Property OOBName As String
    Get
    Set
Visual C++
public:
property String^ OOBName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the OOB.

See Also

OutputSettings Class


ShowFullscreenButton Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ShowFullscreenButton Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [show fullscreen button].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowFullscreenButton { get; set; }
Visual Basic
Public Property ShowFullscreenButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFullscreenButton {
    bool get ();
    void set (bool value);
}

Field Value

true if [show fullscreen button]; otherwise, false.

See Also

OutputSettings Class


ShowInfoLink Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ShowInfoLink Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [show info link].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowInfoLink { get; set; }
Visual Basic
Public Property ShowInfoLink As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInfoLink {
    bool get ();
    void set (bool value);
}

Field Value

true if [show info link]; otherwise, false.

See Also

OutputSettings Class


ShowSizeModePicker Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ShowSizeModePicker Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [show size mode picker].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowSizeModePicker { get; set; }
Visual Basic
Public Property ShowSizeModePicker As Boolean
    Get
    Set
Visual C++
public:
property bool ShowSizeModePicker {
    bool get ();
    void set (bool value);
}

Field Value

true if [show size mode picker]; otherwise, false.

See Also

OutputSettings Class


ShowThumbnailsListOnStart Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ShowThumbnailsListOnStart Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [show thumbnails list on start].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowThumbnailsListOnStart { get; set; }
Visual Basic
Public Property ShowThumbnailsListOnStart As Boolean
    Get
    Set
Visual C++
public:
property bool ShowThumbnailsListOnStart {
    bool get ();
    void set (bool value);
}

Field Value

true if [show thumbnails list on start]; otherwise, false.

See Also

OutputSettings Class


ShowToolbar Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ShowToolbar Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets a value indicating whether [show toolbar].

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowToolbar { get; set; }
Visual Basic
Public Property ShowToolbar As Boolean
    Get
    Set
Visual C++
public:
property bool ShowToolbar {
    bool get ();
    void set (bool value);
}

Field Value

true if [show toolbar]; otherwise, false.

See Also

OutputSettings Class


ThumbnailsStyle Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ThumbnailsStyle Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the thumbnails style.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ThumbnailsStyle ThumbnailsStyle { get; set; }
Visual Basic
Public Property ThumbnailsStyle As ThumbnailsStyle
    Get
    Set
Visual C++
public:
property ThumbnailsStyle ThumbnailsStyle {
    ThumbnailsStyle get ();
    void set (ThumbnailsStyle value);
}

Field Value

The thumbnails style.

See Also

OutputSettings Class


ViewMode Property

[image]

conaito Office2Silverlight SDK Documentation
OutputSettings..::..ViewMode Property
OutputSettings Class See Also Send Feedback
conaito Office2Silverlight SDK
Gets or sets the view mode.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic
Public Property ViewMode As ViewMode
    Get
    Set
Visual C++
public:
property ViewMode ViewMode {
    ViewMode get ();
    void set (ViewMode value);
}

Field Value

The view mode.

See Also

OutputSettings Class


ThumbnailsPosition Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ThumbnailsPosition Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Thumbnails class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ThumbnailsPosition
Visual Basic
Public Enumeration ThumbnailsPosition
Visual C++
public enum class ThumbnailsPosition

Members

Member name | Description
Left |
Right |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


ThumbnailsStyle Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ThumbnailsStyle Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Enumeration of thumbnails style

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ThumbnailsStyle
Visual Basic
Public Enumeration ThumbnailsStyle
Visual C++
public enum class ThumbnailsStyle

Members

Member name | Description
Gallery |
List |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


ToolbarHorizontalAlignment Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ToolbarHorizontalAlignment Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Indicates where an element should be displayed on the horizontal axis relative to the allocated layout slot of the parent element.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ToolbarHorizontalAlignment
Visual Basic
Public Enumeration ToolbarHorizontalAlignment
Visual C++
public enum class ToolbarHorizontalAlignment

Members

Member name | Description
Left |
Center |
Right |
Stretch |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


ToolbarPosition Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ToolbarPosition Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
ToolbarPosition class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ToolbarPosition
Visual Basic
Public Enumeration ToolbarPosition
Visual C++
public enum class ToolbarPosition

Members

Member name | Description
Top |
Bottom |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


ToolbarVerticalAlignment Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ToolbarVerticalAlignment Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Describes how a child element is vertically positioned or stretched within a parent's layout slot.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ToolbarVerticalAlignment
Visual Basic
Public Enumeration ToolbarVerticalAlignment
Visual C++
public enum class ToolbarVerticalAlignment

Members

Member name | Description
Top |
Center |
Bottom |
Stretch |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies


Utils Class

[image]

conaito Office2Silverlight SDK Documentation
Utils Class
Members See Also Send Feedback
conaito Office2Silverlight SDK
Utils class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Utils
Visual Basic
Public Class Utils
Visual C++
public ref class Utils

Inheritance Hierarchy

System..::..Object
Conaito.Office2Silverlight..::..Utils

See Also

Utils Members


Utils Members

[image] [image]

conaito Office2Silverlight SDK Documentation
Utils Members
Utils Class Constructors Methods See Also Send Feedback
conaito Office2Silverlight SDK

The Utils type exposes the following members.

Constructors

 | Name | Description
Public method | Utils | Initializes a new instance of the Utils class

Methods

Name | Description
Base64ToImage | Base64 to image.
ColorFromHex | Get color from hex(use for appearance.BeckgroundColor etc.).
ColorToHex | Get hex from color(use for appearance.BeckgroundColor etc.).
ImageToBase64 | Images to base64.

See Also

Utils Class


Utils Constructor

[image]

conaito Office2Silverlight SDK Documentation
Utils Constructor
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK
Initializes a new instance of the Utils class

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Utils()
Visual Basic
Public Sub New
Visual C++
public:
Utils()

See Also

Utils Class


Utils Methods

[image] [image]

conaito Office2Silverlight SDK Documentation
Utils Methods
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK

The Utils type exposes the following members.

Methods

Name | Description
Base64ToImage | Base64 to image.
ColorFromHex | Get color from hex(use for appearance.BeckgroundColor etc.).
ColorToHex | Get hex from color(use for appearance.BeckgroundColor etc.).
ImageToBase64 | Images to base64.

See Also

Utils Class


Base64ToImage Method

[image]

conaito Office2Silverlight SDK Documentation
Utils..::..Base64ToImage Method
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK
Base64 to image.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Image Base64ToImage(
    string base64String
)
Visual Basic
Public Shared Function Base64ToImage ( _
    base64String As String _
) As Image
Visual C++
public:
static Image^ Base64ToImage(
    String^ base64String
)

Parameters

base64String
Type: System..::..String
The base64 string.

Return Value

See Also

Utils Class


ColorFromHex Method

[image]

conaito Office2Silverlight SDK Documentation
Utils..::..ColorFromHex Method
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK
Get color from hex(use for appearance.BeckgroundColor etc.).

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Color ColorFromHex(
    string hexColor
)
Visual Basic
Public Shared Function ColorFromHex ( _
    hexColor As String _
) As Color
Visual C++
public:
static Color ColorFromHex(
    String^ hexColor
)

Parameters

hexColor
Type: System..::..String
Color of the hex.

Return Value

See Also

Utils Class


ColorToHex Method

[image]

conaito Office2Silverlight SDK Documentation
Utils..::..ColorToHex Method
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK
Get hex from color(use for appearance.BeckgroundColor etc.).

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static string ColorToHex(
    Color color
)
Visual Basic
Public Shared Function ColorToHex ( _
    color As Color _
) As String
Visual C++
public:
static String^ ColorToHex(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
The color.

Return Value

See Also

Utils Class


ImageToBase64 Method

[image]

conaito Office2Silverlight SDK Documentation
Utils..::..ImageToBase64 Method
Utils Class See Also Send Feedback
conaito Office2Silverlight SDK
Images to base64.

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static string ImageToBase64(
    Image image
)
Visual Basic
Public Shared Function ImageToBase64 ( _
    image As Image _
) As String
Visual C++
public:
static String^ ImageToBase64(
    Image^ image
)

Parameters

image
Type: System.Drawing..::..Image
The image.

Return Value

See Also

Utils Class


ViewMode Enumeration

[image]

conaito Office2Silverlight SDK Documentation
ViewMode Enumeration
See Also Send Feedback
conaito Office2Silverlight SDK
Enumeration of output view modes

Namespace: Conaito.Office2Silverlight
Assembly: office2silverlight (in office2silverlight.exe) Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ViewMode
Visual Basic
Public Enumeration ViewMode
Visual C++
public enum class ViewMode

Members

Member name | Description
Scroll |
Book |
Slideshow |

See Also

Conaito.Office2Silverlight Namespace
conaito Office2Silverlight SDK

Send comments on this topic to contact conaito Support

© 2011 conaito Technologies