Conaito.Flipdoo Namespace

[image]

Flipdoo SDK Documentation
Conaito.Flipdoo Namespace
Send Feedback
Flipdoo SDK
Conaito Flipdoo SDK

Classes

 | Class | Description
Public class | FlipdooPublisher | Class for generating the Flash with ready-to-use player from PDF documents
Public class | PDFDocument | PDFDocument class
Public class | Settings | Settings class

Delegates

 | Delegate | Description
Public delegate | ConvertingFinishedEventHandler | Converting Finished Event Handler
Public delegate | ConvertingProgressChangedEventHandler | Converting Progress Changed Event Handler

Enumerations

 | Enumeration | Description
Public enumeration | OutputType | Enumeration of output type
Flipdoo SDK

Send comments on this topic to Flipdoo Support

Flipdoo SDK


ConvertingFinishedEventHandler Delegate

[image]

Flipdoo SDK Documentation
ConvertingFinishedEventHandler Delegate
See Also Send Feedback
Flipdoo SDK
Converting Finished Event Handler

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void ConvertingFinishedEventHandler()
Visual Basic
Public Delegate Sub ConvertingFinishedEventHandler
Visual C++
public delegate void ConvertingFinishedEventHandler()

See Also

Conaito.Flipdoo Namespace


ConvertingProgressChangedEventHandler Delegate

[image]

Flipdoo SDK Documentation
ConvertingProgressChangedEventHandler Delegate
See Also Send Feedback
Flipdoo SDK
Converting Progress Changed Event Handler

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public delegate void ConvertingProgressChangedEventHandler(
    int currenItem,
    int totalItems
)
Visual Basic
Public Delegate Sub ConvertingProgressChangedEventHandler ( _
    currenItem As Integer, _
    totalItems As Integer _
)
Visual C++
public delegate void ConvertingProgressChangedEventHandler(
    int currenItem,
    int totalItems
)

Parameters

currenItem
Type: System..::..Int32
totalItems
Type: System..::..Int32

See Also

Conaito.Flipdoo Namespace
Flipdoo SDK

Send comments on this topic to Flipdoo Support

Flipdoo SDK


FlipdooPublisher Class

[image]

Flipdoo SDK Documentation
FlipdooPublisher Class
Members See Also Send Feedback
Flipdoo SDK
Class for generating the Flash with ready-to-use player from PDF documents

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FlipdooPublisher : MarshalByRefObject
Visual Basic
Public Class FlipdooPublisher _
    Inherits MarshalByRefObject
Visual C++
public ref class FlipdooPublisher : public MarshalByRefObject

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Conaito.Flipdoo..::..FlipdooPublisher

See Also

FlipdooPublisher Members


FlipdooPublisher Members

[image] [image]

Flipdoo SDK Documentation
FlipdooPublisher Members
FlipdooPublisher Class Constructors Methods Properties Events See Also Send Feedback
Flipdoo SDK

The FlipdooPublisher type exposes the following members.

Constructors

 | Name | Description
Public method | FlipdooPublisher | Initializes a new instance of the FlipdooPublisher class.

Methods

 | Name | Description
Public method | ConvertToFlash | Converts to flash.
Public method | ConvertToFlashAsync | Converts to flash async.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the library version.
Public method | IsLicenseValid | Determines whether [is license valid].
Protected method | OnConvertingConvertingFinished |
Protected method | OnConvertingProgressChanged |
Public method | OpenPDFDocument | Opens the PDF document.
Public method | SetLicenseKey | Sets the license key.
Public method | Stop | Stops converting.

Properties

 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | Document | Gets the XPS document information.
Public property | ErrorMessage | Gets the error message.
Public property | ErrorReturned | Gets a value indicating whether [error returned].
Public property | Settings | Output settings.
Public property | Stopped | Gets value indicating whether converting was stopped.

Events

 | Name | Description
Public event | ConvertingFinished | Occurs when [converting finished].
Public event | ConvertingProgressChanged | Occurs when [converting progress changed].

See Also

FlipdooPublisher Class


FlipdooPublisher Constructor

[image]

Flipdoo SDK Documentation
FlipdooPublisher Constructor
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Initializes a new instance of the FlipdooPublisher class.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FlipdooPublisher()
Visual Basic
Public Sub New
Visual C++
public:
FlipdooPublisher()

See Also

FlipdooPublisher Class


FlipdooPublisher Methods

[image] [image]

Flipdoo SDK Documentation
FlipdooPublisher Methods
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK

The FlipdooPublisher type exposes the following members.

Methods

 | Name | Description
Public method | ConvertToFlash | Converts to flash.
Public method | ConvertToFlashAsync | Converts to flash async.
Public method | GetLicenseInfo | Gets the license info.
Public method | GetVersion | Gets the library version.
Public method | IsLicenseValid | Determines whether [is license valid].
Protected method | OnConvertingConvertingFinished |
Protected method | OnConvertingProgressChanged |
Public method | OpenPDFDocument | Opens the PDF document.
Public method | SetLicenseKey | Sets the license key.
Public method | Stop | Stops converting.

See Also

FlipdooPublisher Class


ConvertToFlash Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ConvertToFlash Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Converts to flash.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ConvertToFlash(
    string outputDirectory
)
Visual Basic
Public Sub ConvertToFlash ( _
    outputDirectory As String _
)
Visual C++
public:
void ConvertToFlash(
    String^ outputDirectory
)

Parameters

outputDirectory
Type: System..::..String
The output directory.

See Also

FlipdooPublisher Class


ConvertToFlashAsync Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ConvertToFlashAsync Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Converts to flash async.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ConvertToFlashAsync(
    string outputDirectory
)
Visual Basic
Public Sub ConvertToFlashAsync ( _
    outputDirectory As String _
)
Visual C++
public:
void ConvertToFlashAsync(
    String^ outputDirectory
)

Parameters

outputDirectory
Type: System..::..String
The output directory.

See Also

FlipdooPublisher Class


GetLicenseInfo Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..GetLicenseInfo Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets the license info.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetLicenseInfo()
Visual Basic
Public Function GetLicenseInfo As String
Visual C++
public:
String^ GetLicenseInfo()

Return Value

See Also

FlipdooPublisher Class


GetVersion Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..GetVersion Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets the library version.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetVersion()
Visual Basic
Public Function GetVersion As String
Visual C++
public:
String^ GetVersion()

Return Value

See Also

FlipdooPublisher Class


IsLicenseValid Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..IsLicenseValid Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Determines whether [is license valid].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLicenseValid()
Visual Basic
Public Function IsLicenseValid As Boolean
Visual C++
public:
bool IsLicenseValid()

Return Value

true if [is license valid]; otherwise, false.

See Also

FlipdooPublisher Class


OnConvertingConvertingFinished Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..OnConvertingConvertingFinished Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnConvertingConvertingFinished()
Visual Basic
Protected Overridable Sub OnConvertingConvertingFinished
Visual C++
protected:
virtual void OnConvertingConvertingFinished()

See Also

FlipdooPublisher Class


OnConvertingProgressChanged Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..OnConvertingProgressChanged Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnConvertingProgressChanged(
    int currenItem,
    int totalItems
)
Visual Basic
Protected Overridable Sub OnConvertingProgressChanged ( _
    currenItem As Integer, _
    totalItems As Integer _
)
Visual C++
protected:
virtual void OnConvertingProgressChanged(
    int currenItem,
    int totalItems
)

Parameters

currenItem
Type: System..::..Int32
totalItems
Type: System..::..Int32

See Also

FlipdooPublisher Class


OpenPDFDocument Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..OpenPDFDocument Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Opens the PDF document.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void OpenPDFDocument(
    string pdfFilePath
)
Visual Basic
Public Sub OpenPDFDocument ( _
    pdfFilePath As String _
)
Visual C++
public:
void OpenPDFDocument(
    String^ pdfFilePath
)

Parameters

pdfFilePath
Type: System..::..String
The PDF file path.

See Also

FlipdooPublisher Class


SetLicenseKey Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..SetLicenseKey Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Sets the license key.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetLicenseKey(
    string licenseKey
)
Visual Basic
Public Sub SetLicenseKey ( _
    licenseKey As String _
)
Visual C++
public:
void SetLicenseKey(
    String^ licenseKey
)

Parameters

licenseKey
Type: System..::..String
The license key.

See Also

FlipdooPublisher Class


Stop Method

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..Stop Method
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Stops converting.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

FlipdooPublisher Class


FlipdooPublisher Properties

[image] [image]

Flipdoo SDK Documentation
FlipdooPublisher Properties
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK

The FlipdooPublisher type exposes the following members.

Properties

 | Name | Description
Public property | CustomLogo | Gets or sets the custom banner. Works only on FULL license mode.
Public property | CustomLogoURL | Gets or sets the custom logo URL.
Public property | Document | Gets the XPS document information.
Public property | ErrorMessage | Gets the error message.
Public property | ErrorReturned | Gets a value indicating whether [error returned].
Public property | Settings | Output settings.
Public property | Stopped | Gets value indicating whether converting was stopped.

See Also

FlipdooPublisher Class


CustomLogo Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..CustomLogo Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets or sets the custom banner. Works only on FULL license mode.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bitmap CustomLogo { get; set; }
Visual Basic
Public Property CustomLogo As Bitmap
    Get
    Set
Visual C++
public:
property Bitmap^ CustomLogo {
    Bitmap^ get ();
    void set (Bitmap^ value);
}

Field Value

The custom banner.

See Also

FlipdooPublisher Class


CustomLogoURL Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..CustomLogoURL Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets or sets the custom logo URL.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CustomLogoURL { get; set; }
Visual Basic
Public Property CustomLogoURL As String
    Get
    Set
Visual C++
public:
property String^ CustomLogoURL {
    String^ get ();
    void set (String^ value);
}

Field Value

The custom logo URL.

See Also

FlipdooPublisher Class


Document Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..Document Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets the XPS document information.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PDFDocument Document { get; private set; }
Visual Basic
Public Property Document As PDFDocument
    Get
    Private Set
Visual C++
public:
property PDFDocument^ Document {
    PDFDocument^ get ();
    private: void set (PDFDocument^ value);
}

Field Value

The document.

See Also

FlipdooPublisher Class


ErrorMessage Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ErrorMessage Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets the error message.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ErrorMessage { get; private set; }
Visual Basic
Public Property ErrorMessage As String
    Get
    Private Set
Visual C++
public:
property String^ ErrorMessage {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The error message.

See Also

FlipdooPublisher Class


ErrorReturned Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ErrorReturned Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets a value indicating whether [error returned].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ErrorReturned { get; private set; }
Visual Basic
Public Property ErrorReturned As Boolean
    Get
    Private Set
Visual C++
public:
property bool ErrorReturned {
    bool get ();
    private: void set (bool value);
}

Field Value

true if [error returned]; otherwise, false.

See Also

FlipdooPublisher Class


Settings Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..Settings Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Output settings.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Settings Settings { get; set; }
Visual Basic
Public Property Settings As Settings
    Get
    Set
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
    void set (Settings^ value);
}

Field Value

The settings.

See Also

FlipdooPublisher Class


Stopped Property

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..Stopped Property
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Gets value indicating whether converting was stopped.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Stopped { get; private set; }
Visual Basic
Public Property Stopped As Boolean
    Get
    Private Set
Visual C++
public:
property bool Stopped {
    bool get ();
    private: void set (bool value);
}

Field Value

true if stopped; otherwise, false.

See Also

FlipdooPublisher Class


FlipdooPublisher Events

[image] [image]

Flipdoo SDK Documentation
FlipdooPublisher Events
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK

The FlipdooPublisher type exposes the following members.

Events

 | Name | Description
Public event | ConvertingFinished | Occurs when [converting finished].
Public event | ConvertingProgressChanged | Occurs when [converting progress changed].

See Also

FlipdooPublisher Class


ConvertingFinished Event

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ConvertingFinished Event
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Occurs when [converting finished].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event ConvertingFinishedEventHandler ConvertingFinished
Visual Basic
Public Event ConvertingFinished As ConvertingFinishedEventHandler
Visual C++
public:
 event ConvertingFinishedEventHandler^ ConvertingFinished {
    void add (ConvertingFinishedEventHandler^ value);
    void remove (ConvertingFinishedEventHandler^ value);
}

See Also

FlipdooPublisher Class


ConvertingProgressChanged Event

[image]

Flipdoo SDK Documentation
FlipdooPublisher..::..ConvertingProgressChanged Event
FlipdooPublisher Class See Also Send Feedback
Flipdoo SDK
Occurs when [converting progress changed].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event ConvertingProgressChangedEventHandler ConvertingProgressChanged
Visual Basic
Public Event ConvertingProgressChanged As ConvertingProgressChangedEventHandler
Visual C++
public:
 event ConvertingProgressChangedEventHandler^ ConvertingProgressChanged {
    void add (ConvertingProgressChangedEventHandler^ value);
    void remove (ConvertingProgressChangedEventHandler^ value);
}

See Also

FlipdooPublisher Class


OutputType Enumeration

[image]

Flipdoo SDK Documentation
OutputType Enumeration
See Also Send Feedback
Flipdoo SDK
Enumeration of output type

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public enum OutputType
Visual Basic
<SerializableAttribute> _
Public Enumeration OutputType
Visual C++
[SerializableAttribute]
public enum class OutputType

Members

Member name | Description
Web |
Windows |
WindowsKiosk |
MAC |

See Also

Conaito.Flipdoo Namespace
Flipdoo SDK

Send comments on this topic to Flipdoo Support

Flipdoo SDK


PDFDocument Class

[image]

Flipdoo SDK Documentation
PDFDocument Class
Members See Also Send Feedback
Flipdoo SDK
PDFDocument class

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PDFDocument
Visual Basic
Public Class PDFDocument
Visual C++
public ref class PDFDocument

Inheritance Hierarchy

System..::..Object
Conaito.Flipdoo..::..PDFDocument

See Also

PDFDocument Members


PDFDocument Members

[image] [image]

Flipdoo SDK Documentation
PDFDocument Members
PDFDocument Class Properties See Also Send Feedback
Flipdoo SDK

The PDFDocument type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets the height of PDF document.
Public property | Name | Gets the PDF document name.
Public property | Path | Gets the PDF document full path.
Public property | Width | Gets the width of PDF document.

See Also

PDFDocument Class


PDFDocument Properties

[image] [image]

Flipdoo SDK Documentation
PDFDocument Properties
PDFDocument Class See Also Send Feedback
Flipdoo SDK

The PDFDocument type exposes the following members.

Properties

 | Name | Description
Public property | Height | Gets the height of PDF document.
Public property | Name | Gets the PDF document name.
Public property | Path | Gets the PDF document full path.
Public property | Width | Gets the width of PDF document.

See Also

PDFDocument Class


Height Property

[image]

Flipdoo SDK Documentation
PDFDocument..::..Height Property
PDFDocument Class See Also Send Feedback
Flipdoo SDK
Gets the height of PDF document.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Height { get; internal set; }
Visual Basic
Public Property Height As Integer
    Get
    Friend Set
Visual C++
public:
property int Height {
    int get ();
    internal: void set (int value);
}

Field Value

The height.

See Also

PDFDocument Class


Name Property

[image]

Flipdoo SDK Documentation
PDFDocument..::..Name Property
PDFDocument Class See Also Send Feedback
Flipdoo SDK
Gets the PDF document name.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set
Visual C++
public:
property String^ Name {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

The name.

See Also

PDFDocument Class


Path Property

[image]

Flipdoo SDK Documentation
PDFDocument..::..Path Property
PDFDocument Class See Also Send Feedback
Flipdoo SDK
Gets the PDF document full path.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Path { get; internal set; }
Visual Basic
Public Property Path As String
    Get
    Friend Set
Visual C++
public:
property String^ Path {
    String^ get ();
    internal: void set (String^ value);
}

Field Value

The path.

See Also

PDFDocument Class


Width Property

[image]

Flipdoo SDK Documentation
PDFDocument..::..Width Property
PDFDocument Class See Also Send Feedback
Flipdoo SDK
Gets the width of PDF document.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Width { get; internal set; }
Visual Basic
Public Property Width As Integer
    Get
    Friend Set
Visual C++
public:
property int Width {
    int get ();
    internal: void set (int value);
}

Field Value

The width.

See Also

PDFDocument Class


Settings Class

[image]

Flipdoo SDK Documentation
Settings Class
Members See Also Send Feedback
Flipdoo SDK
Settings class

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class Settings : MarshalByRefObject
Visual Basic
<SerializableAttribute> _
Public Class Settings _
    Inherits MarshalByRefObject
Visual C++
[SerializableAttribute]
public ref class Settings : public MarshalByRefObject

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
Conaito.Flipdoo..::..Settings

See Also

Settings Members


Settings Members

[image] [image]

Flipdoo SDK Documentation
Settings Members
Settings Class Constructors Properties See Also Send Feedback
Flipdoo SDK

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings | Initializes a new instance of the Settings class.

Properties

 | Name | Description
Public property | AllowDownloading | Gets or sets a value indicating whether [allow downloading].
Public property | AllowPrinting | Gets or sets a value indicating whether [allow printing].
Public property | AllowSharing | Gets or sets a value indicating whether [allow sharing].
Public property | AutoPlayingTime | Gets or sets the auto playing time. (sec)
Public property | CustomLogoPath | Gets or sets the custom logo path.
Public property | EnableAutoPlaying | Gets or sets a value indicating whether [enable auto playing].
Public property | OutputType | Gets or sets the type of the output.
Public property | RenderFlipdooBackward | Gets or sets a value indicating whether [render flipdoo backward].
Public property | RenderPdfDocumentBackward | Gets or sets a value indicating whether [render PDF document backward].
Public property | Title | Gets or sets the title.

See Also

Settings Class


Settings Constructor

[image]

Flipdoo SDK Documentation
Settings Constructor
Settings Class See Also Send Feedback
Flipdoo SDK
Initializes a new instance of the Settings class.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Settings()
Visual Basic
Public Sub New
Visual C++
public:
Settings()

See Also

Settings Class


Settings Properties

[image] [image]

Flipdoo SDK Documentation
Settings Properties
Settings Class See Also Send Feedback
Flipdoo SDK

The Settings type exposes the following members.

Properties

 | Name | Description
Public property | AllowDownloading | Gets or sets a value indicating whether [allow downloading].
Public property | AllowPrinting | Gets or sets a value indicating whether [allow printing].
Public property | AllowSharing | Gets or sets a value indicating whether [allow sharing].
Public property | AutoPlayingTime | Gets or sets the auto playing time. (sec)
Public property | CustomLogoPath | Gets or sets the custom logo path.
Public property | EnableAutoPlaying | Gets or sets a value indicating whether [enable auto playing].
Public property | OutputType | Gets or sets the type of the output.
Public property | RenderFlipdooBackward | Gets or sets a value indicating whether [render flipdoo backward].
Public property | RenderPdfDocumentBackward | Gets or sets a value indicating whether [render PDF document backward].
Public property | Title | Gets or sets the title.

See Also

Settings Class


AllowDownloading Property

[image]

Flipdoo SDK Documentation
Settings..::..AllowDownloading Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [allow downloading].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowDownloading { get; set; }
Visual Basic
Public Property AllowDownloading As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDownloading {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow downloading]; otherwise, false.

See Also

Settings Class


AllowPrinting Property

[image]

Flipdoo SDK Documentation
Settings..::..AllowPrinting Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [allow printing].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowPrinting { get; set; }
Visual Basic
Public Property AllowPrinting As Boolean
    Get
    Set
Visual C++
public:
property bool AllowPrinting {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow printing]; otherwise, false.

See Also

Settings Class


AllowSharing Property

[image]

Flipdoo SDK Documentation
Settings..::..AllowSharing Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [allow sharing].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowSharing { get; set; }
Visual Basic
Public Property AllowSharing As Boolean
    Get
    Set
Visual C++
public:
property bool AllowSharing {
    bool get ();
    void set (bool value);
}

Field Value

true if [allow sharing]; otherwise, false.

See Also

Settings Class


AutoPlayingTime Property

[image]

Flipdoo SDK Documentation
Settings..::..AutoPlayingTime Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets the auto playing time. (sec)

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int AutoPlayingTime { get; set; }
Visual Basic
Public Property AutoPlayingTime As Integer
    Get
    Set
Visual C++
public:
property int AutoPlayingTime {
    int get ();
    void set (int value);
}

Field Value

The auto playing time.

See Also

Settings Class


CustomLogoPath Property

[image]

Flipdoo SDK Documentation
Settings..::..CustomLogoPath Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets the custom logo path.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CustomLogoPath { get; set; }
Visual Basic
Public Property CustomLogoPath As String
    Get
    Set
Visual C++
public:
property String^ CustomLogoPath {
    String^ get ();
    void set (String^ value);
}

Field Value

The custom logo path.

See Also

Settings Class


EnableAutoPlaying Property

[image]

Flipdoo SDK Documentation
Settings..::..EnableAutoPlaying Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [enable auto playing].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EnableAutoPlaying { get; set; }
Visual Basic
Public Property EnableAutoPlaying As Boolean
    Get
    Set
Visual C++
public:
property bool EnableAutoPlaying {
    bool get ();
    void set (bool value);
}

Field Value

true if [enable auto playing]; otherwise, false.

See Also

Settings Class


OutputType Property

[image]

Flipdoo SDK Documentation
Settings..::..OutputType Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets the type of the output.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OutputType OutputType { get; set; }
Visual Basic
Public Property OutputType As OutputType
    Get
    Set
Visual C++
public:
property OutputType OutputType {
    OutputType get ();
    void set (OutputType value);
}

Field Value

The type of the output.

See Also

Settings Class


RenderFlipdooBackward Property

[image]

Flipdoo SDK Documentation
Settings..::..RenderFlipdooBackward Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [render flipdoo backward].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RenderFlipdooBackward { get; set; }
Visual Basic
Public Property RenderFlipdooBackward As Boolean
    Get
    Set
Visual C++
public:
property bool RenderFlipdooBackward {
    bool get ();
    void set (bool value);
}

Field Value

true if [render flipdoo backward]; otherwise, false.

See Also

Settings Class


RenderPdfDocumentBackward Property

[image]

Flipdoo SDK Documentation
Settings..::..RenderPdfDocumentBackward Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets a value indicating whether [render PDF document backward].

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RenderPdfDocumentBackward { get; set; }
Visual Basic
Public Property RenderPdfDocumentBackward As Boolean
    Get
    Set
Visual C++
public:
property bool RenderPdfDocumentBackward {
    bool get ();
    void set (bool value);
}

Field Value

true if [render PDF document backward]; otherwise, false.

See Also

Settings Class


Title Property

[image]

Flipdoo SDK Documentation
Settings..::..Title Property
Settings Class See Also Send Feedback
Flipdoo SDK
Gets or sets the title.

Namespace: Conaito.Flipdoo
Assembly: flipdoo (in flipdoo.exe) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Field Value

The title.

See Also

Settings Class